summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-09-21 14:54:19 +0200
committerNicola Murino2018-09-21 14:54:19 +0200
commit85cf6881bd36198f10d26b336c72cca393625913 (patch)
tree3c01d75845f2ed47307e16f74c74eefa3b4575dd
parent1ff574961dede7b358f25746814c6b9d8b8ceaea (diff)
downloadaur-85cf6881bd36198f10d26b336c72cca393625913.tar.gz
remove -lgnulib from pc file
another difference from the autotools build is that pc file contains -lintl while now there is -lcharset, let's see if it breaks something else ...
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff02a76fd717..4c6aab391258 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-glib2
pkgdesc = Low level core library (mingw-w64)
pkgver = 2.58.0
- pkgrel = 3
+ pkgrel = 4
url = https://wiki.gnome.org/Projects/GLib
arch = any
license = LGPL2.1
diff --git a/PKGBUILD b/PKGBUILD
index 252669c7cd25..78668580ad75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Renato Silva <br.renatosilva@gmail.com>
pkgname=mingw-w64-glib2
pkgver=2.58.0
-pkgrel=3
+pkgrel=4
_commit=c138b98e363df8b95c2ee3eac214649b2908ad68 # tags/2.58.0^0
arch=(any)
pkgdesc="Low level core library (mingw-w64)"
@@ -56,10 +56,12 @@ build() {
package() {
for _arch in ${_architectures}; do
+ sed -i "s/-lgnulib//g" ${srcdir}/glib/build-${_arch}/meson-private/glib-2.0.pc
DESTDIR="${pkgdir}" ninja -C "${srcdir}/glib/build-${_arch}" install
#FIXME: Ranlib (isn't meson supposed to do this?)
${_arch}-gcc-ranlib ${pkgdir}/usr/${_arch}/lib/*.a
+
done
}