summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-10-12 03:39:47 -0700
committerSchala2016-10-12 03:39:47 -0700
commit9d93bc6a038603014fe26f865f0424d6260a4c94 (patch)
treeb1a10e7d59eaf466685471c1eaac1e69f40a5195
parent44ab2864f1a80916f71f00ed3f67c760ed18e79a (diff)
downloadaur-9d93bc6a038603014fe26f865f0424d6260a4c94.tar.gz
2.50.1
-rw-r--r--.SRCINFO12
-rw-r--r--0003-g_abort.all.patch253
-rw-r--r--PKGBUILD10
3 files changed, 8 insertions, 267 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2477f2ae2241..461902994cdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Aug 28 08:19:18 UTC 2016
+# Wed Oct 12 10:39:29 UTC 2016
pkgbase = mingw-w64-glib2
- pkgdesc = Common C routines used by GTK+ and other libs (mingw-w64)
- pkgver = 2.48.2
+ pkgdesc = Low level core library (mingw-w64)
+ pkgver = 2.50.1
pkgrel = 1
url = http://www.gtk.org/
arch = any
@@ -18,17 +18,15 @@ pkgbase = mingw-w64-glib2
options = !buildflags
options = staticlibs
options = !emptydirs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.48/glib-2.48.2.tar.xz
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.50/glib-2.50.1.tar.xz
source = 0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch
- source = 0003-g_abort.all.patch
source = 0004-glib-prefer-constructors-over-DllMain.patch
source = 0027-no_sys_if_nametoindex.patch
source = 0028-inode_directory.patch
source = revert-warn-glib-compile-schemas.patch
source = use-pkgconfig-file-for-intl.patch
- sha256sums = f25e751589cb1a58826eac24fbd4186cda4518af772806b666a3f91f66e6d3f4
+ sha256sums = 2ef87a78f37c1eb5b95f4cc95efd5b66f69afad9c9c0899918d04659cf6df7dd
sha256sums = ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3
- sha256sums = 1b24cc928f69f73599f83269a7b3eb7bf7efbe114109251e6765053a1e1f4cd6
sha256sums = 7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6
sha256sums = 5cb481295ff86c2802030984d8b2bf6a3b1dcd5e5fe7b0be68b22d9116305837
sha256sums = f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b
diff --git a/0003-g_abort.all.patch b/0003-g_abort.all.patch
deleted file mode 100644
index 7e286db3067b..000000000000
--- a/0003-g_abort.all.patch
+++ /dev/null
@@ -1,253 +0,0 @@
-diff -Naur glib-2.46.0-orig/glib/gbacktrace.c glib-2.46.0/glib/gbacktrace.c
---- glib-2.46.0-orig/glib/gbacktrace.c 2014-12-20 00:49:48.000000000 +0300
-+++ glib-2.46.0/glib/gbacktrace.c 2015-09-22 09:08:59.311126700 +0300
-@@ -254,7 +254,7 @@
- if (IsDebuggerPresent ())
- G_BREAKPOINT ();
- else
-- abort ();
-+ g_abort ();
- #endif
- }
-
-diff -Naur glib-2.46.0-orig/glib/giowin32.c glib-2.46.0/glib/giowin32.c
---- glib-2.46.0-orig/glib/giowin32.c 2014-12-20 00:49:48.000000000 +0300
-+++ glib-2.46.0/glib/giowin32.c 2015-09-22 09:08:59.357921600 +0300
-@@ -798,7 +798,7 @@
-
- default:
- g_assert_not_reached ();
-- abort ();
-+ g_abort ();
- }
- if (channel->debug)
- g_print ("\n");
-@@ -945,7 +945,7 @@
-
- default:
- g_assert_not_reached ();
-- abort ();
-+ g_abort ();
- }
- }
-
-@@ -1010,7 +1010,7 @@
-
- default:
- g_assert_not_reached ();
-- abort ();
-+ g_abort ();
- }
- if (channel->debug)
- g_print ("\n");
-@@ -1295,7 +1295,7 @@
- default:
- whence = -1; /* Keep the compiler quiet */
- g_assert_not_reached ();
-- abort ();
-+ g_abort ();
- }
-
- tmp_offset = offset;
-@@ -1690,7 +1690,7 @@
- break;
- default:
- g_assert_not_reached ();
-- abort ();
-+ g_abort ();
- }
-
- /* always open 'untranslated' */
-@@ -1736,7 +1736,7 @@
- break;
- default:
- g_assert_not_reached ();
-- abort ();
-+ g_abort ();
- }
-
- return channel;
-@@ -2225,7 +2225,7 @@
-
- default:
- g_assert_not_reached ();
-- abort ();
-+ g_abort ();
- }
-
- fd->events = condition;
-diff -Naur glib-2.46.0-orig/glib/gmessages.c glib-2.46.0/glib/gmessages.c
---- glib-2.46.0-orig/glib/gmessages.c 2015-09-21 06:33:23.000000000 +0300
-+++ glib-2.46.0/glib/gmessages.c 2015-09-22 09:08:59.373519900 +0300
-@@ -323,7 +323,7 @@
- if (breakpoint)
- G_BREAKPOINT ();
- else
-- abort ();
-+ g_abort ();
- }
-
- #ifdef G_OS_WIN32
-@@ -1176,7 +1176,7 @@
- line,
- pretty_function);
- _g_log_abort (FALSE);
-- abort ();
-+ g_abort ();
- }
-
- /**
-diff -Naur glib-2.46.0-orig/glib/gslice.c glib-2.46.0/glib/gslice.c
---- glib-2.46.0-orig/glib/gslice.c 2015-09-08 20:40:27.000000000 +0300
-+++ glib-2.46.0/glib/gslice.c 2015-09-22 09:08:59.404716500 +0300
-@@ -1082,7 +1082,7 @@
- return;
- if (G_UNLIKELY (allocator->config.debug_blocks) &&
- !smc_notify_free (mem_block, mem_size))
-- abort();
-+ g_abort();
- if (G_LIKELY (acat == 1)) /* allocate through magazine layer */
- {
- ThreadMemory *tmem = thread_memory_from_self();
-@@ -1165,7 +1165,7 @@
- slice = *(gpointer*) (current + next_offset);
- if (G_UNLIKELY (allocator->config.debug_blocks) &&
- !smc_notify_free (current, mem_size))
-- abort();
-+ g_abort();
- if (G_UNLIKELY (thread_memory_magazine2_is_full (tmem, ix)))
- {
- thread_memory_swap_magazines (tmem, ix);
-@@ -1186,7 +1186,7 @@
- slice = *(gpointer*) (current + next_offset);
- if (G_UNLIKELY (allocator->config.debug_blocks) &&
- !smc_notify_free (current, mem_size))
-- abort();
-+ g_abort();
- if (G_UNLIKELY (g_mem_gc_friendly))
- memset (current, 0, chunk_size);
- slab_allocator_free_chunk (chunk_size, current);
-@@ -1200,7 +1200,7 @@
- slice = *(gpointer*) (current + next_offset);
- if (G_UNLIKELY (allocator->config.debug_blocks) &&
- !smc_notify_free (current, mem_size))
-- abort();
-+ g_abort();
- if (G_UNLIKELY (g_mem_gc_friendly))
- memset (current, 0, mem_size);
- g_free (current);
-@@ -1436,7 +1436,7 @@
- vfprintf (stderr, format, args);
- va_end (args);
- fputs ("\n", stderr);
-- abort();
-+ g_abort();
- _exit (1);
- }
-
-diff -Naur glib-2.46.0-orig/glib/gtester.c glib-2.46.0/glib/gtester.c
---- glib-2.46.0-orig/glib/gtester.c 2014-12-20 00:49:48.000000000 +0300
-+++ glib-2.46.0/glib/gtester.c 2015-09-22 09:08:59.420314800 +0300
-@@ -94,7 +94,7 @@
- terminate (void)
- {
- kill (getpid(), SIGTERM);
-- abort();
-+ g_abort();
- }
-
- static void
-diff -Naur glib-2.46.0-orig/glib/gtestutils.c glib-2.46.0/glib/gtestutils.c
---- glib-2.46.0-orig/glib/gtestutils.c 2015-09-01 06:34:13.000000000 +0300
-+++ glib-2.46.0/glib/gtestutils.c 2015-09-22 09:08:59.576297800 +0300
-@@ -846,7 +846,7 @@
- {
- if (test_tap_log)
- g_print ("Bail out!\n");
-- abort();
-+ g_abort();
- }
- if (result == G_TEST_RUN_SKIPPED)
- test_skipped_count++;
-@@ -2426,7 +2426,7 @@
- _exit (1);
- }
- else
-- abort ();
-+ g_abort ();
- }
-
- void
-@@ -2451,7 +2451,7 @@
- if (test_in_subprocess)
- _exit (1);
- else
-- abort ();
-+ g_abort ();
- }
-
- void
-diff -Naur glib-2.46.0-orig/glib/gthread-posix.c glib-2.46.0/glib/gthread-posix.c
---- glib-2.46.0-orig/glib/gthread-posix.c 2015-08-19 06:35:30.000000000 +0300
-+++ glib-2.46.0/glib/gthread-posix.c 2015-09-22 09:08:59.560699500 +0300
-@@ -46,6 +46,7 @@
- #include "gmessages.h"
- #include "gstrfuncs.h"
- #include "gmain.h"
-+#include "gutils.h"
-
- #include <stdlib.h>
- #include <stdio.h>
-@@ -77,7 +78,7 @@
- {
- fprintf (stderr, "GLib (gthread-posix.c): Unexpected error from C library during '%s': %s. Aborting.\n",
- function, strerror (status));
-- abort ();
-+ g_abort ();
- }
-
- /* {{{1 GMutex */
-diff -Naur glib-2.46.0-orig/glib/gthread-win32.c glib-2.46.0/glib/gthread-win32.c
---- glib-2.46.0-orig/glib/gthread-win32.c 2014-12-20 00:49:48.000000000 +0300
-+++ glib-2.46.0/glib/gthread-win32.c 2015-09-22 09:08:59.467109700 +0300
-@@ -58,7 +58,7 @@
- {
- fprintf (stderr, "GLib (gthread-win32.c): Unexpected error from C library during '%s': %s. Aborting.\n",
- strerror (status), function);
-- abort ();
-+ g_abort ();
- }
-
- /* Starting with Vista and Windows 2008, we have access to the
-diff -Naur glib-2.46.0-orig/glib/gutils.c glib-2.46.0/glib/gutils.c
---- glib-2.46.0-orig/glib/gutils.c 2015-08-28 21:15:54.000000000 +0300
-+++ glib-2.46.0/glib/gutils.c 2015-09-22 09:08:59.498306300 +0300
-@@ -2375,3 +2375,15 @@
- return FALSE;
- #endif
- }
-+
-+/* Crashes the program. */
-+void
-+g_abort (void)
-+{
-+#ifdef G_OS_WIN32
-+ DebugBreak ();
-+ ExitProcess (127);
-+#else
-+ abort ();
-+#endif
-+}
-diff -Naur glib-2.46.0-orig/glib/gutils.h glib-2.46.0/glib/gutils.h
---- glib-2.46.0-orig/glib/gutils.h 2015-08-21 03:20:48.000000000 +0300
-+++ glib-2.46.0/glib/gutils.h 2015-09-22 09:08:59.529502900 +0300
-@@ -228,6 +228,9 @@
- GLIB_DEPRECATED_FOR(g_format_size)
- gchar *g_format_size_for_display (goffset size);
-
-+GLIB_AVAILABLE_IN_2_30
-+void g_abort (void);
-+
- #ifndef G_DISABLE_DEPRECATED
- /**
- * GVoidFunc:
diff --git a/PKGBUILD b/PKGBUILD
index dbe6422e5e83..1cd9ba325da4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Renato Silva <br.renatosilva@gmail.com>
pkgname=mingw-w64-glib2
-pkgver=2.48.2
+pkgver=2.50.1
pkgrel=1
arch=(any)
-pkgdesc="Common C routines used by GTK+ and other libs (mingw-w64)"
+pkgdesc="Low level core library (mingw-w64)"
depends=(mingw-w64-gettext mingw-w64-zlib mingw-w64-libffi mingw-w64-pcre mingw-w64-freetype2)
makedepends=(mingw-w64-configure python)
license=("LGPL")
@@ -13,15 +13,13 @@ options=(!strip !buildflags staticlibs !emptydirs)
url="http://www.gtk.org/"
source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz"
"0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
-"0003-g_abort.all.patch"
"0004-glib-prefer-constructors-over-DllMain.patch"
"0027-no_sys_if_nametoindex.patch"
"0028-inode_directory.patch"
"revert-warn-glib-compile-schemas.patch"
"use-pkgconfig-file-for-intl.patch")
-sha256sums=('f25e751589cb1a58826eac24fbd4186cda4518af772806b666a3f91f66e6d3f4'
+sha256sums=('2ef87a78f37c1eb5b95f4cc95efd5b66f69afad9c9c0899918d04659cf6df7dd'
'ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3'
- '1b24cc928f69f73599f83269a7b3eb7bf7efbe114109251e6765053a1e1f4cd6'
'7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6'
'5cb481295ff86c2802030984d8b2bf6a3b1dcd5e5fe7b0be68b22d9116305837'
'f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b'
@@ -33,7 +31,6 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd glib-$pkgver
patch -Np1 -i .."/0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
- patch -Np1 -i .."/0003-g_abort.all.patch"
patch -Np1 -i ../0004-glib-prefer-constructors-over-DllMain.patch
patch -Np1 -i ../"0027-no_sys_if_nametoindex.patch"
patch -Np1 -i ../"0028-inode_directory.patch"
@@ -70,7 +67,6 @@ package() {
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- rm "$pkgdir/usr/${_arch}/bin/"{glib-{gettextize,mkenums},gdbus-codegen}
rm -r "$pkgdir/usr/${_arch}/lib/charset.alias"
rm -r "$pkgdir/static"
done