summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-08-02 20:13:25 -0700
committerBuildTools2015-08-02 20:13:25 -0700
commita1c3eac3e0c750bab6b113b2d022a635f2dc8b42 (patch)
tree56e14e7954efee6edacb9b786585f76345c5cffd
parent028dd3b3f78a124ef5e848c17f6d8758f9571f5b (diff)
downloadaur-a1c3eac3e0c750bab6b113b2d022a635f2dc8b42.tar.gz
update patches from Alexpux's github
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--0027-no_sys_if_nametoindex.patch24
-rw-r--r--0029-grand.all.patch12
-rw-r--r--PKGBUILD11
5 files changed, 42 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 604adcd83064..3fe6101b2e88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-glib2
pkgdesc = Common C routines used by GTK+ and other libs (mingw-w64)
pkgver = 2.44.1
- pkgrel = 2
+ pkgrel = 3
url = http://www.gtk.org/
arch = any
license = LGPL
@@ -26,6 +26,7 @@ pkgbase = mingw-w64-glib2
source = 0024-return-actually-written-data-in-printf.all.patch
source = 0027-no_sys_if_nametoindex.patch
source = 0028-inode_directory.patch
+ source = 0029-grand.all.patch
sha256sums = 8811deacaf8a503d0a9b701777ea079ca6a4277be10e3d730d2112735d5eca07
sha256sums = 1420d8a8cadef2d33d748b31e5ae9c385aee1351d267dabf7a6a68fed6dfe7db
sha256sums = 5551461a90386837356d2b56d4011e5272ba1d3e6bc4262275ea0b7d0dfbce82
@@ -35,8 +36,9 @@ pkgbase = mingw-w64-glib2
sha256sums = 9ba68777f48816cbee154084c10d0d577a021ef406606d5c2d230761cf82b66b
sha256sums = ad13c9aaa3d2ca7b1e3dcfd6d0c8043fa4fe45d8abb3659dbbc1fcbc412c10c7
sha256sums = 497d057e79943df233ca304c389f462d3c4bf55ab3267e94dbef892b79fe3274
- sha256sums = bf80d21ed1931f839d5920d0c3633b7c84ceb8f6da051cecc942ce90eccb883f
+ sha256sums = cc3bf5af21ea2138d5022163c95fc4dd5f1fe9c7f4169cac84d5a92ce851b44a
sha256sums = 97384c3e72f7d419eaa2377aeb85a382ce5441c5858e2c986a70dd380d3e1c1b
+ sha256sums = b038511e9da94c75922612f1fb10f6f6f951094e8d58fe64c2fa397044446c40
pkgname = mingw-w64-glib2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f46de972b6fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.xz
diff --git a/0027-no_sys_if_nametoindex.patch b/0027-no_sys_if_nametoindex.patch
index e2d279db0cf5..4ab05ad294e8 100644
--- a/0027-no_sys_if_nametoindex.patch
+++ b/0027-no_sys_if_nametoindex.patch
@@ -1,11 +1,19 @@
---- glib-2.42.1/gio/gsocket.c.orig.zak 2015-02-17 09:43:45.018111600 +0100
-+++ glib-2.42.1/gio/gsocket.c 2015-02-17 09:43:56.560283500 +0100
-@@ -1929,7 +1929,7 @@
- return TRUE;
- }
+--- glib-2.43.2/gio/gsocket.c.orig 2014-12-12 15:03:50.000000000 +0000
++++ glib-2.43.2/gio/gsocket.c 2015-01-14 12:44:04.619136700 +0000
+@@ -1931,7 +1931,7 @@
--#if !defined(HAVE_IF_NAMETOINDEX) && defined(G_OS_WIN32)
-+#if defined(G_OS_WIN32)
+ #if !defined(HAVE_IF_NAMETOINDEX) && defined(G_OS_WIN32)
static guint
- if_nametoindex (const gchar *iface)
+-if_nametoindex (const gchar *iface)
++w32_if_nametoindex (const gchar *iface)
{
+ PIP_ADAPTER_ADDRESSES addresses = NULL, p;
+ gulong addresses_len = 0;
+@@ -1981,6 +1981,7 @@
+ }
+
+ #define HAVE_IF_NAMETOINDEX 1
++#define if_nametoindex w32_if_nametoindex
+ #endif
+
+ static gboolean
diff --git a/0029-grand.all.patch b/0029-grand.all.patch
new file mode 100644
index 000000000000..13bc3a96b1cd
--- /dev/null
+++ b/0029-grand.all.patch
@@ -0,0 +1,12 @@
+--- glib-2.43.2/glib/grand.c.orig 2014-09-15 19:51:01.000000000 +0000
++++ glib-2.43.2/glib/grand.c 2015-01-14 13:53:08.130295800 +0000
+@@ -263,7 +263,8 @@
+ }
+ #else /* G_OS_WIN32 */
+ /* rand_s() is only available since Visual Studio 2005 */
+-#if defined(_MSC_VER) && _MSC_VER >= 1400
++ /* MinGW-w64 has a wrapper that will emulate rand_s() if it's not in msvcrt */
++#if (defined(_MSC_VER) && _MSC_VER >= 1400) || defined(__MINGW64_VERSION_MAJOR)
+ gint i;
+
+ for (i = 0; i < G_N_ELEMENTS (seed); i++)
diff --git a/PKGBUILD b/PKGBUILD
index 9a6f6e9c2cc4..caad78f2add7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Renato Silva <br.renatosilva@gmail.com>
pkgname=mingw-w64-glib2
pkgver=2.44.1
-pkgrel=2
+pkgrel=3
arch=(any)
pkgdesc="Common C routines used by GTK+ and other libs (mingw-w64)"
depends=(mingw-w64-gettext mingw-w64-zlib mingw-w64-libffi mingw-w64-pcre mingw-w64-freetype)
@@ -21,7 +21,8 @@ source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.t
"0021-use-64bit-stat-for-localfile-size-calc.all.patch"
"0024-return-actually-written-data-in-printf.all.patch"
"0027-no_sys_if_nametoindex.patch"
-"0028-inode_directory.patch")
+"0028-inode_directory.patch"
+"0029-grand.all.patch")
sha256sums=('8811deacaf8a503d0a9b701777ea079ca6a4277be10e3d730d2112735d5eca07'
'1420d8a8cadef2d33d748b31e5ae9c385aee1351d267dabf7a6a68fed6dfe7db'
'5551461a90386837356d2b56d4011e5272ba1d3e6bc4262275ea0b7d0dfbce82'
@@ -31,8 +32,9 @@ sha256sums=('8811deacaf8a503d0a9b701777ea079ca6a4277be10e3d730d2112735d5eca07'
'9ba68777f48816cbee154084c10d0d577a021ef406606d5c2d230761cf82b66b'
'ad13c9aaa3d2ca7b1e3dcfd6d0c8043fa4fe45d8abb3659dbbc1fcbc412c10c7'
'497d057e79943df233ca304c389f462d3c4bf55ab3267e94dbef892b79fe3274'
- 'bf80d21ed1931f839d5920d0c3633b7c84ceb8f6da051cecc942ce90eccb883f'
- '97384c3e72f7d419eaa2377aeb85a382ce5441c5858e2c986a70dd380d3e1c1b')
+ 'cc3bf5af21ea2138d5022163c95fc4dd5f1fe9c7f4169cac84d5a92ce851b44a'
+ '97384c3e72f7d419eaa2377aeb85a382ce5441c5858e2c986a70dd380d3e1c1b'
+ 'b038511e9da94c75922612f1fb10f6f6f951094e8d58fe64c2fa397044446c40')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -48,6 +50,7 @@ prepare() {
patch -Np1 -i "$srcdir/0024-return-actually-written-data-in-printf.all.patch"
patch -Np1 -i "$srcdir/0027-no_sys_if_nametoindex.patch"
patch -Np1 -i "$srcdir/0028-inode_directory.patch"
+ patch -Np1 -i "${srcdir}/0029-grand.all.patch"
NOCONFIGURE=1 ./autogen.sh
}