summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-08-17 17:25:59 +0200
committerNicola Murino2018-08-17 17:25:59 +0200
commitbb483d29a7c4acd13e165329c31d5a776504dd9c (patch)
tree4d489d67dc91a814f989b5a16188f6f5c1947a0b
parent32540bac2d19f7ee3c86c36fc37028142f4d44af (diff)
downloadaur-bb483d29a7c4acd13e165329c31d5a776504dd9c.tar.gz
Update to 2.56.2-1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-gsocket-fix-cross-compilation.patch26
-rw-r--r--PKGBUILD15
3 files changed, 41 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f78814dc6c43..34c2a058f270 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
# Generated by mksrcinfo v8
-# Sun Apr 22 20:03:46 UTC 2018
+# Fri Aug 17 15:25:01 UTC 2018
pkgbase = mingw-w64-glib2
pkgdesc = Low level core library (mingw-w64)
- pkgver = 2.56.1
+ pkgver = 2.56.2
pkgrel = 1
url = http://www.gtk.org/
arch = any
- license = LGPL
+ license = LGPL2.1
makedepends = mingw-w64-configure
makedepends = python
makedepends = shared-mime-info
@@ -19,18 +19,20 @@ pkgbase = mingw-w64-glib2
options = !buildflags
options = staticlibs
options = !emptydirs
- source = git+https://git.gnome.org/browse/glib#commit=d0364b443805dcb832c200fcf8bf58a64fdf3e7d
+ source = git+https://gitlab.gnome.org/GNOME/glib.git#commit=d4b60396c79c7294ab69a2c591518e76ab17b603
source = 0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch
source = 0004-glib-prefer-constructors-over-DllMain.patch
source = 0028-inode_directory.patch
source = use-pkgconfig-file-for-intl.patch
source = skip-broken-timer-test.patch
+ source = 0001-gsocket-fix-cross-compilation.patch
sha256sums = SKIP
sha256sums = ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3
sha256sums = 7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6
sha256sums = f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b
sha256sums = 1991eaa0471ff8d0b3dd3bccccd560ca6cc8c0995c6145b9bc93d5e90755e3f4
sha256sums = a39dc8c1c1707053d565d5b198b1f03f7c55b31e11335a1bfdc3f9803b114d5d
+ sha256sums = 44c8c6b4ca376177a8c333a00c3485d638f8641967503e15364606d4c4292ff3
pkgname = mingw-w64-glib2
diff --git a/0001-gsocket-fix-cross-compilation.patch b/0001-gsocket-fix-cross-compilation.patch
new file mode 100644
index 000000000000..5ad7ed78ec87
--- /dev/null
+++ b/0001-gsocket-fix-cross-compilation.patch
@@ -0,0 +1,26 @@
+From b7789bb144ff4545021fbd95ee93c98ec706891a Mon Sep 17 00:00:00 2001
+From: Nicola Murino <nicola.murino@gmail.com>
+Date: Fri, 17 Aug 2018 17:04:07 +0200
+Subject: [PATCH] gsocket: fix cross compilation
+
+for some reason when cross compiling for windows BROKEN_IP_MREQ_SOURCE_STRUCT is defined but should not
+---
+ gio/gsocket.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gio/gsocket.c b/gio/gsocket.c
+index 859e807cb..71a97b8cf 100644
+--- a/gio/gsocket.c
++++ b/gio/gsocket.c
+@@ -2404,7 +2404,7 @@ g_socket_multicast_group_operation_ssm (GSocket *socket,
+ memset (&mc_req_src, 0, sizeof (mc_req_src));
+
+ /* By default use the default IPv4 multicast interface. */
+- S_ADDR_FIELD(mc_req_src) = g_htonl (INADDR_ANY);
++ mc_req_src.imr_interface.s_addr = g_htonl (INADDR_ANY);
+
+ if (iface)
+ {
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index fc0547232f5f..2547840f3456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,30 @@
# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Renato Silva <br.renatosilva@gmail.com>
pkgname=mingw-w64-glib2
-pkgver=2.56.1
+pkgver=2.56.2
pkgrel=1
-_commit=d0364b443805dcb832c200fcf8bf58a64fdf3e7d # tags/2.56.1^0
+_commit=d4b60396c79c7294ab69a2c591518e76ab17b603 # tags/2.56.2^0
arch=(any)
pkgdesc="Low level core library (mingw-w64)"
depends=(mingw-w64-libffi mingw-w64-pcre mingw-w64-gettext)
makedepends=(mingw-w64-configure python shared-mime-info mingw-w64-zlib git)
-license=("LGPL")
+license=("LGPL2.1")
options=(!strip !buildflags staticlibs !emptydirs)
url="http://www.gtk.org/"
-source=("git+https://git.gnome.org/browse/glib#commit=$_commit"
+source=("git+https://gitlab.gnome.org/GNOME/glib.git#commit=$_commit"
"0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
"0004-glib-prefer-constructors-over-DllMain.patch"
"0028-inode_directory.patch"
"use-pkgconfig-file-for-intl.patch"
-"skip-broken-timer-test.patch")
+"skip-broken-timer-test.patch"
+"0001-gsocket-fix-cross-compilation.patch")
sha256sums=('SKIP'
'ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3'
'7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6'
'f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b'
'1991eaa0471ff8d0b3dd3bccccd560ca6cc8c0995c6145b9bc93d5e90755e3f4'
- 'a39dc8c1c1707053d565d5b198b1f03f7c55b31e11335a1bfdc3f9803b114d5d')
+ 'a39dc8c1c1707053d565d5b198b1f03f7c55b31e11335a1bfdc3f9803b114d5d'
+ '44c8c6b4ca376177a8c333a00c3485d638f8641967503e15364606d4c4292ff3')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -40,6 +42,7 @@ prepare() {
patch -Np1 -i ../"0028-inode_directory.patch"
patch -p0 -i ../use-pkgconfig-file-for-intl.patch
patch -Np1 -i ../skip-broken-timer-test.patch
+ patch -Np1 -i ../0001-gsocket-fix-cross-compilation.patch
NOCONFIGURE=1 ./autogen.sh
}