summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Archive Bot2015-08-16 23:47:54 +0200
committerSandy Carter2017-03-08 09:39:22 -0500
commit928cad04ffc53e0dddc11f7f2047687d9d9d7ddb (patch)
tree7f56952b98af6a2879ec402d2a294dd220557f7a
downloadaur-928cad04ffc53e0dddc11f7f2047687d9d9d7ddb.tar.gz
Initial AUR Archive commit of 'mingw-w64-glm'
(full history will be added later)
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b302dd00ff4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = mingw-w64-glm
+ pkgdesc = C++ mathematics library for 3D software based on the OpenGL Shading Language (GLSL) specification. (mingw-w64 symlinks)
+ pkgver = 0.9.x
+ pkgrel = 2
+ url = http://glm.g-truc.net
+ arch = any
+ license = GPL
+ depends = glm
+ depends = mingw-w64-crt
+
+pkgname = mingw-w64-glm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da38f6b8bf96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Daniel Kirchner <daniel at ekpyron dot org>
+pkgname=mingw-w64-glm
+pkgver=0.9.x
+pkgrel=2
+pkgdesc="C++ mathematics library for 3D software based on the OpenGL Shading Language (GLSL) specification. (mingw-w64 symlinks)"
+arch=('any')
+license=('GPL')
+url="http://glm.g-truc.net"
+depends=('glm' 'mingw-w64-crt')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+package() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${pkgdir}/usr/${_arch}/include"
+ ln -s ../../../usr/include/glm "${pkgdir}/usr/${_arch}/include"
+ done
+}