summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2021-03-01 10:12:01 -0500
committerSandy Carter2021-03-01 10:12:01 -0500
commita8df01a6247f483d4ffaf9777b1d938a5bad5fd2 (patch)
treefb8dd62577600c1b86f64392818418ca0f6ed277
parent84dc284ec5246a064ec9ce41c709546d3a46db80 (diff)
downloadaur-a8df01a6247f483d4ffaf9777b1d938a5bad5fd2.tar.gz
Symlink the .cmake files instead of folder because they are not symlink agnostic
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 866bdb6dc331..3064c7f09f61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-glm
pkgdesc = C++ mathematics library for 3D software based on the OpenGL Shading Language (GLSL) specification. (mingw-w64 symlinks)
pkgver = 0.9.x
- pkgrel = 3
+ pkgrel = 4
url = http://glm.g-truc.net
arch = any
license = GPL
diff --git a/.gitignore b/.gitignore
index 771449444e96..ca10a57a79ad 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,2 @@
-*.pkg.tar.xz
+*.pkg.tar.*
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 599696693466..33c5e6ad8b5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Daniel Kirchner <daniel at ekpyron dot org>
pkgname=mingw-w64-glm
+# x because this does not need updating with new versions, depends on glm package
pkgver=0.9.x
-pkgrel=3
+pkgrel=4
pkgdesc="C++ mathematics library for 3D software based on the OpenGL Shading Language (GLSL) specification. (mingw-w64 symlinks)"
arch=('any')
license=('GPL')
@@ -16,7 +17,8 @@ package() {
for _arch in ${_architectures}; do
mkdir -p "${pkgdir}/usr/${_arch}/include"
ln -s /usr/include/glm "${pkgdir}/usr/${_arch}/include"
- mkdir -p "${pkgdir}/usr/${_arch}/lib/cmake"
- ln -s /usr/lib/cmake/glm "${pkgdir}/usr/${_arch}/lib/cmake"
+ mkdir -p "${pkgdir}/usr/${_arch}/lib/cmake/glm"
+ # symlink the cmake files instead of the folder because they are not symlink agnostic
+ ln -s /usr/lib/cmake/glm/* "${pkgdir}/usr/${_arch}/lib/cmake/glm"
done
}