summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-06-14 19:41:27 +0200
committerMichel Zou2022-06-14 19:41:27 +0200
commit0acb3d723b131fd87780daba14e351ca225b1da1 (patch)
tree7ada595217f0c7f9f0fd72c2f83ed93a4090341d
parent62a58c9f2451fccda6bedb189160786df66dfb49 (diff)
downloadaur-0acb3d723b131fd87780daba14e351ca225b1da1.tar.gz
11.10.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rw-r--r--wine-glslangValidator.sh5
3 files changed, 9 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c7c1779bcfb..21dc804f07c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-glslang
pkgdesc = OpenGL and OpenGL ES shader front end and validator (mingw-w64)
- pkgver = 11.5.0
- pkgrel = 2
+ pkgver = 11.10.0
+ pkgrel = 1
url = https://github.com/KhronosGroup/glslang
arch = any
license = BSD
@@ -13,13 +13,7 @@ pkgbase = mingw-w64-glslang
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/KhronosGroup/glslang/archive/11.5.0.tar.gz
- source = wine-glslangValidator.sh
- source = git+https://github.com/KhronosGroup/SPIRV-Tools#commit=dc72924cb31cd9f3dbc3eb47e9d926cf641e3a07
- source = git+https://github.com/KhronosGroup/SPIRV-Headers#commit=dafead1765f6c1a5f9f8a76387dcb2abe4e54acd
- sha256sums = fd0b5e3bda591bb08bd3049655a99a0a55f0de4059b9c8f7b397e4b19cf5d51f
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = mingw-w64-glslang-11.10.0.tar.gz::https://github.com/KhronosGroup/glslang/archive/11.10.0.tar.gz
+ sha256sums = 8ffc19c435232d09299dd2c91e247292b3508c1b826a3497c60682e4bbf2d602
pkgname = mingw-w64-glslang
diff --git a/PKGBUILD b/PKGBUILD
index 84e07f4ea235..a460161356b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-glslang
-pkgver=11.5.0
-pkgrel=2
+pkgver=11.10.0
+pkgrel=1
pkgdesc='OpenGL and OpenGL ES shader front end and validator (mingw-w64)'
arch=('any')
url='https://github.com/KhronosGroup/glslang'
@@ -9,17 +9,12 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake' 'python' 'git')
optdepends=('mingw-w64-wine: runtime support')
options=('!strip' '!buildflags' 'staticlibs')
-source=(https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz wine-glslangValidator.sh
- git+https://github.com/KhronosGroup/SPIRV-Tools#commit=dc72924cb31cd9f3dbc3eb47e9d926cf641e3a07
- git+https://github.com/KhronosGroup/SPIRV-Headers#commit=dafead1765f6c1a5f9f8a76387dcb2abe4e54acd)
-sha256sums=('fd0b5e3bda591bb08bd3049655a99a0a55f0de4059b9c8f7b397e4b19cf5d51f' SKIP SKIP SKIP)
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz)
+sha256sums=('8ffc19c435232d09299dd2c91e247292b3508c1b826a3497c60682e4bbf2d602')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cp -r SPIRV-Tools glslang-${pkgver}/External/spirv-tools
- cp -r SPIRV-Headers glslang-${pkgver}/External/spirv-tools/external/spirv-headers
-
cd glslang-$pkgver
}
@@ -31,7 +26,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
..
make
- sed "s|@TRIPLE@|${_arch}|g" "${srcdir}"/wine-glslangValidator.sh > ${_arch}-glslangValidator
+ echo -e "#!/bin/sh\n${_arch}-wine /usr/${_arch}/bin/glslangValidator.exe \"\$@\"" > ${_arch}-glslangValidator
popd
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
${_arch}-cmake \
@@ -49,10 +44,6 @@ package() {
make DESTDIR="${pkgdir}" install
cd "${srcdir}/glslang-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
- # Delete the stuff that's been vendored in. It's not ideal but that's we'll deal with for now.
- mv "${pkgdir}"/usr/${_arch}/bin/spirv-remap.exe .
- rm -r "${pkgdir}"/usr/${_arch}/{bin/spirv*,bin/libSPIRV-Tools*,include/spirv-tools,SPIRV-Tools*,lib/libSPIRV-Tools*,lib/pkgconfig}
- mv spirv-remap.exe "${pkgdir}"/usr/${_arch}/bin/spirv-remap.exe
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
install -d "$pkgdir"/usr/bin
diff --git a/wine-glslangValidator.sh b/wine-glslangValidator.sh
deleted file mode 100644
index d48b208428e7..000000000000
--- a/wine-glslangValidator.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-set -e
-
-@TRIPLE@-wine /usr/@TRIPLE@/bin/glslangValidator.exe "$@"