summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMladen Milinkovic2019-07-09 01:14:23 +0200
committerMladen Milinkovic2019-07-09 01:14:23 +0200
commit1c701cb819c0bdd4f09e757a1a05cff935c4e095 (patch)
tree39650c0966638e203479884446aae84e1b1439eb
downloadaur-1c701cb819c0bdd4f09e757a1a05cff935c4e095.tar.gz
Version 7.11.3214
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--001-install-missing-dll.patch12
-rw-r--r--PKGBUILD55
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d9c1a7c3a80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-glslang
+ pkgdesc = OpenGL and OpenGL ES shader front end and validator (mingw-w64)
+ pkgver = 7.11.3214
+ pkgrel = 1
+ url = https://github.com/KhronosGroup/glslang
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-spirv-tools
+ options = staticlibs
+ source = mingw-w64-glslang-7.11.3214.tar.gz::https://github.com/KhronosGroup/glslang/archive/7.11.3214.tar.gz
+ source = 001-install-missing-dll.patch
+ sha256sums = b30b4668734328d256e30c94037e60d3775b1055743c04d8fd709f2960f302a9
+ sha256sums = f4b129e6c79ca25729d32b2d3098536dcd326dc3c75be4e0db615d8fc80a9f1e
+
+pkgname = mingw-w64-glslang
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c98cdbbd9a8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.log
+*.sig
+*.tar
+*.xz
diff --git a/001-install-missing-dll.patch b/001-install-missing-dll.patch
new file mode 100644
index 000000000000..9799b15fc5b9
--- /dev/null
+++ b/001-install-missing-dll.patch
@@ -0,0 +1,12 @@
+diff --git a/StandAlone/CMakeLists.txt b/StandAlone/CMakeLists.txt
+index 2a9a3c47..e3d46595 100644
+--- a/StandAlone/CMakeLists.txt
++++ b/StandAlone/CMakeLists.txt
+@@ -45,6 +45,6 @@ install(TARGETS glslangValidator
+
+ if(BUILD_SHARED_LIBS)
+ install(TARGETS glslang-default-resource-limits
+- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ endif()
+ endif(ENABLE_GLSLANG_INSTALL)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58bce4f9de8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+_pkgname=glslang
+pkgname="mingw-w64-${_pkgname}"
+pkgver=7.11.3214
+pkgrel=1
+pkgdesc='OpenGL and OpenGL ES shader front end and validator (mingw-w64)'
+arch=('any')
+url='https://github.com/KhronosGroup/glslang'
+license=('BSD')
+depends=('mingw-w64-spirv-tools')
+makedepends=('mingw-w64-cmake')
+options=('staticlibs')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz
+ 001-install-missing-dll.patch)
+sha256sums=('b30b4668734328d256e30c94037e60d3775b1055743c04d8fd709f2960f302a9'
+ 'f4b129e6c79ca25729d32b2d3098536dcd326dc3c75be4e0db615d8fc80a9f1e')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd $_pkgname-$pkgver
+ patch -Np1 -i ${srcdir}/001-install-missing-dll.patch
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p "build-${_arch}"-{shared,static}
+# (cd "build-${_arch}-shared"
+# ${_arch}-cmake .. \
+# -DCMAKE_BUILD_TYPE=Release \
+# -DBUILD_SHARED_LIBS=ON
+# make
+# )
+ (cd build-${_arch}-static
+ ${_arch}-cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=OFF
+ make
+ )
+ done
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ for _arch in ${_architectures}; do
+# make -C "build-${_arch}-shared" DESTDIR="${pkgdir}" install
+ make -C "build-${_arch}-static" DESTDIR="${pkgdir}" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ done
+}
+
+# vim: ts=2 sw=2 et: