summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2020-05-19 08:03:04 +0200
committerMichel Zou2020-05-19 08:03:04 +0200
commit5408c19647cb02c0069bf62dfb10305143806f4f (patch)
treefa17f9f51c31574ff59562d3a4cd7d31c764a201
parent1c701cb819c0bdd4f09e757a1a05cff935c4e095 (diff)
downloadaur-5408c19647cb02c0069bf62dfb10305143806f4f.tar.gz
8.13.3743
-rw-r--r--.SRCINFO10
-rw-r--r--001-install-missing-dll.patch12
-rw-r--r--PKGBUILD51
3 files changed, 25 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d9c1a7c3a80..f6238ece246e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = mingw-w64-glslang
pkgdesc = OpenGL and OpenGL ES shader front end and validator (mingw-w64)
- pkgver = 7.11.3214
+ pkgver = 8.13.3743
pkgrel = 1
url = https://github.com/KhronosGroup/glslang
arch = any
license = BSD
makedepends = mingw-w64-cmake
depends = mingw-w64-spirv-tools
+ options = !strip
+ options = !buildflags
options = staticlibs
- source = mingw-w64-glslang-7.11.3214.tar.gz::https://github.com/KhronosGroup/glslang/archive/7.11.3214.tar.gz
- source = 001-install-missing-dll.patch
- sha256sums = b30b4668734328d256e30c94037e60d3775b1055743c04d8fd709f2960f302a9
- sha256sums = f4b129e6c79ca25729d32b2d3098536dcd326dc3c75be4e0db615d8fc80a9f1e
+ source = https://github.com/KhronosGroup/glslang/archive/8.13.3743.tar.gz
+ sha256sums = 639ebec56f1a7402f2fa094469a5ddea1eceecfaf2e9efe361376a0f73a7ee2f
pkgname = mingw-w64-glslang
diff --git a/001-install-missing-dll.patch b/001-install-missing-dll.patch
deleted file mode 100644
index 9799b15fc5b9..000000000000
--- a/001-install-missing-dll.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/StandAlone/CMakeLists.txt b/StandAlone/CMakeLists.txt
-index 2a9a3c47..e3d46595 100644
---- a/StandAlone/CMakeLists.txt
-+++ b/StandAlone/CMakeLists.txt
-@@ -45,6 +45,6 @@ install(TARGETS glslangValidator
-
- if(BUILD_SHARED_LIBS)
- install(TARGETS glslang-default-resource-limits
-- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
- endif()
- endif(ENABLE_GLSLANG_INSTALL)
diff --git a/PKGBUILD b/PKGBUILD
index 58bce4f9de8a..c7cf42678880 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_pkgname=glslang
pkgname="mingw-w64-${_pkgname}"
-pkgver=7.11.3214
+pkgver=8.13.3743
pkgrel=1
pkgdesc='OpenGL and OpenGL ES shader front end and validator (mingw-w64)'
arch=('any')
@@ -8,48 +8,37 @@ url='https://github.com/KhronosGroup/glslang'
license=('BSD')
depends=('mingw-w64-spirv-tools')
makedepends=('mingw-w64-cmake')
-options=('staticlibs')
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz
- 001-install-missing-dll.patch)
-sha256sums=('b30b4668734328d256e30c94037e60d3775b1055743c04d8fd709f2960f302a9'
- 'f4b129e6c79ca25729d32b2d3098536dcd326dc3c75be4e0db615d8fc80a9f1e')
+options=('!strip' '!buildflags' 'staticlibs')
+source=(https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz)
+sha256sums=('639ebec56f1a7402f2fa094469a5ddea1eceecfaf2e9efe361376a0f73a7ee2f')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd $_pkgname-$pkgver
- patch -Np1 -i ${srcdir}/001-install-missing-dll.patch
+ cd glslang-$pkgver
+ # error: conflicting declaration of ‘int sprintf_s
+ sed -i "s|MINGW_HAS_SECURE_API|NO_MINGW|g" glslang/Include/Common.h
}
build() {
- cd $_pkgname-$pkgver
+ cd glslang-$pkgver
for _arch in ${_architectures}; do
- unset LDFLAGS
- mkdir -p "build-${_arch}"-{shared,static}
-# (cd "build-${_arch}-shared"
-# ${_arch}-cmake .. \
-# -DCMAKE_BUILD_TYPE=Release \
-# -DBUILD_SHARED_LIBS=ON
-# make
-# )
- (cd build-${_arch}-static
- ${_arch}-cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_SHARED_LIBS=OFF
- make
- )
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=OFF \
+ -DENABLE_GLSLANG_BINARIES=OFF \
+ ..
+ make
+ popd
done
}
package() {
- cd $_pkgname-$pkgver
for _arch in ${_architectures}; do
-# make -C "build-${_arch}-shared" DESTDIR="${pkgdir}" install
- make -C "build-${_arch}-static" DESTDIR="${pkgdir}" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ cd "${srcdir}/glslang-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
+# ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
done
}
-
-# vim: ts=2 sw=2 et: