summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 23:45:07 +0200
committerxantares2015-06-08 23:45:07 +0200
commit0bce8efd81ebd2860381893e96d984c7c5f6a4a3 (patch)
tree5b4a11fc2da3909b4b9f9c952a95d8852f2a3542
downloadaur-0bce8efd81ebd2860381893e96d984c7c5f6a4a3.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD65
-rw-r--r--gnutls-3.1.11-nosrp.patch12
-rw-r--r--gnutls-3.2.7-rpath.patch12
-rw-r--r--gnutls-3.3.6-default-policy.patch31
-rw-r--r--gnutls-fix-external-libtasn1-detection.patch11
6 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee58b4063f41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = mingw-w64-gnutls
+ pkgdesc = A library which provides a secure layer over a reliable transport layer (mingw-w64)
+ pkgver = 3.3.12
+ pkgrel = 1
+ url = http://www.gnu.org/software/gnutls
+ arch = any
+ license = GPL3, LGPL2.1
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ depends = mingw-w64-libtasn1
+ depends = mingw-w64-readline
+ depends = mingw-w64-zlib
+ depends = mingw-w64-nettle
+ depends = mingw-w64-p11-kit
+ optdepends = mingw-w64-openssl: libgnutls-openssl
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/gnutls-3.3.12.tar.xz
+ source = ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3/gnutls-3.3.12.tar.xz.sig
+ source = gnutls-3.2.7-rpath.patch
+ source = gnutls-3.1.11-nosrp.patch
+ source = gnutls-3.3.6-default-policy.patch
+ source = gnutls-fix-external-libtasn1-detection.patch
+ md5sums = a37b20b4352a5f542367ded904729c90
+ md5sums = SKIP
+ md5sums = 291612225516234ede7e60f8b367dd8b
+ md5sums = c3a2abfe08f47d9b07f770689b0c1b39
+ md5sums = e0dba6bfe81b965a352f965b1398bcad
+ md5sums = f90a0f01eb0f2a6b7afcc25a836eb67e
+
+pkgname = mingw-w64-gnutls
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65801b2beb2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+pkgname=mingw-w64-gnutls
+pkgver=3.3.12
+pkgrel=1
+pkgdesc="A library which provides a secure layer over a reliable transport layer (mingw-w64)"
+arch=(any)
+url="http://www.gnu.org/software/gnutls"
+license=("GPL3, LGPL2.1")
+makedepends=(mingw-w64-configure)
+depends=(mingw-w64-crt mingw-w64-libtasn1 mingw-w64-readline mingw-w64-zlib mingw-w64-nettle mingw-w64-p11-kit)
+options=(staticlibs !strip !buildflags)
+optdepends=("mingw-w64-openssl: libgnutls-openssl")
+source=("ftp://ftp.gnutls.org/gcrypt/gnutls/v${pkgver%.*}/gnutls-${pkgver}.tar.xz"{,.sig}
+ 'gnutls-3.2.7-rpath.patch'
+ 'gnutls-3.1.11-nosrp.patch'
+ 'gnutls-3.3.6-default-policy.patch'
+ 'gnutls-fix-external-libtasn1-detection.patch')
+md5sums=('a37b20b4352a5f542367ded904729c90'
+ 'SKIP'
+ '291612225516234ede7e60f8b367dd8b'
+ 'c3a2abfe08f47d9b07f770689b0c1b39'
+ 'e0dba6bfe81b965a352f965b1398bcad'
+ 'f90a0f01eb0f2a6b7afcc25a836eb67e')
+validpgpkeys=('1F42418905D8206AA754CCDC29EE58B996865171')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/gnutls-${pkgver}"
+ patch -p0 -i ../gnutls-fix-external-libtasn1-detection.patch
+ patch -p1 -i ../gnutls-3.2.7-rpath.patch
+ patch -p1 -i ../gnutls-3.1.11-nosrp.patch
+ patch -p1 -i ../gnutls-3.3.6-default-policy.patch
+ sed 's/gnutls_srp.c//g' -i lib/Makefile.in
+ sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
+ rm -f lib/minitasn1/*.c lib/minitasn1/*.h
+}
+
+build() {
+ cd "${srcdir}/gnutls-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure --disable-doc \
+ --disable-openssl-compatibility \
+ --disable-srp-authentication \
+ --disable-nls \
+ --disable-rpath \
+ --disable-non-suiteb-curves \
+ --with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit" \
+ --enable-local-libopts \
+ --without-tpm
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/gnutls-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ rm "$pkgdir"/usr/${_arch}/bin/*.def
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
diff --git a/gnutls-3.1.11-nosrp.patch b/gnutls-3.1.11-nosrp.patch
new file mode 100644
index 000000000000..29227c08ce20
--- /dev/null
+++ b/gnutls-3.1.11-nosrp.patch
@@ -0,0 +1,12 @@
+diff -up gnutls-3.1.10/tests/srp/mini-srp.c.noecc gnutls-3.1.10/tests/srp/mini-srp.c
+--- gnutls-3.1.10/tests/srp/mini-srp.c.noecc 2013-03-21 21:42:28.000000000 +0100
++++ gnutls-3.1.10/tests/srp/mini-srp.c 2013-03-25 13:42:20.753422209 +0100
+@@ -27,7 +27,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
+-#if defined(_WIN32)
++#if defined(_WIN32) || !defined(ENABLE_SRP)
+
+ int main()
+ {
diff --git a/gnutls-3.2.7-rpath.patch b/gnutls-3.2.7-rpath.patch
new file mode 100644
index 000000000000..4e6aed37a50f
--- /dev/null
+++ b/gnutls-3.2.7-rpath.patch
@@ -0,0 +1,12 @@
+diff -ur gnutls-3.2.7.orig/configure gnutls-3.2.7/configure
+--- gnutls-3.2.7.orig/configure 2013-11-23 11:09:49.000000000 +0100
++++ gnutls-3.2.7/configure 2013-11-25 16:53:05.559440656 +0100
+@@ -39652,7 +39652,7 @@
+ shlibpath_overrides_runpath=unknown
+ version_type=none
+ dynamic_linker="$host_os ld.so"
+-sys_lib_dlsearch_path_spec="/lib /usr/lib"
++sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64"
+ need_lib_prefix=unknown
+ hardcode_into_libs=no
+
diff --git a/gnutls-3.3.6-default-policy.patch b/gnutls-3.3.6-default-policy.patch
new file mode 100644
index 000000000000..94185e8904c6
--- /dev/null
+++ b/gnutls-3.3.6-default-policy.patch
@@ -0,0 +1,31 @@
+diff -ur gnutls-3.3.6.orig/lib/gnutls_priority.c gnutls-3.3.6/lib/gnutls_priority.c
+--- gnutls-3.3.6.orig/lib/gnutls_priority.c 2014-07-22 23:43:41.000000000 +0200
++++ gnutls-3.3.6/lib/gnutls_priority.c 2014-07-23 10:13:30.456310043 +0200
+@@ -1110,6 +1110,7 @@
+ int algo;
+ rmadd_func *fn;
+ bulk_rmadd_func *bulk_fn;
++ unsigned dset = 0;
+
+ if (err_pos)
+ *err_pos = priorities;
+@@ -1129,10 +1130,16 @@
+
+ (*priority_cache)->max_empty_records = DEFAULT_MAX_EMPTY_RECORDS;
+
+- if (priorities == NULL)
+- priorities = "NORMAL";
++ if (priorities == NULL) {
++ priorities = "@SYSTEM";
++ dset = 1;
++ }
+
+ darg = resolve_priorities(priorities);
++ if (darg == NULL && dset == 1) {
++ priorities = "NORMAL";
++ darg = resolve_priorities(priorities);
++ }
+ if (darg == NULL) {
+ gnutls_assert();
+ goto error;
+Only in gnutls-3.3.6/lib: gnutls_priority.c.orig
diff --git a/gnutls-fix-external-libtasn1-detection.patch b/gnutls-fix-external-libtasn1-detection.patch
new file mode 100644
index 000000000000..d8c68bb396e9
--- /dev/null
+++ b/gnutls-fix-external-libtasn1-detection.patch
@@ -0,0 +1,11 @@
+--- extra/Makefile.in.orig 2013-02-03 19:40:27.000000000 -0600
++++ extra/Makefile.in 2013-02-06 23:08:54.619176090 -0600
+@@ -76,7 +76,7 @@
+ @ENABLE_MINITASN1_TRUE@am__append_1 = -I$(srcdir)/../lib/minitasn1
+ @ENABLE_OPENSSL_TRUE@am__append_2 = -version-info $(LT_SSL_CURRENT):$(LT_SSL_REVISION):$(LT_SSL_AGE)
+ @ENABLE_MINITASN1_TRUE@@ENABLE_OPENSSL_TRUE@am__append_3 = ../lib/minitasn1/libminitasn1.la
+-@ENABLE_MINITASN1_FALSE@@ENABLE_OPENSSL_TRUE@am__append_4 = $(LTLIBTASN1)
++@ENABLE_MINITASN1_FALSE@@ENABLE_OPENSSL_TRUE@am__append_4 = $(LIBTASN1_LIBS)
+ @ENABLE_OPENSSL_TRUE@@HAVE_LD_OUTPUT_DEF_TRUE@am__append_5 = \
+ @ENABLE_OPENSSL_TRUE@@HAVE_LD_OUTPUT_DEF_TRUE@ -Wl,--output-def,libgnutls-openssl-$(DLL_VERSION).def
+