summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-05-05 19:54:51 +0200
committerMartchus2018-06-18 19:37:24 +0200
commit2eff03eae9168ed9be3dbebea8302fb18c680fb0 (patch)
treebc67e00439e550298de4017a4d76eac721055630
parentc152b7d9969e86101fc441d2e6676b5372f850f8 (diff)
downloadaur-2eff03eae9168ed9be3dbebea8302fb18c680fb0.tar.gz
Update to 3.5.18
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--gnutls-3.2.7-rpath.patch12
3 files changed, 33 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c89ce57944ea..141ab1945a63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Dec 28 14:43:11 UTC 2017
pkgbase = mingw-w64-gnutls
pkgdesc = A library which provides a secure layer over a reliable transport layer (mingw-w64)
- pkgver = 3.5.16
+ pkgver = 3.5.18
pkgrel = 1
url = http://www.gnu.org/software/gnutls
arch = any
@@ -20,14 +18,14 @@ pkgbase = mingw-w64-gnutls
options = staticlibs
options = !strip
options = !buildflags
- source = https://www.gnupg.org/ftp/gcrypt/gnutls/v3.5/gnutls-3.5.16.tar.xz
- source = https://www.gnupg.org/ftp/gcrypt/gnutls/v3.5/gnutls-3.5.16.tar.xz.sig
- source = gnutls-3.2.7-rpath.patch
+ source = https://www.gnupg.org/ftp/gcrypt/gnutls/v3.5/gnutls-3.5.18.tar.xz
+ source = https://www.gnupg.org/ftp/gcrypt/gnutls/v3.5/gnutls-3.5.18.tar.xz.sig
source = gnutls-fix-external-libtasn1-detection.patch
- sha256sums = 0924dec90c37c05f49fec966eba3672dab4d336d879e5c06e06e13325cbfec25
+ validpgpkeys = 0424D4EE81A0E3D119C6F835EDA21E94B565716F
+ validpgpkeys = 1F42418905D8206AA754CCDC29EE58B996865171
+ sha256sums = ae2248d9e78747cf9c469dde81ff8f90b56838b707a0637f3f7d4eee90e80234
sha256sums = SKIP
sha256sums = c77b307dcbe3d83b99a15b9ff0cac3978983b40b8cb2495eeb02ade5c9c12969
- sha256sums = 8525da75852a516be0cb05df0a770daf19ce0583033260d6cac03a1e40fd2072
pkgname = mingw-w64-gnutls
diff --git a/PKGBUILD b/PKGBUILD
index 4777e29c3169..76790c900dde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: Martchus <martchus@gmx.net>
pkgname=mingw-w64-gnutls
-pkgver=3.5.16
+pkgver=3.5.18
pkgrel=1
pkgdesc='A library which provides a secure layer over a reliable transport layer (mingw-w64)'
arch=('any')
url="http://www.gnu.org/software/gnutls"
license=('GPL3', 'LGPL2.1')
makedepends=('mingw-w64-configure')
+#checkdepends=('wine')
depends=('mingw-w64-crt' 'mingw-w64-libtasn1' 'mingw-w64-readline' 'mingw-w64-zlib' 'mingw-w64-nettle' 'mingw-w64-p11-kit' 'mingw-w64-libunistring')
options=(staticlibs !strip !buildflags)
optdepends=("mingw-w64-openssl: libgnutls-openssl")
source=(https://www.gnupg.org/ftp/gcrypt/gnutls/v3.5/${pkgname#mingw-w64-}-${pkgver}.tar.xz{,.sig}
- 'gnutls-3.2.7-rpath.patch'
'gnutls-fix-external-libtasn1-detection.patch')
-sha256sums=('0924dec90c37c05f49fec966eba3672dab4d336d879e5c06e06e13325cbfec25'
+sha256sums=('ae2248d9e78747cf9c469dde81ff8f90b56838b707a0637f3f7d4eee90e80234'
'SKIP'
- 'c77b307dcbe3d83b99a15b9ff0cac3978983b40b8cb2495eeb02ade5c9c12969'
- '8525da75852a516be0cb05df0a770daf19ce0583033260d6cac03a1e40fd2072')
+ 'c77b307dcbe3d83b99a15b9ff0cac3978983b40b8cb2495eeb02ade5c9c12969')
validpgpkeys=('0424D4EE81A0E3D119C6F835EDA21E94B565716F'
'1F42418905D8206AA754CCDC29EE58B996865171')
# "Simon Josefsson <simon@josefsson.org>"
@@ -28,7 +27,6 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "${srcdir}/gnutls-${pkgver}"
patch -p0 -i ../gnutls-fix-external-libtasn1-detection.patch
- patch -p1 -i ../gnutls-3.2.7-rpath.patch
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
rm -f lib/minitasn1/*.c lib/minitasn1/*.h
@@ -38,13 +36,21 @@ build() {
cd "${srcdir}/gnutls-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --disable-doc \
+ ${_arch}-configure \
+ --disable-doc \
--disable-openssl-compatibility \
--disable-srp-authentication \
- --disable-nls \
--disable-rpath \
--disable-non-suiteb-curves \
+ --disable-gtk-doc \
+ --disable-guile \
+ --disable-full-test-suite \
+ --with-zlib \
+ --with-libiconv-prefix=/usr/$_arch \
+ --with-regex-libs=-lsystre \
--with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit" \
+ --enable-nls \
+ --enable-cxx \
--enable-local-libopts \
--without-tpm
make
@@ -52,6 +58,19 @@ build() {
done
}
+# not sure how to setup systemd npawn via makechrootpkg to mount binfmt_misc (version below leads to "only root can use "--types" option")
+#check() {
+# mount -t binfmt_misc binfmt_misc /proc/sys/fs/binfmt_misc
+# echo ':DOSWin:M::MZ::/usr/bin/wine:' > /proc/sys/fs/binfmt_misc/register
+# for _arch in ${_architectures}; do
+# cd "${srcdir}/gnutls-${pkgver}/build-${_arch}"
+# export WINEPREFIX=~/.wine-${_arch}
+# export WINEPATH=/usr/${_arch}/bin
+# [[ $_arch == x86_64-w64-mingw32 ]] && export WINEARCH=win64 || export WINEARCH=win32
+# make -C tests check
+# done
+#}
+
package() {
for _arch in ${_architectures}; do
cd "${srcdir}/gnutls-${pkgver}/build-${_arch}"
diff --git a/gnutls-3.2.7-rpath.patch b/gnutls-3.2.7-rpath.patch
deleted file mode 100644
index 4e6aed37a50f..000000000000
--- a/gnutls-3.2.7-rpath.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur gnutls-3.2.7.orig/configure gnutls-3.2.7/configure
---- gnutls-3.2.7.orig/configure 2013-11-23 11:09:49.000000000 +0100
-+++ gnutls-3.2.7/configure 2013-11-25 16:53:05.559440656 +0100
-@@ -39652,7 +39652,7 @@
- shlibpath_overrides_runpath=unknown
- version_type=none
- dynamic_linker="$host_os ld.so"
--sys_lib_dlsearch_path_spec="/lib /usr/lib"
-+sys_lib_dlsearch_path_spec="/lib /usr/lib /lib64 /usr/lib64"
- need_lib_prefix=unknown
- hardcode_into_libs=no
-