summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-06-18 22:23:12 +0200
committerMichel Zou2022-06-18 22:23:12 +0200
commit4dd94777e9870a8b5f01f34eb1ca8999db059675 (patch)
treea0e9e027529b8dca4b529d7dd75c6da2f92f3189
parent136f07e9fff149629a1b717c5a7003581c7b184d (diff)
downloadaur-4dd94777e9870a8b5f01f34eb1ca8999db059675.tar.gz
0.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34ba8bc770de..9eb313f4046e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = mingw-w64-google-glog
pkgdesc = Logging library for C++ (mingw-w64)
- pkgver = 0.4.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/google/glog
arch = any
license = custom:BSD3
- makedepends = make
makedepends = mingw-w64-cmake
options = !strip
options = !buildflags
options = staticlibs
- source = glog-0.4.0.tar.gz::https://github.com/google/glog/archive/v0.4.0.tar.gz
- sha512sums = b585f1819ade2075f6b61dc5aaca5c3f9d25601dba2bd08b6c49b96ac5f79db23c6b7f2042df003f7130497dd7241fcaa8b107d1f97385cb66ce52d3c554b176
+ source = glog-0.6.0.tar.gz::https://github.com/google/glog/archive/v0.6.0.tar.gz
+ sha512sums = fd2c42583d0dd72c790a8cf888f328a64447c5fb9d99b2e2a3833d70c102cb0eb9ae874632c2732424cc86216c8a076a3e24b23a793eaddb5da8a1dc52ba9226
pkgname = mingw-w64-google-glog
-
diff --git a/PKGBUILD b/PKGBUILD
index 3bbae8af48a6..67092fe8ec7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,30 @@
-# $Id$
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Contributor: Ian Yang <doit.ian@gmail.com>
-
_pkgname=glog
pkgname=mingw-w64-google-$_pkgname
-pkgver=0.4.0
+pkgver=0.6.0
pkgrel=1
pkgdesc="Logging library for C++ (mingw-w64)"
arch=(any)
license=('custom:BSD3')
url='https://github.com/google/glog'
-makedepends=('make' 'mingw-w64-cmake')
+makedepends=('mingw-w64-cmake')
options=(!strip !buildflags staticlibs)
source=("glog-$pkgver.tar.gz::https://github.com/google/glog/archive/v$pkgver.tar.gz")
-sha512sums=('b585f1819ade2075f6b61dc5aaca5c3f9d25601dba2bd08b6c49b96ac5f79db23c6b7f2042df003f7130497dd7241fcaa8b107d1f97385cb66ce52d3c554b176')
+sha512sums=('fd2c42583d0dd72c790a8cf888f328a64447c5fb9d99b2e2a3833d70c102cb0eb9ae874632c2732424cc86216c8a076a3e24b23a793eaddb5da8a1dc52ba9226')
+
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- #unset LDFLAGS
cd $_pkgname-$pkgver
- sed -i "/endif (HAVE_DBGHELP)/atarget_link_libraries (glog PUBLIC dbghelp ssp)" CMakeLists.txt
- sed -i "s/check_symbol_exists (snprintf stdio.h HAVE_SNPRINTF)/set (HAVE_SNPRINTF 1)/" CMakeLists.txt
+ sed -i "s/check_cxx_symbol_exists (snprintf cstdio HAVE_SNPRINTF)/set (HAVE_SNPRINTF 1)/" CMakeLists.txt
for _arch in ${_architectures}; do
mkdir -p build-$_arch
pushd build-$_arch
- $_arch-cmake .. -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS:BOOL=ON
+ $_arch-cmake .. -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS:BOOL=ON
make
popd
mkdir -p build-$_arch-static
pushd build-$_arch-static
- $_arch-cmake .. -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS:BOOL=OFF
+ $_arch-cmake .. -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS:BOOL=OFF
make
popd
done
@@ -38,15 +33,12 @@ build() {
package() {
cd $_pkgname-$pkgver
for _arch in ${_architectures}; do
- pushd build-$_arch
+ pushd build-$_arch-static
make DESTDIR="$pkgdir" install
popd
- pushd build-$_arch-static
+ pushd build-$_arch
make DESTDIR="$pkgdir" install
popd
- # Lazy way of dealing with conflicting man and info pages...
- rm -rf "${pkgdir}/usr/${_arch}/share"
- rm -rf "${pkgdir}/usr/${_arch}/lib/cmake/"
install -D -m644 COPYING "$pkgdir"/usr/${_arch}/share/licenses/google-$_pkgname/COPYING
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a