summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorosfans2017-05-16 10:27:53 +0800
committerosfans2017-05-16 10:27:53 +0800
commit640aeb0fd233283abfbbefcf4f7a2d48ec8848f7 (patch)
tree97da41b471d772d2e5bf68b3f1982f19c25f71c6
parent056fb072fb448b560510253a018e2a1c938cf5e1 (diff)
downloadaur-640aeb0fd233283abfbbefcf4f7a2d48ec8848f7.tar.gz
strip symbols
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e01606c5841a..8c43785ba269 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue May 9 14:26:19 UTC 2017
+# Tue May 16 02:27:26 UTC 2017
pkgbase = mingw-w64-google-glog
pkgdesc = Logging library for C++ (mingw-w64)
pkgver = 0.3.5
@@ -13,7 +13,7 @@ pkgbase = mingw-w64-google-glog
options = !buildflags
options = staticlibs
source = glog-0.3.5.tar.gz::https://github.com/google/glog/archive/v0.3.5.tar.gz
- sha512sums = 68b42ef42d57c9ede697c1423f8490deada06c9e9cb11a5e0ce53368e7e452c087d0e23bea50f51e1634b03eb4105e657c91318b6423c4e2a9c147b7334eb3f3
+ sha512sums = SKIP
pkgname = mingw-w64-google-glog
diff --git a/PKGBUILD b/PKGBUILD
index b7e7b9c4f84c..ab4c32b32e75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,12 @@ url='https://github.com/google/glog'
makedepends=('make' 'mingw-w64-cmake')
options=(!strip !buildflags staticlibs)
source=("glog-$pkgver.tar.gz::https://github.com/google/glog/archive/v$pkgver.tar.gz")
-sha512sums=('68b42ef42d57c9ede697c1423f8490deada06c9e9cb11a5e0ce53368e7e452c087d0e23bea50f51e1634b03eb4105e657c91318b6423c4e2a9c147b7334eb3f3')
+sha512sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- unset LDFLAGS
- cd $_pkgname
+ #unset LDFLAGS
+ cd $_pkgname-$pkgver
sed -i "s/BaseTsd/basetsd/" src/logging.cc
for _arch in ${_architectures}; do
mkdir -p build-$_arch
@@ -35,7 +35,7 @@ build() {
}
package() {
- cd $_pkgname
+ cd $_pkgname-$pkgver
for _arch in ${_architectures}; do
pushd build-$_arch
make DESTDIR="$pkgdir" install
@@ -46,6 +46,8 @@ package() {
# Lazy way of dealing with conflicting man and info pages...
rm -rf "${pkgdir}/usr/${_arch}/share"
install -D -m644 COPYING "$pkgdir"/usr/${_arch}/share/licenses/$_pkgname/COPYING
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}