diff options
author | Eduardo Bart | 2016-08-03 17:06:53 -0300 |
---|---|---|
committer | Eduardo Bart | 2016-08-03 17:06:53 -0300 |
commit | 2dad4327b2dc3b39059c4490812bcfd468cfc481 (patch) | |
tree | f71aab55b56e00e2f2493afe36c4b00bc266bd44 | |
parent | f86be655c46a26956b71bc3e0cb519168fd4b910 (diff) | |
download | aur-2dad4327b2dc3b39059c4490812bcfd468cfc481.tar.gz |
fix compile errors
-rw-r--r-- | PKGBUILD | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -18,17 +18,18 @@ prepare() { unset LDFLAGS cd "$_basename" ./autogen.sh + sed -i 's/\/\/ These are the methods we.re going to conditionally include\./#undef pthread_atfork/' src/maybe_threads.cc } build() { cd "$_basename" unset LDFLAGS - export CXXFLAGS="-Wno-narrowing" + export CXXFLAGS="${CXXFLAGS} -Wno-narrowing" for _arch in ${_architectures}; do mkdir -p build-${_arch} cd build-${_arch} - ${_arch}-configure --enable-frame-pointers + ${_arch}-configure --enable-frame-pointers --enable-minimal cp src/config.h ../src/config.h make cd .. |