summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2021-09-27 02:56:48 +0800
committerTing-Wei Lan2021-09-27 02:56:48 +0800
commitc3de91adb498df0e6629b96f9dd19537d02ac707 (patch)
tree3e597223e02d03809883dbfcb5c8bc81114950bb
downloadaur-c3de91adb498df0e6629b96f9dd19537d02ac707.tar.gz
mingw-w64-graphene: 1.10.6 (initial commit)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..838aea80bf07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-graphene
+ pkgdesc = A thin layer of graphic data types (mingw-w64)
+ pkgver = 1.10.6
+ pkgrel = 1
+ url = https://ebassi.github.io/graphene/
+ arch = any
+ license = MIT
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-meson
+ depends = mingw-w64-crt
+ depends = mingw-w64-glib2>=2.30.0
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/ebassi/graphene/releases/download/1.10.6/graphene-1.10.6.tar.xz
+ sha256sums = 80ae57723e4608e6875626a88aaa6f56dd25df75024bd16e9d77e718c3560b25
+
+pkgname = mingw-w64-graphene
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0afa748dc4ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: lantw44 (at) gmail (dot) com
+
+pkgname=mingw-w64-graphene
+pkgver=1.10.6
+pkgrel=1
+pkgdesc='A thin layer of graphic data types (mingw-w64)'
+arch=('any')
+url='https://ebassi.github.io/graphene/'
+license=('MIT')
+makedepends=(
+ 'mingw-w64-gcc'
+ 'mingw-w64-meson')
+depends=(
+ 'mingw-w64-crt'
+ 'mingw-w64-glib2>=2.30.0')
+options=('!strip' '!buildflags' 'staticlibs')
+source=(
+ "https://github.com/ebassi/graphene/releases/download/${pkgver}/graphene-${pkgver}.tar.xz")
+sha256sums=(
+ '80ae57723e4608e6875626a88aaa6f56dd25df75024bd16e9d77e718c3560b25')
+
+_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
+
+build() {
+ cd "${srcdir}/graphene-${pkgver}"
+ for _arch in "${_architectures[@]}"; do
+ mkdir -p "build-${_arch}"
+ cd "build-${_arch}"
+ "${_arch}-meson" \
+ --default-library both \
+ -Dgtk_doc=false \
+ -Dintrospection=disabled
+ ninja
+ cd ..
+ done
+}
+
+package() {
+ cd "${srcdir}/graphene-${pkgver}"
+ for _arch in "${_architectures[@]}"; do
+ cd "build-${_arch}"
+ DESTDIR="${pkgdir}" ninja install
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec "${_arch}-strip" '{}' ';'
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec "${_arch}-strip" --strip-unneeded '{}' ';'
+ find "${pkgdir}/usr/${_arch}" '(' -name '*.a' -o -name '*.dll' ')' -exec "${_arch}-strip" -g '{}' ';'
+ cd ..
+ done
+}