summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Spies2015-12-24 06:41:29 -0330
committerLukas Spies2015-12-24 06:41:29 -0330
commita1d31f60655b974381d0a59d99fff5a713aef5ad (patch)
tree154acd36f4aaaf8903687f25729a80fa589d3e74
parent069f147f67589f50bcadb33983fa5e41e23337ce (diff)
downloadaur-a1d31f60655b974381d0a59d99fff5a713aef5ad.tar.gz
[1.3.23] Dependency libltdl is commented out, not AUR package available atm (only in some external repos)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eb344420829..38ec359bf1d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Dec 23 23:27:46 UTC 2015
+# Thu Dec 24 10:10:39 UTC 2015
pkgbase = mingw-w64-graphicsmagick
pkgdesc = Image processing system (mingw-w64)
pkgver = 1.3.23
diff --git a/PKGBUILD b/PKGBUILD
index be76525e68cf..bb800d9a3963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,14 +20,23 @@ md5sums=('9885ff5d91bc215a0adb3be1185e9777')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
+
cd "${srcdir}/GraphicsMagick-$pkgver/"
+
for _arch in ${_architectures}; do
+
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --enable-shared --without-x --with-quantum-depth=16 --with-modules --with-threads
+
+ ### NOTE ###
+ # if you manage to get libltdl installed, you can add the flag '--with-modules' for support of synamically loaded modules
+ ${_arch}-configure --enable-shared --without-x --with-quantum-depth=16 --with-threads
+
sed -i "s/\/usr\/include/\/usr\/${_arch}\/include/g" Makefile
sed -i "s/\/usr\/lib/\/usr\/${_arch}\/lib/g" Makefile
- make
+
+ make -j4
popd
+
done
}