summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-08-18 21:28:43 +0800
committerpingplug2018-08-18 21:30:02 +0800
commit51259db5329f2c5776afccbb8fa9b91820274a2c (patch)
treeb91c08a01c970e20a94352f30519e93a0076d342
parent8086a2e6deef5b707ce8f0a9136397fe47c8c86a (diff)
downloadaur-51259db5329f2c5776afccbb8fa9b91820274a2c.tar.gz
Updated to 1.3.12
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore12
-rw-r--r--001-graphite2-1.3.8-win64.patch26
-rw-r--r--003-graphite2-1.3.8-staticbuild.patch6
-rw-r--r--PKGBUILD56
5 files changed, 45 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 681cf6f23258..e99e6def2a3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-graphite
- pkgdesc = reimplementation of the SIL Graphite text processing engine (mingw-w64)
- pkgver = 1.3.11
+ pkgdesc = Reimplementation of the SIL Graphite text processing engine (mingw-w64)
+ pkgver = 1.3.12
pkgrel = 1
url = https://github.com/silnrsi/graphite
arch = any
@@ -10,17 +10,15 @@ pkgbase = mingw-w64-graphite
makedepends = mingw-w64-cmake
makedepends = python2
depends = mingw-w64-crt
- options = staticlibs
options = !strip
+ options = staticlibs
options = !buildflags
- source = https://github.com/silnrsi/graphite/releases/download/1.3.11/graphite2-1.3.11.tgz
- source = 001-graphite2-1.3.8-win64.patch
+ source = https://github.com/silnrsi/graphite/releases/download/1.3.12/graphite2-1.3.12.tgz
source = 002-graphite2-1.2.1-pkgconfig.patch
source = 003-graphite2-1.3.8-staticbuild.patch
- sha1sums = 26b70897bac68868d964ef70002c384ec10b6572
- sha1sums = 68c7b3c1c9e38f357a95e5b3b266d4afcfe78329
- sha1sums = 4460d61e238892c421ae7771e3b36dc0b21d682c
- sha1sums = da2c20e50cd50a6cac422fd69459060a02311988
+ sha256sums = cd9530c16955c181149f9af1f13743643771cb920c75a04c95c77c871a2029d0
+ sha256sums = 22bef0d90c0266b3b0eff01859c1e002f84c165d12242c2bfc153f8f98fb272a
+ sha256sums = 5d9512f44ee82e4d8bf273f9a909a64d478cdb3a27f932f377c2863afa092cb2
pkgname = mingw-w64-graphite
diff --git a/.gitignore b/.gitignore
index 19ea2a25c1e9..97589fb4de69 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
-pkg/
-src/
-*.log
-*.tar
-*.tgz
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.install
+!*.patch
+!*.diff
diff --git a/001-graphite2-1.3.8-win64.patch b/001-graphite2-1.3.8-win64.patch
deleted file mode 100644
index cd00c3d6e4cd..000000000000
--- a/001-graphite2-1.3.8-win64.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- graphite2-1.3.8/src/inc/json.h.orig 2016-04-01 03:31:38.543833400 -0400
-+++ graphite2-1.3.8/src/inc/json.h 2016-04-01 03:38:38.112543400 -0400
-@@ -86,6 +86,10 @@ public:
- json & operator << (number) throw();
- json & operator << (integer) throw();
- json & operator << (long unsigned int d) throw();
-+#ifdef _WIN32
-+ json & operator << (unsigned __int64 d) throw();
-+ json & operator << (__int64 d) throw();
-+#endif
- json & operator << (boolean) throw();
- json & operator << (_null_t) throw();
- json & operator << (_context_t) throw();
---- graphite2-1.3.8/src/json.cpp.orig 2016-04-01 03:31:38.550833700 -0400
-+++ graphite2-1.3.8/src/json.cpp 2016-04-01 03:41:05.363588200 -0400
-@@ -133,6 +133,10 @@ json & json::operator << (json::number f
- }
- json & json::operator << (json::integer d) throw() { context(seq); fprintf(_stream, "%ld", d); return *this; }
- json & json::operator << (long unsigned d) throw() { context(seq); fprintf(_stream, "%ld", d); return *this; }
-+#ifdef _WIN32
-+json & json::operator << (unsigned __int64 d) throw() { context(seq); fprintf(_stream, "%I64", d); return *this; }
-+json & json::operator << (__int64 d) throw() { context(seq); fprintf(_stream, "%I64", d); return *this; }
-+#endif
- json & json::operator << (json::boolean b) throw() { context(seq); fputs(b ? "true" : "false", _stream); return *this; }
- json & json::operator << (json::_null_t) throw() { context(seq); fputs("null",_stream); return *this; }
-
diff --git a/003-graphite2-1.3.8-staticbuild.patch b/003-graphite2-1.3.8-staticbuild.patch
index 74b864e31415..ab37b1ec0009 100644
--- a/003-graphite2-1.3.8-staticbuild.patch
+++ b/003-graphite2-1.3.8-staticbuild.patch
@@ -1,6 +1,6 @@
--- graphite2-1.3.8/src/CMakeLists.txt.orig 2016-09-17 06:30:02.570522500 -0400
+++ graphite2-1.3.8/src/CMakeLists.txt 2016-09-17 06:33:57.962672400 -0400
-@@ -106,6 +106,48 @@
+@@ -106,6 +106,46 @@
LT_VERSION_REVISION ${GRAPHITE_API_REVISION}
LT_VERSION_AGE ${GRAPHITE_API_AGE})
@@ -13,7 +13,6 @@
+ gr_logging.cpp
+ gr_segment.cpp
+ gr_slot.cpp
-+ CachedFace.cpp
+ CmapCache.cpp
+ Code.cpp
+ Collider.cpp
@@ -35,7 +34,6 @@
+ TtfUtil.cpp
+ UtfCodec.cpp
+ ${FILEFACE}
-+ ${SEGCACHE}
+ ${TRACING})
+
+set_target_properties(graphite2_static PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
@@ -49,7 +47,7 @@
if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
set_target_properties(graphite2 PROPERTIES
COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden -fno-stack-protector"
-@@ -148,8 +190,11 @@
+@@ -148,8 +188,11 @@
if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
set_target_properties(graphite2 PROPERTIES
COMPILE_DEFINITIONS "_SCL_SECURE_NO_WARNINGS;_CRT_SECURE_NO_WARNINGS;UNICODE;GRAPHITE2_EXPORTING")
diff --git a/PKGBUILD b/PKGBUILD
index 86aea2934853..898d50fd70b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
+# Maintainer: pingplug <pingplug@foxmail.com>
+# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
pkgname=mingw-w64-graphite
-pkgver=1.3.11
+pkgver=1.3.12
pkgrel=1
-arch=(any)
-pkgdesc="reimplementation of the SIL Graphite text processing engine (mingw-w64)"
-license=("LGPL" "GPL" "custom")
-depends=(mingw-w64-crt)
-makedepends=(mingw-w64-cmake python2)
-options=(staticlibs !strip !buildflags)
+pkgdesc="Reimplementation of the SIL Graphite text processing engine (mingw-w64)"
+arch=('any')
url="https://github.com/silnrsi/graphite"
+license=('LGPL' 'GPL' 'custom')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake'
+ 'python2')
+options=('!strip' 'staticlibs' '!buildflags')
source=("https://github.com/silnrsi/graphite/releases/download/${pkgver}/graphite2-${pkgver}.tgz"
-"001-graphite2-1.3.8-win64.patch"
-"002-graphite2-1.2.1-pkgconfig.patch"
-"003-graphite2-1.3.8-staticbuild.patch")
-sha1sums=('26b70897bac68868d964ef70002c384ec10b6572'
- '68c7b3c1c9e38f357a95e5b3b266d4afcfe78329'
- '4460d61e238892c421ae7771e3b36dc0b21d682c'
- 'da2c20e50cd50a6cac422fd69459060a02311988')
-
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+ "002-graphite2-1.2.1-pkgconfig.patch"
+ "003-graphite2-1.3.8-staticbuild.patch")
+sha256sums=('cd9530c16955c181149f9af1f13743643771cb920c75a04c95c77c871a2029d0'
+ '22bef0d90c0266b3b0eff01859c1e002f84c165d12242c2bfc153f8f98fb272a'
+ '5d9512f44ee82e4d8bf273f9a909a64d478cdb3a27f932f377c2863afa092cb2')
prepare() {
- cd graphite2-$pkgver
- patch -p1 -i "${srcdir}"/001-graphite2-1.3.8-win64.patch
+ cd graphite2-${pkgver}
patch -p1 -i "${srcdir}"/002-graphite2-1.2.1-pkgconfig.patch
patch -p1 -i "${srcdir}"/003-graphite2-1.3.8-staticbuild.patch
sed -i "s:\/usr\/bin\/python:\/usr\/bin\/python2:" tests/{corrupt.py,defuzz,fnttxtrender,fuzzbidi,fuzztest,hbspeeds,jsoncmp}
}
build() {
- cd graphite2-$pkgver
- for _arch in ${_architectures}; do
- unset LDFLAGS
+ cd graphite2-${pkgver}
+ for _arch in ${_architectures}; do
mkdir "build-${_arch}" && pushd "build-${_arch}"
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \
@@ -42,11 +42,13 @@ build() {
}
package() {
- for _arch in ${_architectures}; do
- cd "${srcdir}/${pkgname#mingw-w64-}2-$pkgver/build-${_arch}"
- make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname#mingw-w64-}2-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}
+
+# vim:set ts=2 sw=2 et: