summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-06-08 22:50:02 +0200
committerxantares2015-06-08 22:50:02 +0200
commit4a0ff727a7739a8472033e03bd0e13c49456d734 (patch)
tree3e3a00a3b4e219b711beb3809fb8887973b86509
downloadaur-4a0ff727a7739a8472033e03bd0e13c49456d734.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57d413106c93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-gsl
+ pkgdesc = The GNU Scientific Library (GSL) is a modern numerical library for C and C++ programmers (mingw-w64)
+ pkgver = 1.16
+ pkgrel = 3
+ url = http://www.gnu.org/software/gsl/gsl.html
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://mirror.ibcp.fr/pub/gnu/gsl/gsl-1.16.tar.gz
+ md5sums = e49a664db13d81c968415cd53f62bc8b
+
+pkgname = mingw-w64-gsl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db074c600d23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+
+pkgname=mingw-w64-gsl
+pkgver=1.16
+pkgrel=3
+pkgdesc="The GNU Scientific Library (GSL) is a modern numerical library for C and C++ programmers (mingw-w64)"
+arch=(any)
+url="http://www.gnu.org/software/gsl/gsl.html"
+license=("GPL")
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-crt')
+options=('staticlibs' '!strip' '!buildflags')
+source=("http://mirror.ibcp.fr/pub/gnu/gsl/gsl-$pkgver.tar.gz")
+md5sums=('e49a664db13d81c968415cd53f62bc8b')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/gsl-$pkgver"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/gsl-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}