summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-04-27 23:09:22 +0200
committerNicola Murino2019-04-27 23:09:22 +0200
commit014099aa7fcede17d49c2c9dd93ac934fc5b9c19 (patch)
treef4c792c7d738d96ba21cf4f1df6e4b5ef9b15dab
parent94e3b63e4b01f7e4a911753b9bb94673ef625ea9 (diff)
downloadaur-014099aa7fcede17d49c2c9dd93ac934fc5b9c19.tar.gz
add WebRTC plugin
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d22a0dd2753..6cc9b2bbc1db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-gst-plugins-bad
pkgdesc = GStreamer Multimedia Framework Bad Plugins (mingw-w64)
pkgver = 1.16.0
- pkgrel = 1
+ pkgrel = 2
url = http://gstreamer.freedesktop.org/
arch = any
license = LGPL
@@ -21,6 +21,7 @@ pkgbase = mingw-w64-gst-plugins-bad
makedepends = mingw-w64-libwebp
makedepends = mingw-w64-srt
makedepends = mingw-w64-curl
+ makedepends = mingw-w64-libnice
depends = mingw-w64-gst-plugins-base
depends = mingw-w64-orc
optdepends = mingw-w64-openh264: H.264 video codec plugin
@@ -36,6 +37,7 @@ pkgbase = mingw-w64-gst-plugins-bad
optdepends = mingw-w64-srt: Secure, Reliable, Transport client/server network source/sink plugin
optdepends = mingw-w64-curl: cURL network source and sink plugin
optdepends = mingw-w64-bzip2: bz2 stream encoder and decoder plugin
+ optdepends = mingw-w64-libice: WebRTC audio/video network bin plugin
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index 539faec18653..79464c394f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-gst-plugins-bad
pkgver=1.16.0
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer Multimedia Framework Bad Plugins (mingw-w64)"
arch=(any)
url="http://gstreamer.freedesktop.org/"
license=('LGPL')
depends=('mingw-w64-gst-plugins-base' 'mingw-w64-orc')
-makedepends=('mingw-w64-meson' 'mingw-w64-openh264' 'mingw-w64-nettle' 'mingw-w64-opus' 'mingw-w64-bzip2' 'mingw-w64-libsrtp' 'mingw-w64-vo-aacenc' 'mingw-w64-libkate' 'mingw-w64-librsvg' 'mingw-w64-openjpeg2' 'mingw-w64-opencv' 'mingw-w64-libfdk-aac' 'mingw-w64-librtmp0' 'mingw-w64-libwebp' 'mingw-w64-srt' 'mingw-w64-curl')
+makedepends=('mingw-w64-meson' 'mingw-w64-openh264' 'mingw-w64-nettle' 'mingw-w64-opus' 'mingw-w64-bzip2' 'mingw-w64-libsrtp' 'mingw-w64-vo-aacenc' 'mingw-w64-libkate' 'mingw-w64-librsvg' 'mingw-w64-openjpeg2' 'mingw-w64-opencv' 'mingw-w64-libfdk-aac' 'mingw-w64-librtmp0' 'mingw-w64-libwebp' 'mingw-w64-srt' 'mingw-w64-curl' 'mingw-w64-libnice')
optdepends=(
"mingw-w64-openh264: H.264 video codec plugin"
"mingw-w64-opus: OPUS audio parser plugin"
@@ -22,6 +22,7 @@ optdepends=(
"mingw-w64-srt: Secure, Reliable, Transport client/server network source/sink plugin"
"mingw-w64-curl: cURL network source and sink plugin"
"mingw-w64-bzip2: bz2 stream encoder and decoder plugin"
+ "mingw-w64-libice: WebRTC audio/video network bin plugin"
)
options=('!strip' '!buildflags' 'staticlibs')