summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-07-25 13:42:25 +0200
committerNicola Murino2018-07-25 13:42:25 +0200
commitd2cdade7524424aa3b51c0fad4bfbde500bc5758 (patch)
tree22b75d96d64dd8fcaace62e977f5b641c3e8c6a3
parentd8176d71d1d52f5c1ec975511101a49db7bc0d19 (diff)
downloadaur-d2cdade7524424aa3b51c0fad4bfbde500bc5758.tar.gz
Fix build for opencv >= 3.4.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--c247745faaf885fd3fa094198fc0ea288e295dbf.patch66
3 files changed, 81 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 682dde788833..8470e192314f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jul 25 09:12:02 UTC 2018
+# Wed Jul 25 11:41:09 UTC 2018
pkgbase = mingw-w64-gst-plugins-bad
pkgdesc = GStreamer Multimedia Framework Bad Plugins (mingw-w64)
pkgver = 1.14.2
- pkgrel = 1
+ pkgrel = 2
url = http://gstreamer.freedesktop.org/
arch = any
license = LGPL
@@ -27,7 +27,9 @@ pkgbase = mingw-w64-gst-plugins-bad
options = !buildflags
options = staticlibs
source = http://gstreamer.freedesktop.org//src/gst-plugins-bad/gst-plugins-bad-1.14.2.tar.xz
+ source = c247745faaf885fd3fa094198fc0ea288e295dbf.patch
sha256sums = 34fab7da70994465a64468330b2168a4a0ed90a7de7e4c499b6d127c6c1b1eaf
+ sha256sums = 65f6de70e7f08cd60fa913270f44c99baabd51b64bae3669c62d2b5cde1142eb
pkgname = mingw-w64-gst-plugins-bad
diff --git a/PKGBUILD b/PKGBUILD
index b4e043526faf..c932194301b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-gst-plugins-bad
pkgver=1.14.2
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer Multimedia Framework Bad Plugins (mingw-w64)"
arch=(any)
url="http://gstreamer.freedesktop.org/"
@@ -10,11 +10,19 @@ depends=('mingw-w64-gstreamer' 'mingw-w64-orc')
makedepends=('mingw-w64-configure' 'mingw-w64-openh264' 'mingw-w64-nettle' 'mingw-w64-opus' 'mingw-w64-bzip2' 'mingw-w64-libsrtp' 'mingw-w64-vo-aacenc' 'mingw-w64-libkate' 'mingw-w64-librsvg' 'mingw-w64-openjpeg2' 'mingw-w64-opencv' 'mingw-w64-libfdk-aac' 'mingw-w64-librtmp0' 'mingw-w64-libwebp')
options=('!strip' '!buildflags' 'staticlibs')
-source=(${url}/src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz)
-sha256sums=('34fab7da70994465a64468330b2168a4a0ed90a7de7e4c499b6d127c6c1b1eaf')
+source=(${url}/src/gst-plugins-bad/gst-plugins-bad-${pkgver}.tar.xz
+ 'c247745faaf885fd3fa094198fc0ea288e295dbf.patch')
+sha256sums=('34fab7da70994465a64468330b2168a4a0ed90a7de7e4c499b6d127c6c1b1eaf'
+ '65f6de70e7f08cd60fa913270f44c99baabd51b64bae3669c62d2b5cde1142eb')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/gst-plugins-bad-${pkgver}"
+
+ patch -Np1 < ../c247745faaf885fd3fa094198fc0ea288e295dbf.patch
+}
+
build() {
cd "${srcdir}/gst-plugins-bad-${pkgver}"
diff --git a/c247745faaf885fd3fa094198fc0ea288e295dbf.patch b/c247745faaf885fd3fa094198fc0ea288e295dbf.patch
new file mode 100644
index 000000000000..6671e058c85c
--- /dev/null
+++ b/c247745faaf885fd3fa094198fc0ea288e295dbf.patch
@@ -0,0 +1,66 @@
+From c247745faaf885fd3fa094198fc0ea288e295dbf Mon Sep 17 00:00:00 2001
+From: Thibault Saunier <tsaunier@igalia.com>
+Date: Fri, 13 Jul 2018 14:42:28 -0400
+Subject: opencv: Fix build for opencv >= 3.4.2
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The `CV_RGB` macro is now in `imgproc.hpp`.
+
+Fixes:
+
+ ../subprojects/gst-plugins-bad/ext/opencv/gsthanddetect.cpp:497:40: error: ‘CV_RGB’ was not declared in this scope
+ cvCircle (img, center, radius, CV_RGB (0, 0, 200), 1, 8, 0);
+ ^~~~~~
+---
+ ext/opencv/MotionCells.cpp | 3 +++
+ ext/opencv/gsthanddetect.cpp | 3 +++
+ ext/opencv/gsttemplatematch.cpp | 3 +++
+ 3 files changed, 9 insertions(+)
+
+diff --git a/ext/opencv/MotionCells.cpp b/ext/opencv/MotionCells.cpp
+index f85989e..175ec90 100644
+--- a/ext/opencv/MotionCells.cpp
++++ b/ext/opencv/MotionCells.cpp
+@@ -51,6 +51,9 @@
+
+ #include <errno.h>
+ #include "MotionCells.h"
++#if (CV_MAJOR_VERSION >= 3)
++#include <opencv2/imgproc.hpp>
++#endif
+ #include <opencv2/imgproc/imgproc_c.h>
+
+ MotionCells::MotionCells ()
+diff --git a/ext/opencv/gsthanddetect.cpp b/ext/opencv/gsthanddetect.cpp
+index 60fd5be..47203fd 100644
+--- a/ext/opencv/gsthanddetect.cpp
++++ b/ext/opencv/gsthanddetect.cpp
+@@ -62,6 +62,9 @@
+
+ /* element header */
+ #include "gsthanddetect.h"
++#if (CV_MAJOR_VERSION >= 3)
++#include <opencv2/imgproc.hpp>
++#endif
+ #include <opencv2/imgproc/imgproc_c.h>
+
+ GST_DEBUG_CATEGORY_STATIC (gst_handdetect_debug);
+diff --git a/ext/opencv/gsttemplatematch.cpp b/ext/opencv/gsttemplatematch.cpp
+index f39208d..ec0b56a 100644
+--- a/ext/opencv/gsttemplatematch.cpp
++++ b/ext/opencv/gsttemplatematch.cpp
+@@ -63,6 +63,9 @@
+
+ #include "../../gst-libs/gst/gst-i18n-plugin.h"
+ #include "gsttemplatematch.h"
++#if (CV_MAJOR_VERSION >= 3)
++#include <opencv2/imgproc.hpp>
++#endif
+ #include <opencv2/imgproc/imgproc_c.h>
+
+ GST_DEBUG_CATEGORY_STATIC (gst_template_match_debug);
+--
+cgit v1.1
+