summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2016-06-26 16:08:50 -0400
committerXiao-Long Chen2016-06-26 16:08:50 -0400
commit7bd059df740f4ec714b58858fb370d598802028b (patch)
tree6cc8bd0201c787c15941ba67416df01abc400bcc
downloadaur-7bd059df740f4ec714b58858fb370d598802028b.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD56
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..459eea9f4a60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Jun 26 20:08:22 UTC 2016
+pkgbase = mingw-w64-gtest
+ pkgdesc = Google Test - C++ testing utility based on the xUnit framework (like JUnit)
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://github.com/google/googletest
+ arch = any
+ license = custom:BSD3
+ makedepends = mingw-w64-cmake
+ makedepends = python2
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ source = https://github.com/google/googletest/archive/release-1.7.0.tar.gz
+ sha512sums = c623d5720c4ed574e95158529872815ecff478c03bdcee8b79c9b042a603533f93fe55f939bcfe2cd745ce340fd626ad6d9a95981596f1a4d05053d874cd1dfc
+
+pkgname = mingw-w64-gtest
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c906e75958f4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b644d3b4de4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# $Id: PKGBUILD 151545 2015-12-10 03:56:01Z foutrelis $
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Contributor: Felix Yan <felixonmars@gmail.com>
+# Contributor: Alexandre Bique <bique.alexandre@gmail.com>
+# Contributor: Louis R. Marascio <lrm@fitnr.com>
+# Contributor: Cody Maloney <cmaloney@theoreticalchaos.com>
+
+pkgname=mingw-w64-gtest
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="Google Test - C++ testing utility based on the xUnit framework (like JUnit)"
+arch=(any)
+url="https://github.com/google/googletest"
+license=(custom:BSD3)
+depends=(mingw-w64-crt)
+makedepends=(mingw-w64-cmake python2)
+options=(!buildflags staticlibs !strip)
+source=("https://github.com/google/googletest/archive/release-${pkgver}.tar.gz")
+sha512sums=('c623d5720c4ed574e95158529872815ecff478c03bdcee8b79c9b042a603533f93fe55f939bcfe2cd745ce340fd626ad6d9a95981596f1a4d05053d874cd1dfc')
+
+_mingw_arch=(i686-w64-mingw32 x86_64-w64-mingw32)
+
+build() {
+ cd "googletest-release-${pkgver}"
+
+ for _arch in "${_mingw_arch[@]}"; do
+ mkdir -p "build_${_arch}"
+ pushd "build_${_arch}"
+ "${_arch}-cmake" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_SKIP_RPATH=ON \
+ ..
+ make
+ popd
+ done
+
+ python2 scripts/fuse_gtest_files.py fused-src
+}
+
+package() {
+ cd "googletest-release-${pkgver}"
+
+ for _arch in "${_mingw_arch[@]}"; do
+ mkdir -pm 0755 "${pkgdir}/${_arch}"/{bin,lib,include/gtest/internal,share/licenses/${pkgname},src/gtest/src,src/gtest/cmake}
+ install -m 0644 "build_${_arch}"/libgtest{,_main}.dll "${pkgdir}/${_arch}"/bin
+ install -m 0644 "build_${_arch}"/libgtest{,_main}.dll.a "${pkgdir}/${_arch}"/lib
+ install -m 0644 include/gtest/*.h "${pkgdir}/${_arch}"/include/gtest
+ install -m 0644 include/gtest/internal/*.h "${pkgdir}/${_arch}"/include/gtest/internal/
+ install -m 0644 LICENSE "${pkgdir}/${_arch}"/share/licenses/${pkgname}/
+ install -m 0644 fused-src/gtest/* "${pkgdir}/${_arch}"/src/gtest/src/
+ install -m 0644 CMakeLists.txt "${pkgdir}/${_arch}"/src/gtest/
+ install -m 0644 cmake/* "${pkgdir}/${_arch}"/src/gtest/cmake/
+ done
+}