summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2014-11-19 16:55:07 +0800
committerTing-Wei Lan2014-11-19 16:55:44 +0800
commit0eec4826708c7ecb68e2848d9194fa3243748fb2 (patch)
tree345fbeb7eda8f66ddfb3f783ea326f21538e3121
parent86de2ea79a8987151957a645012621eccdbd14bc (diff)
downloadaur-0eec4826708c7ecb68e2848d9194fa3243748fb2.tar.gz
mingw-w64-{gdk-pixbuf2,gtk2,gtk3}: Use mingw-w64-configure
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD52
2 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1bb081efcad..96e59986fbcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = mingw-w64-gtk3
license = LGPL
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = mingw-w64-configure
makedepends = gtk-update-icon-cache
makedepends = python2
depends = mingw-w64-crt
diff --git a/PKGBUILD b/PKGBUILD
index 35e082162d92..73d4b22e2f35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,30 @@
pkgname=mingw-w64-gtk3
pkgver=3.14.5
pkgrel=1
-pkgdesc="GObject-based multi-platform GUI toolkit (v3) (mingw-w64)"
+pkgdesc='GObject-based multi-platform GUI toolkit (v3) (mingw-w64)'
arch=(any)
-url="http://www.gtk.org"
-license=("LGPL")
-makedepends=(mingw-w64-gcc mingw-w64-pkg-config gtk-update-icon-cache python2)
-# python2 is required to run gdbus-codegen
+url='http://www.gtk.org'
+license=('LGPL')
+makedepends=(
+ 'mingw-w64-gcc'
+ 'mingw-w64-pkg-config'
+ 'mingw-w64-configure'
+ 'gtk-update-icon-cache'
+ 'python2') # python2 is required to run gdbus-codegen
depends=(
-'mingw-w64-crt'
-'mingw-w64-atk>=2.12.0'
-'mingw-w64-pango>=1.36.7'
-'mingw-w64-glib2>=2.41.2'
-'mingw-w64-cairo>=1.12.0'
-'mingw-w64-gdk-pixbuf2>=2.30.0')
+ 'mingw-w64-crt'
+ 'mingw-w64-atk>=2.12.0'
+ 'mingw-w64-pango>=1.36.7'
+ 'mingw-w64-glib2>=2.41.2'
+ 'mingw-w64-cairo>=1.12.0'
+ 'mingw-w64-gdk-pixbuf2>=2.30.0')
options=(!strip !buildflags staticlibs)
source=(
-"http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
-"0005-Remove-gobject-introspection.patch"
-"gtk3-bug-731013-fix-cross-compilation.patch"
-"window-GtkPlug-is-conditionally-supported-on-X11-o.patch")
+ "http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
+ "0005-Remove-gobject-introspection.patch"
+ "gtk3-bug-731013-fix-cross-compilation.patch"
+ "window-GtkPlug-is-conditionally-supported-on-X11-o.patch")
# The third patch is downloaded from Fedora Project
# The fourth patch: https://bugzilla.gnome.org/show_bug.cgi?id=739885
@@ -42,34 +46,30 @@ build() {
autoreconf -i
for _arch in ${_architectures}; do
unset LDFLAGS
- export CFLAGS="-O2 -mms-bitfields"
- export CXXFLAGS="${CFLAGS}"
export PKG_CONFIG="${_arch}-pkg-config"
export PKG_CONFIG_FOR_BUILD="pkg-config"
- mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
- cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ mkdir -p "build-${_arch}"
+ cd "build-${_arch}"
msg "Starting configure and make"
- ${srcdir}/gtk+-${pkgver}/configure \
- --prefix=/usr/${_arch} \
- --build=$CHOST \
- --host=${_arch} \
+ ${_arch}-configure \
--enable-win32-backend \
--enable-gtk2-dependency \
- --enable-static \
- --enable-shared \
--disable-cups
make
+ cd ..
done
}
package() {
+ cd "${srcdir}/gtk+-${pkgver}"
for _arch in ${_architectures}; do
- cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ cd "build-${_arch}"
make -j1 DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' -o -name '*.manifest' | xargs -rtl1 rm
find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
rm -r "$pkgdir/usr/${_arch}/etc"
rm -r "$pkgdir/usr/${_arch}/share/man"
+ cd ..
done
}