summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2021-09-25 02:49:47 +0800
committerTing-Wei Lan2021-09-25 02:49:47 +0800
commit1f20bc9a4d928a4bc1f1724472992ff6f86cd15d (patch)
tree68edb230dc5dfee2d6e285f2a7a160a3c35fb2b0
parent7f9c79ce5c1bedb1d6822583d7c3caeaff36f9cc (diff)
downloadaur-1f20bc9a4d928a4bc1f1724472992ff6f86cd15d.tar.gz
mingw-w64-gtk3: 3.24.29 -> 3.24.30
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--gtk3-merge-3991-fix-autotools-build.patch43
3 files changed, 61 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 155174be3106..1839e8fc9124 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-gtk3
pkgdesc = GObject-based multi-platform GUI toolkit (mingw-w64)
- pkgver = 3.24.29
+ pkgver = 3.24.30
pkgrel = 1
url = https://www.gtk.org
install = mingw-w64-gtk3.install
@@ -24,8 +24,11 @@ pkgbase = mingw-w64-gtk3
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.gnome.org/sources/gtk+/3.24/gtk+-3.24.29.tar.xz
- sha256sums = f57ec4ade8f15cab0c23a80dcaee85b876e70a8823d9105f067ce335a8268caa
+ source = https://download.gnome.org/sources/gtk+/3.24/gtk+-3.24.30.tar.xz
+ source = gtk3-merge-3991-fix-autotools-build.patch
+ source = mingw-w64-gtk3-3.24.30-winpointer.h::https://gitlab.gnome.org/GNOME/gtk/-/raw/3.24.30/gdk/win32/winpointer.h
+ sha256sums = ba75bfff320ad1f4cfbee92ba813ec336322cc3c660d406aad014b07087a3ba9
+ sha256sums = 17d1a2307655a648f9f321cd720e6207fa507ea7cae8f72445621dc8313ec3a6
+ sha256sums = 66d01eb23bc87533f7838f298354567c52ce246d9c8270ed503d5d5b654c2cd0
pkgname = mingw-w64-gtk3
-
diff --git a/PKGBUILD b/PKGBUILD
index 9673168641b5..49143b92aef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: lantw44 at gmail dot com
pkgname=mingw-w64-gtk3
-pkgver=3.24.29
+pkgver=3.24.30
pkgrel=1
pkgdesc='GObject-based multi-platform GUI toolkit (mingw-w64)'
arch=('any')
@@ -27,9 +27,13 @@ depends=(
'mingw-w64-pango>=1.41.0')
options=('!strip' '!buildflags' 'staticlibs')
source=(
- "https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz")
+ "https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
+ 'gtk3-merge-3991-fix-autotools-build.patch'
+ "${pkgname}-${pkgver}-winpointer.h::https://gitlab.gnome.org/GNOME/gtk/-/raw/${pkgver}/gdk/win32/winpointer.h")
sha256sums=(
- 'f57ec4ade8f15cab0c23a80dcaee85b876e70a8823d9105f067ce335a8268caa')
+ 'ba75bfff320ad1f4cfbee92ba813ec336322cc3c660d406aad014b07087a3ba9'
+ '17d1a2307655a648f9f321cd720e6207fa507ea7cae8f72445621dc8313ec3a6'
+ '66d01eb23bc87533f7838f298354567c52ce246d9c8270ed503d5d5b654c2cd0')
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
@@ -43,10 +47,14 @@ prepare() {
;;
esac
done
+ for source_file in "${source[@]:2:1}"; do
+ cp "${srcdir}/${source_file%%::*}" "gdk/win32/${source_file##*/}"
+ done
}
build() {
cd "${srcdir}/gtk+-${pkgver}"
+ NOCONFIGURE=1 ./autogen.sh
for _arch in "${_architectures[@]}"; do
export PKG_CONFIG="${_arch}-pkg-config"
export PKG_CONFIG_FOR_BUILD="pkg-config"
diff --git a/gtk3-merge-3991-fix-autotools-build.patch b/gtk3-merge-3991-fix-autotools-build.patch
new file mode 100644
index 000000000000..38f4cd6c9709
--- /dev/null
+++ b/gtk3-merge-3991-fix-autotools-build.patch
@@ -0,0 +1,43 @@
+From 26d61e2abc22707e628045b1c33ea9930e8ca0dc Mon Sep 17 00:00:00 2001
+From: Ting-Wei Lan <lantw@src.gnome.org>
+Date: Fri, 24 Sep 2021 00:06:51 +0800
+Subject: [PATCH] GDK/Win32: Fix MinGW autotools build
+
+MinGW-w64 CRT provides no 'hid.lib' file. Instead, it has 'libhid.a'
+which can be linked with '-lhid' linker argument.
+
+Also, we have to declare the '_LIBADD' variable and add 'LDADDS' to it,
+or 'LDADDS' won't do anything for the build.
+
+https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/3991
+---
+ gdk/win32/Makefile.am | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/gdk/win32/Makefile.am b/gdk/win32/Makefile.am
+index 5fe1289570..21f4579192 100644
+--- a/gdk/win32/Makefile.am
++++ b/gdk/win32/Makefile.am
+@@ -22,7 +22,7 @@ AM_CPPFLAGS += "-DGDK_WIN32_ENABLE_EGL=1"
+ endif #WIN32_GLES
+
+ libgdk_win32_DEP_LIBS = \
+- hid.lib
++ -lhid
+
+ LDADDS = $(libgdk_win32_DEP_LIBS) $(GDK_DEP_LIBS)
+
+@@ -87,6 +87,10 @@ libgdk_win32_la_SOURCES = \
+ wintab.h \
+ xcursors.h
+
++libgdk_win32_la_LIBADD = \
++ $(LDADDS) \
++ $(NULL)
++
+ libgdkinclude_HEADERS = \
+ gdkwin32.h
+
+--
+GitLab
+