summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2022-01-21 00:20:52 +0800
committerTing-Wei Lan2022-01-21 00:20:52 +0800
commit469a0ec49dfd943fcce33c7aae077e2cbf65bfff (patch)
treeb1f0306d359f1fb035c7a55b54d87991924a5225
parent453f0122c6c6f9c33070a0ba38421b73f98e2535 (diff)
downloadaur-469a0ec49dfd943fcce33c7aae077e2cbf65bfff.tar.gz
mingw-w64-gtk3: 3.24.30 -> 3.24.31
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rw-r--r--gtk3-merge-3991-fix-autotools-build.patch43
-rw-r--r--gtk3-merge-4292-fix-windows-build.patch53
4 files changed, 69 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfbb9ca68ae6..e98f3a2b917d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-gtk3
pkgdesc = GObject-based multi-platform GUI toolkit (mingw-w64)
- pkgver = 3.24.30
+ pkgver = 3.24.31
pkgrel = 1
url = https://www.gtk.org
install = mingw-w64-gtk3.install
@@ -10,7 +10,6 @@ pkgbase = mingw-w64-gtk3
makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-configure
makedepends = gobject-introspection
- makedepends = gtk-doc
makedepends = gtk-update-icon-cache
makedepends = python
depends = mingw-w64-crt
@@ -25,11 +24,11 @@ pkgbase = mingw-w64-gtk3
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.gnome.org/sources/gtk+/3.24/gtk+-3.24.30.tar.xz
- source = gtk3-merge-3991-fix-autotools-build.patch
- source = mingw-w64-gtk3-3.24.30-winpointer.h::https://gitlab.gnome.org/GNOME/gtk/-/raw/3.24.30/gdk/win32/winpointer.h
- sha256sums = ba75bfff320ad1f4cfbee92ba813ec336322cc3c660d406aad014b07087a3ba9
- sha256sums = 17d1a2307655a648f9f321cd720e6207fa507ea7cae8f72445621dc8313ec3a6
- sha256sums = 66d01eb23bc87533f7838f298354567c52ce246d9c8270ed503d5d5b654c2cd0
+ source = https://download.gnome.org/sources/gtk+/3.24/gtk+-3.24.31.tar.xz
+ source = mingw-w64-gtk3-3.24.31-gdkkeys-win32.h::https://gitlab.gnome.org/GNOME/gtk/-/raw/3.24.31/gdk/win32/gdkkeys-win32.h
+ source = gtk3-merge-4292-fix-windows-build.patch
+ sha256sums = 423c3e7fdb4c459ee889e35fd4d71fd2623562541c1041b11c07e5ad1ff10bf9
+ sha256sums = 540c9fbca675a787377b9ba832df1acb0e870088e0c0bb2484312dc9754797a0
+ sha256sums = cbcda384fb206388d69729cb8e81cbbf87db362d83292f36a42cde9f0c2e7cb5
pkgname = mingw-w64-gtk3
diff --git a/PKGBUILD b/PKGBUILD
index 16eefedd30e1..8be234fb45af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: lantw44 at gmail dot com
pkgname=mingw-w64-gtk3
-pkgver=3.24.30
+pkgver=3.24.31
pkgrel=1
pkgdesc='GObject-based multi-platform GUI toolkit (mingw-w64)'
arch=('any')
@@ -13,7 +13,6 @@ makedepends=(
'mingw-w64-pkg-config'
'mingw-w64-configure'
'gobject-introspection'
- 'gtk-doc'
'gtk-update-icon-cache'
'python') # python is required to run gdbus-codegen
depends=(
@@ -29,18 +28,21 @@ depends=(
options=('!strip' '!buildflags' 'staticlibs')
source=(
"https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
- 'gtk3-merge-3991-fix-autotools-build.patch'
- "${pkgname}-${pkgver}-winpointer.h::https://gitlab.gnome.org/GNOME/gtk/-/raw/${pkgver}/gdk/win32/winpointer.h")
+ "${pkgname}-${pkgver}-gdkkeys-win32.h::https://gitlab.gnome.org/GNOME/gtk/-/raw/${pkgver}/gdk/win32/gdkkeys-win32.h"
+ 'gtk3-merge-4292-fix-windows-build.patch')
sha256sums=(
- 'ba75bfff320ad1f4cfbee92ba813ec336322cc3c660d406aad014b07087a3ba9'
- '17d1a2307655a648f9f321cd720e6207fa507ea7cae8f72445621dc8313ec3a6'
- '66d01eb23bc87533f7838f298354567c52ce246d9c8270ed503d5d5b654c2cd0')
+ '423c3e7fdb4c459ee889e35fd4d71fd2623562541c1041b11c07e5ad1ff10bf9'
+ '540c9fbca675a787377b9ba832df1acb0e870088e0c0bb2484312dc9754797a0'
+ 'cbcda384fb206388d69729cb8e81cbbf87db362d83292f36a42cde9f0c2e7cb5')
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
prepare() {
cd "${srcdir}/gtk+-${pkgver}"
local source_file
+ for source_file in "${source[@]:1:1}"; do
+ cp "${srcdir}/${source_file%%::*}" "gdk/win32/${source_file##*/}"
+ done
for source_file in "${source[@]}"; do
case "${source_file}" in
*.patch)
@@ -48,14 +50,10 @@ prepare() {
;;
esac
done
- for source_file in "${source[@]:2:1}"; do
- cp "${srcdir}/${source_file%%::*}" "gdk/win32/${source_file##*/}"
- done
}
build() {
cd "${srcdir}/gtk+-${pkgver}"
- NOCONFIGURE=1 ./autogen.sh
for _arch in "${_architectures[@]}"; do
export PKG_CONFIG="${_arch}-pkg-config"
export PKG_CONFIG_FOR_BUILD="pkg-config"
diff --git a/gtk3-merge-3991-fix-autotools-build.patch b/gtk3-merge-3991-fix-autotools-build.patch
deleted file mode 100644
index 38f4cd6c9709..000000000000
--- a/gtk3-merge-3991-fix-autotools-build.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 26d61e2abc22707e628045b1c33ea9930e8ca0dc Mon Sep 17 00:00:00 2001
-From: Ting-Wei Lan <lantw@src.gnome.org>
-Date: Fri, 24 Sep 2021 00:06:51 +0800
-Subject: [PATCH] GDK/Win32: Fix MinGW autotools build
-
-MinGW-w64 CRT provides no 'hid.lib' file. Instead, it has 'libhid.a'
-which can be linked with '-lhid' linker argument.
-
-Also, we have to declare the '_LIBADD' variable and add 'LDADDS' to it,
-or 'LDADDS' won't do anything for the build.
-
-https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/3991
----
- gdk/win32/Makefile.am | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/gdk/win32/Makefile.am b/gdk/win32/Makefile.am
-index 5fe1289570..21f4579192 100644
---- a/gdk/win32/Makefile.am
-+++ b/gdk/win32/Makefile.am
-@@ -22,7 +22,7 @@ AM_CPPFLAGS += "-DGDK_WIN32_ENABLE_EGL=1"
- endif #WIN32_GLES
-
- libgdk_win32_DEP_LIBS = \
-- hid.lib
-+ -lhid
-
- LDADDS = $(libgdk_win32_DEP_LIBS) $(GDK_DEP_LIBS)
-
-@@ -87,6 +87,10 @@ libgdk_win32_la_SOURCES = \
- wintab.h \
- xcursors.h
-
-+libgdk_win32_la_LIBADD = \
-+ $(LDADDS) \
-+ $(NULL)
-+
- libgdkinclude_HEADERS = \
- gdkwin32.h
-
---
-GitLab
-
diff --git a/gtk3-merge-4292-fix-windows-build.patch b/gtk3-merge-4292-fix-windows-build.patch
new file mode 100644
index 000000000000..cd2e4b238ef2
--- /dev/null
+++ b/gtk3-merge-4292-fix-windows-build.patch
@@ -0,0 +1,53 @@
+From 4090306fd7216cb102590262b444de7127242725 Mon Sep 17 00:00:00 2001
+From: Melroy van den Berg <melroy@melroy.org>
+Date: Tue, 28 Dec 2021 00:47:28 +0100
+Subject: [PATCH 1/3] Lowercaps Windows.h -> windows.h
+
+---
+ gdk/win32/gdkkeys-win32.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gdk/win32/gdkkeys-win32.h b/gdk/win32/gdkkeys-win32.h
+index 14a69d8081..17b7d7125c 100644
+--- a/gdk/win32/gdkkeys-win32.h
++++ b/gdk/win32/gdkkeys-win32.h
+@@ -22,7 +22,7 @@
+ */
+
+ #include <glib.h>
+-#include <Windows.h>
++#include <windows.h>
+
+ /* For lookup table VK -> chars */
+ typedef struct
+--
+GitLab
+
+
+From 37f9af58059252c27197444f13fd9fe5b65ef4b4 Mon Sep 17 00:00:00 2001
+From: Melroy van den Berg <melroy@melroy.org>
+Date: Tue, 28 Dec 2021 00:50:17 +0100
+Subject: [PATCH 2/3] Add define for GC_ALLGESTURES, in-case WINVER is not set.
+
+---
+ gdk/win32/winpointer.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/gdk/win32/winpointer.h b/gdk/win32/winpointer.h
+index ee3e42e063..786f6016c7 100644
+--- a/gdk/win32/winpointer.h
++++ b/gdk/win32/winpointer.h
+@@ -138,6 +138,10 @@
+ #define PA_ACTIVATE MA_ACTIVATE
+ #define PA_NOACTIVATE MA_NOACTIVATE
+
++#ifndef GC_ALLGESTURES
++#define GC_ALLGESTURES 0x1
++#endif
++
+ typedef DWORD POINTER_INPUT_TYPE;
+ typedef UINT32 POINTER_FLAGS;
+ typedef UINT32 TOUCH_FLAGS;
+--
+GitLab
+