summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2020-05-17 17:52:24 +0100
committerAlexandros Theodotou2020-05-17 17:52:24 +0100
commitc44011d0aaf9933a8b3e08616c08ebaf23a5ee27 (patch)
tree23ac85aedc4171ed85c6f08717270342ebeaf23a
downloadaur-c44011d0aaf9933a8b3e08616c08ebaf23a5ee27.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86fc4b1ac8cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mingw-w64-gtk3-bin
+ pkgdesc = SVG rendering library (mingw-w64)
+ pkgver = 3.24.18
+ pkgrel = 1
+ url = https://www.gnome.org
+ arch = any
+ license = custom
+ depends = mingw-w64-adwaita-icon-theme
+ depends = mingw-w64-atk
+ depends = mingw-w64-glib2
+ depends = mingw-w64-json-glib
+ depends = mingw-w64-libepoxy
+ depends = mingw-w64-shared-mime-info
+ depends = mingw-w64-gdk-pixbuf2
+ depends = mingw-w64-pango
+ depends = mingw-w64-cairo
+ provides = mingw-w64-gtk3
+ source = http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-gtk3-3.24.18-1-any.pkg.tar.xz
+ sha256sums = SKIP
+
+pkgname = mingw-w64-gtk3-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cec6b79cf2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=mingw-w64-gtk3-bin
+pkgver=3.24.18
+pkgrel=1
+pkgdesc="SVG rendering library (mingw-w64)"
+arch=('any')
+url="https://www.gnome.org"
+license=('custom')
+depends=(
+ 'mingw-w64-adwaita-icon-theme'
+ 'mingw-w64-atk'
+ 'mingw-w64-glib2'
+ 'mingw-w64-json-glib'
+ 'mingw-w64-libepoxy'
+ 'mingw-w64-shared-mime-info'
+ 'mingw-w64-gdk-pixbuf2'
+ 'mingw-w64-pango'
+ 'mingw-w64-cairo')
+provides=('mingw-w64-gtk3')
+source=("http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-gtk3-$pkgver-1-any.pkg.tar.xz")
+sha256sums=('SKIP')
+
+_architectures="x86_64-w64-mingw32"
+
+package() {
+ cd "${srcdir}/mingw64"
+ for _arch in ${_architectures}; do
+ mkdir -p ./* $pkgdir/usr/${_arch}/
+ sed -i -e "s|/mingw64|/usr/${_arch}|" ./lib/pkgconfig/*
+ cp -r ./* $pkgdir/usr/${_arch}/
+ done
+}