summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2020-05-16 13:58:37 +0100
committerAlexandros Theodotou2020-05-16 14:02:26 +0100
commit8adada1ab06004e1d8c3ba0ca84ad3c5cdfcea9d (patch)
treeba28ff6834a1382580bc94e4cfc5ab8d066e8baa
downloadaur-8adada1ab06004e1d8c3ba0ca84ad3c5cdfcea9d.tar.gz
add pkgbuild
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8e72a804ac2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-gtksourceview4
+ pkgdesc = A text widget adding syntax highlighting and more to GNOME (mingw-w64)
+ pkgver = 4.6.0
+ pkgrel = 1
+ url = https://www.gnome.org
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ makedepends = mingw-w64-meson
+ depends = mingw-w64-gtk3
+ depends = mingw-w64-libxml2
+ source = https://download.gnome.org/sources/gtksourceview/4.6/gtksourceview-4.6.0.tar.xz
+ sha256sums = 4c13e30ab2e602abdc56f55d35f43c1142a79b1cd77aa8839d2fc85e966d9a85
+
+pkgname = mingw-w64-gtksourceview4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aa71d8b72d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Mantainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Rafael Ferreira <josephgbr@archlinux.info>
+
+_pkgbase=gtksourceview4
+MINGW_PACKAGE_PREFIX=mingw-w64
+pkgname=$MINGW_PACKAGE_PREFIX-$_pkgbase
+pkgver=4.6.0
+pkgrel=1
+pkgdesc="A text widget adding syntax highlighting and more to GNOME (mingw-w64)"
+arch=('any')
+url="https://www.gnome.org"
+license=("LGPL")
+makedepends=("${MINGW_PACKAGE_PREFIX}-gcc"
+ "${MINGW_PACKAGE_PREFIX}-pkg-config"
+ "${MINGW_PACKAGE_PREFIX}-meson")
+depends=("${MINGW_PACKAGE_PREFIX}-gtk3"
+ "${MINGW_PACKAGE_PREFIX}-libxml2")
+source=("https://download.gnome.org/sources/gtksourceview/${pkgver%.*}/gtksourceview-${pkgver}.tar.xz")
+sha256sums=('4c13e30ab2e602abdc56f55d35f43c1142a79b1cd77aa8839d2fc85e966d9a85')
+_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+
+ for _arch in "${_architectures[@]}"; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ PKG_CONFIG="pkg-config" $_arch-meson \
+ -Dgtk_doc=false \
+ -Dgir=false \
+ ..
+ ninja
+ popd
+ done
+}
+
+package() {
+
+ for _arch in "${_architectures[@]}"; do
+ DESTDIR="${pkgdir}" meson install -C ${srcdir}/${_pkgbase}-${pkgver}/build-${_arch}
+ done
+}