summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2024-05-13 14:54:03 +0800
committerpingplug2024-05-13 14:54:03 +0800
commit0e215dd0ee3b5cc8d40f90044dc9330fe1121d45 (patch)
treeb69aa271a0e68b7b85a7ca92f325653148700bc7
parent24994cef3d191cfeb0e09bb472b5ba72eb4f3521 (diff)
downloadaur-0e215dd0ee3b5cc8d40f90044dc9330fe1121d45.tar.gz
update from Martchus
https://github.com/Martchus/PKGBUILDs/commit/047fd653344265c5419bff79f4742469a2078184
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83760c9a45fe..afa6a205026c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mingw-w64-harfbuzz
pkgdesc = OpenType text shaping engine (mingw-w64)
pkgver = 8.4.0
- pkgrel = 1
- url = https://www.freedesktop.org/wiki/Software/HarfBuzz
+ pkgrel = 2
+ url = https://harfbuzz.github.io/
arch = any
license = MIT
makedepends = mingw-w64-meson
@@ -18,8 +18,12 @@ pkgbase = mingw-w64-harfbuzz
options = !strip
options = staticlibs
options = !buildflags
- source = git+https://github.com/harfbuzz/harfbuzz.git#commit=63973005bc07aba599b47fdd4cf788647b601ccd
- sha256sums = SKIP
+ source = git+https://github.com/harfbuzz/harfbuzz?signed#tag=8.4.0
+ validpgpkeys = 053D20F17CCCA9651B2C6FCB9AB24930C0B997A2
+ validpgpkeys = 9F377DDB6D3153A48EB3EB1E63CC496475267693
+ validpgpkeys = 2277650A4E8BDFE4B7F6BE419FEE04E5D3531115
+ validpgpkeys = EACF64F53455E2771BA661A4803B21859F015E4E
+ b2sums = 19f25dbf2ba6d90fdbb4ecb1039c8d0d72c55cff3dc3b30d6b75b626c15bf28a2118495837d80b7f622f0929dd7d4a07b5526963e1204bb9c90bc9f976c26977
pkgname = mingw-w64-harfbuzz
diff --git a/PKGBUILD b/PKGBUILD
index 6ba5cd0a59ad..ff40ed55e2c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: pingplug < aur at pingplug dot me >
# Contributor: Schala Zeal < schalaalexiazeal at gmail dot com >
-_commit=63973005bc07aba599b47fdd4cf788647b601ccd # tags/8.4.0
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgbase=mingw-w64-harfbuzz
pkgname=('mingw-w64-harfbuzz' 'mingw-w64-harfbuzz-icu')
pkgver=8.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="OpenType text shaping engine (mingw-w64)"
arch=('any')
-url="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+url="https://harfbuzz.github.io/"
license=('MIT')
depends=('mingw-w64-crt'
'mingw-w64-glib2'
@@ -23,8 +22,14 @@ makedepends=('mingw-w64-meson'
'ragel'
'git')
options=('!strip' 'staticlibs' '!buildflags')
-source=("git+https://github.com/harfbuzz/harfbuzz.git#commit=${_commit}")
-sha256sums=('SKIP')
+source=("git+https://github.com/harfbuzz/harfbuzz?signed#tag=$pkgver")
+b2sums=('19f25dbf2ba6d90fdbb4ecb1039c8d0d72c55cff3dc3b30d6b75b626c15bf28a2118495837d80b7f622f0929dd7d4a07b5526963e1204bb9c90bc9f976c26977')
+validpgpkeys=(
+ 053D20F17CCCA9651B2C6FCB9AB24930C0B997A2 # Khaled Hosny <khaled@aliftype.com> (@khaledhosny)
+ 9F377DDB6D3153A48EB3EB1E63CC496475267693 # Caleb Maclennan <caleb@alerque.com> (@alerque)
+ 2277650A4E8BDFE4B7F6BE419FEE04E5D3531115 # Ebrahim Byagowi <ebrahim@gnu.org> (@ebraminio)
+ EACF64F53455E2771BA661A4803B21859F015E4E # Behdad Esfahbod <behdad@behdad.org> (@behdad)
+)
pkgver() {
cd harfbuzz
@@ -40,6 +45,7 @@ build() {
-D graphite=enabled \
-D tests=disabled \
-D docs=disabled \
+ -D cpp_std=c++17 \
..
# fix linker selection error
sed -i 's|: c_LINKER|: cpp_LINKER|g' build.ninja
@@ -54,6 +60,7 @@ build() {
-D graphite=enabled \
-D tests=disabled \
-D docs=disabled \
+ -D cpp_std=c++17 \
..
# fix linker selection error
sed -i 's|: c_LINKER|: cpp_LINKER|g' build.ninja