summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author4shadoww2018-03-21 22:55:55 +0200
committer4shadoww2018-03-21 22:55:55 +0200
commitbb347c1b2e69cc86a9709149e621e5d044cdd2df (patch)
tree58bf94068f2e8139e973fbeb0abe076107e66d84
downloadaur-bb347c1b2e69cc86a9709149e621e5d044cdd2df.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97b5c42d9162
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-headers-bin
+ pkgdesc = MinGW-w64 headers for Windows (pre-compiled)
+ pkgver = 5.0.3
+ pkgrel = 1
+ url = http://mingw-w64.sourceforge.net
+ arch = any
+ groups = mingw-w64-toolchain
+ groups = mingw-w64
+ license = custom
+ provides = mingw-w64-headers
+ conflicts = mingw-w64-headers
+ options = !strip
+ options = !libtool
+ options = !emptydirs
+ source = https://github.com/4shadoww/mingw-w64-builds/releases/download/binary/mingw-w64-headers-5.0.3.tar.xz
+ md5sums = b5881db21241e43420e4215201e31d0e
+
+pkgname = mingw-w64-headers-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a8a97eda538
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Noa-Emil Nissinen <aur dot satella at spamgourmet dot org>
+
+pkgname=mingw-w64-headers-bin
+pkgver=5.0.3
+pkgrel=1
+pkgdesc="MinGW-w64 headers for Windows (pre-compiled)"
+arch=('any')
+url="http://mingw-w64.sourceforge.net"
+license=('custom')
+groups=('mingw-w64-toolchain' 'mingw-w64')
+provides=('mingw-w64-headers')
+conflicts=('mingw-w64-headers')
+options=('!strip' '!libtool' '!emptydirs')
+source=("https://github.com/4shadoww/mingw-w64-builds/releases/download/binary/$provides-$pkgver.tar.xz")
+md5sums=("b5881db21241e43420e4215201e31d0e")
+
+package() {
+ cd "$provides/"
+ cp -r * "$pkgdir/"
+}