summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-05-31 10:45:39 +0800
committerpingplug2018-05-31 10:45:39 +0800
commitd84381899d829917e74cb5242fad3acc8f773438 (patch)
tree2234a503bfc1c5e94a0951dbd339b051cf5430a8
parent76e46005f049926c70bd9bc474d5e0d541081e39 (diff)
downloadaur-d84381899d829917e74cb5242fad3acc8f773438.tar.gz
bump version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8be522b0fae4..eeae8c4d0615 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-headers-git
- pkgdesc = MinGW-w64 headers for Windows(git version)
- pkgver = 5.0.3.20180212
+ pkgdesc = MinGW-w64 headers for Windows (git version)
+ pkgver = 5.0.3.20180524
pkgrel = 1
url = https://mingw-w64.org/doku.php
arch = any
@@ -8,12 +8,11 @@ pkgbase = mingw-w64-headers-git
groups = mingw-w64
license = custom
makedepends = git
- provides = mingw-w64-headers=5.0.3.20180212
+ provides = mingw-w64-headers=5.0.3.20180524
conflicts = mingw-w64-headers
- replaces = mingw-w64-headers
options = !strip
- options = !libtool
- options = !emptydirs
+ options = staticlibs
+ options = !buildflags
source = git+https://git.code.sf.net/p/mingw-w64/mingw-w64
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5b1de0f30407..2fabc6454ee3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,22 @@
# Contributor: rubenvb vanboxem <dottie> ruben <attie> gmail <dottie> com
# Contributor: rkitover <rkitover@gmail.com>
+_pkgver=5.0.3
_targets="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-headers-git
-pkgver=5.0.3.20180212
-_pkgver=5.0.3
+pkgver=5.0.3.20180524
pkgrel=1
-pkgdesc='MinGW-w64 headers for Windows(git version)'
+pkgdesc="MinGW-w64 headers for Windows (git version)"
arch=('any')
-url='https://mingw-w64.org/doku.php'
+url="https://mingw-w64.org/doku.php"
license=('custom')
groups=('mingw-w64-toolchain' 'mingw-w64')
makedepends=('git')
-provides=("mingw-w64-headers=$pkgver")
+provides=("mingw-w64-headers=${pkgver}")
conflicts=('mingw-w64-headers')
-replaces=('mingw-w64-headers')
-options=('!strip' '!libtool' '!emptydirs')
-source=('git+https://git.code.sf.net/p/mingw-w64/mingw-w64')
+options=('!strip' 'staticlibs' '!buildflags')
+source=("git+https://git.code.sf.net/p/mingw-w64/mingw-w64")
sha256sums=('SKIP')
pkgver() {
@@ -34,10 +33,10 @@ build() {
msg "Configuring ${_target} headers"
mkdir -p "headers-${_target}" && pushd "headers-${_target}"
../mingw-w64/mingw-w64-headers/configure \
- --prefix=/usr/${_target} \
- --enable-sdk=all \
- --enable-secure-api \
- --host=${_target}
+ --prefix=/usr/${_target} \
+ --enable-sdk=all \
+ --enable-secure-api \
+ --host=${_target}
popd
done
}
@@ -59,3 +58,5 @@ package() {
install -Dm644 "${srcdir}/mingw-w64/mingw-w64-headers/direct-x/COPYING.LIB" "${pkgdir}/usr/share/licenses/${pkgname}/direct-x-COPYING.LIB"
install -Dm644 "${srcdir}/mingw-w64/mingw-w64-headers/direct-x/readme.txt" "${pkgdir}/usr/share/licenses/${pkgname}/direct-x-readme.txt"
}
+
+# vim:set ts=2 sw=2 et: