summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbenly2021-08-29 11:22:47 +0800
committerbenly2021-08-29 11:32:30 +0800
commit32d3d12671b0d1bbf76e3759b4da31eddd4bdce9 (patch)
tree94be24968c74fec1ae4183868cfc986454815e9a
parent9ac8c70688fd7c2032a55b71dfed213c0a921eae (diff)
downloadaur-32d3d12671b0d1bbf76e3759b4da31eddd4bdce9.tar.gz
update to 0.10.1
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
-rw-r--r--autoconf-2.70.patch11
4 files changed, 36 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 665143d30455..3e29ec575958 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-hidapi
pkgdesc = Simple library for communicating with USB and Bluetooth HID devices (mingw-w64)
- pkgver = 0.9.0
+ pkgver = 0.10.1
pkgrel = 1
url = https://github.com/libusb/hidapi
arch = any
@@ -12,8 +12,9 @@ pkgbase = mingw-w64-hidapi
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/libusb/hidapi/archive/hidapi-0.9.0.tar.gz
- sha256sums = 630ee1834bdd5c5761ab079fd04f463a89585df8fcae51a7bfe4229b1e02a652
+ source = https://github.com/libusb/hidapi/archive/hidapi-0.10.1.tar.gz
+ source = autoconf-2.70.patch
+ sha256sums = f71dd8a1f46979c17ee521bc2117573872bbf040f8a4750e492271fc141f2644
+ sha256sums = a56fd8181d980ae9786000883cb31944d3765088363cfd9c192e475b975cd8c7
pkgname = mingw-w64-hidapi
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..555dbb8dbc89
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!*.patch
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 55e7d897ade0..caffef35a3bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Niels Martignène <niels.martignene@gmail.com>
+# Maintainer: benlypan <benlypan@gmail.com>
+# Contributor: Niels Martignène <niels.martignene@gmail.com>
pkgname=mingw-w64-hidapi
-pkgver=0.9.0
+pkgver=0.10.1
pkgrel=1
pkgdesc="Simple library for communicating with USB and Bluetooth HID devices (mingw-w64)"
arch=(any)
@@ -10,11 +11,21 @@ license=('GPL3' 'BSD' 'custom')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-configure')
options=('!strip' '!buildflags' 'staticlibs')
-source=("https://github.com/libusb/hidapi/archive/hidapi-${pkgver}.tar.gz")
-sha256sums=('630ee1834bdd5c5761ab079fd04f463a89585df8fcae51a7bfe4229b1e02a652')
+source=(
+ "https://github.com/libusb/hidapi/archive/hidapi-${pkgver}.tar.gz"
+ "autoconf-2.70.patch"
+)
+sha256sums=(
+ 'f71dd8a1f46979c17ee521bc2117573872bbf040f8a4750e492271fc141f2644'
+ 'a56fd8181d980ae9786000883cb31944d3765088363cfd9c192e475b975cd8c7'
+)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ patch -d"${srcdir}/hidapi-hidapi-${pkgver}" -p0 -i"${srcdir}"/autoconf-2.70.patch
+}
+
build() {
cd "${srcdir}/hidapi-hidapi-${pkgver}"
diff --git a/autoconf-2.70.patch b/autoconf-2.70.patch
new file mode 100644
index 000000000000..5fd14a1c5c34
--- /dev/null
+++ b/autoconf-2.70.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2021-03-29 12:56:15.896012367 +0800
++++ configure.ac 2021-03-29 12:55:51.319435429 +0800
+@@ -13,7 +13,7 @@ LTLDFLAGS="-version-info ${lt_current}:$
+
+ AC_CONFIG_MACRO_DIR([m4])
+ AM_INIT_AUTOMAKE([foreign -Wall -Werror])
+-AC_CONFIG_MACRO_DIR([m4])
++# AC_CONFIG_MACRO_DIR([m4])
+
+ m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+ LT_INIT