summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2017-07-30 17:52:01 -0700
committerBuildTools2017-07-30 17:52:01 -0700
commit07b10014e5bdecd5a68929e825108e8767a2ed21 (patch)
tree11041c8c000e0822ebbe3dbff5833f8b922b94d6
parent815becf3311f29ddda80e33c8c0b6d7cbed0d4d7 (diff)
downloadaur-07b10014e5bdecd5a68929e825108e8767a2ed21.tar.gz
1.6.1
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--0005-windows-sub-dicts-paths.patch34
-rw-r--r--01-relocate.patch786
-rw-r--r--PKGBUILD15
5 files changed, 799 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af5a0fb8e713..2b99c3ab9d2b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Dec 3 10:50:28 UTC 2016
+# Mon Jul 31 00:51:35 UTC 2017
pkgbase = mingw-w64-hunspell
pkgdesc = Spell checker and morphological analyzer library (mingw-w64)
- pkgver = 1.5.4
+ pkgver = 1.6.1
pkgrel = 1
url = http://hunspell.github.io/
arch = any
@@ -18,10 +18,10 @@ pkgbase = mingw-w64-hunspell
options = staticlibs
options = !debug
options = !emptydirs
- source = https://github.com/hunspell/hunspell/archive/v1.5.4.tar.gz
- source = 0005-windows-sub-dicts-paths.patch
- md5sums = 9849a2381bacbeb2714034ad825bede8
- md5sums = 8f3f269734623b2c57521202877c51bd
+ source = https://github.com/hunspell/hunspell/archive/v1.6.1.tar.gz
+ source = 01-relocate.patch
+ sha256sums = 30f593733c50b794016bb03d31fd2a2071e4610c6fa4708e33edad2335102c49
+ sha256sums = 2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806
pkgname = mingw-w64-hunspell
diff --git a/.gitignore b/.gitignore
index 5b06d8419137..49c4674d6625 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
pkg/
src/
*.gz
+*.log
*.tar
*.xz
diff --git a/0005-windows-sub-dicts-paths.patch b/0005-windows-sub-dicts-paths.patch
deleted file mode 100644
index 6887b2df99d7..000000000000
--- a/0005-windows-sub-dicts-paths.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -aurN 0004/src/tools/hunspell.cxx 0005/src/tools/hunspell.cxx
---- 0004/src/tools/hunspell.cxx
-+++ 0005/src/tools/hunspell.cxx
-@@ -104,6 +104,12 @@
- #endif
- #define PATHSEP ";"
-
-+#ifdef __MINGW32__
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+#include <dirent.h>
-+#include <unistd.h>
-+#endif
- #include "textparser.hxx"
- #include "htmlparser.hxx"
- #include "latexparser.hxx"
-@@ -1812,7 +1818,7 @@
- return NULL;
- }
-
--#ifndef WIN32
-+#if !defined(WIN32) || defined(__MINGW32__)
- int listdicpath(char* dir, int len) {
- std::string buf;
- const char* sep = (len == 0) ? "" : DIRSEP;
-@@ -1847,7 +1853,7 @@
- if (name) {
- res = exist2(begin, end - begin, name, ext);
- } else {
--#ifndef WIN32
-+#if !defined(WIN32) || defined(__MINGW32__)
- listdicpath(begin, end - begin);
- #endif
- }
diff --git a/01-relocate.patch b/01-relocate.patch
new file mode 100644
index 000000000000..66587a96f4b7
--- /dev/null
+++ b/01-relocate.patch
@@ -0,0 +1,786 @@
+diff --git a/.gitignore b/.gitignore
+index 04cdd34..5ede546 100644
+--- a/.gitignore
++++ b/.gitignore
+@@ -51,7 +51,8 @@ Makefile
+ /config.status
+ /hunspell.pc
+ /libtool
+-
++build/*
++.vscode/*
+
+ #make
+ .deps/
+diff --git a/src/tools/Makefile.am b/src/tools/Makefile.am
+index 4c29f1a..cc25476 100644
+--- a/src/tools/Makefile.am
++++ b/src/tools/Makefile.am
+@@ -12,7 +12,10 @@ unmunch_SOURCES=unmunch.cxx unmunch.h
+ example_SOURCES=example.cxx
+ example_LDADD = ../hunspell/libhunspell-1.6.la
+
+-hunspell_SOURCES=hunspell.cxx
++hunspell_CXXFLAGS = \
++ -DBINDIR=\""$(bindir)"\" \
++ -DDATA_DIR=\""$(datadir)"\"
++hunspell_SOURCES=hunspell.cxx pathtools.cxx pathtools.hxx
+ hunspell_LDADD = @LIBINTL@ @LIBICONV@ ../parsers/libparsers.a \
+ ../hunspell/libhunspell-1.6.la @CURSESLIB@ @READLINELIB@
+
+diff --git a/src/tools/hunspell.cxx b/src/tools/hunspell.cxx
+index 399df86..0599794 100644
+--- a/src/tools/hunspell.cxx
++++ b/src/tools/hunspell.cxx
+@@ -51,6 +51,7 @@
+ #include "hunspell.hxx"
+ #include "csutil.hxx"
+ #include "hunzip.hxx"
++#include "pathtools.hxx"
+
+ #define HUNSPELL_VERSION VERSION
+ #define INPUTLEN 50
+@@ -70,6 +71,16 @@
+
+ #ifdef WIN32
+
++#ifdef __MINGW32__
++#define LIBDIR \
++ DATA_DIR "/hunspell:" \
++ DATA_DIR "/myspell:" \
++ DATA_DIR "/myspell/dicts:"
++#define OOODIR \
++ DATA_DIR "/dict/ooo"
++#define USEROOODIR {"/Application Data/OpenOffice.org 2/user/wordbook"}
++#define HOME "%USERPROFILE%"
++#else
+ #define LIBDIR "C:\\Hunspell\\"
+ #define USEROOODIR { "Application Data\\OpenOffice.org 2\\user\\wordbook" }
+ #define OOODIR \
+@@ -79,10 +90,16 @@
+ "C:\\Program files\\OpenOffice.org 2.1\\share\\dict\\ooo\\;" \
+ "C:\\Program files\\OpenOffice.org 2.0\\share\\dict\\ooo\\"
+ #define HOME "%USERPROFILE%\\"
++#endif
+ #define DICBASENAME "hunspell_"
+ #define LOGFILE "C:\\Hunspell\\log"
++#ifdef __MINGW32__
++#define DIRSEPCH '/'
++#define DIRSEP "/"
++#else
+ #define DIRSEPCH '\\'
+ #define DIRSEP "\\"
++#endif
+ #define PATHSEP ";"
+
+ #ifdef __MINGW32__
+@@ -172,7 +189,12 @@ char text_conv[MAXLNLEN];
+
+ #ifdef HAVE_CURSES_H
+ #ifdef HAVE_NCURSESW_H
++#ifdef __MINGW32__
++#include <ncurses/ncurses.h>
++#else
+ #include <ncurses.h>
++#endif //__MINGW32__
++
+ #else
+ #include <curses.h>
+ #endif
+@@ -2042,11 +2064,20 @@ int main(int argc, char** argv) {
+ {
+ std::string path_std_str = ".";
+ path_std_str.append(PATHSEP); // <- check path in local directory
++#ifndef __MINGW32__
+ path_std_str.append(PATHSEP); // <- check path in root directory
++#else
++ path_std_str.append(single_path_relocation(BINDIR, BINDIR)).append(PATHSEP);
++#endif
+ if (getenv("DICPATH")) {
+ path_std_str.append(getenv("DICPATH")).append(PATHSEP);
+ }
++#ifndef __MINGW32__
+ path_std_str.append(LIBDIR).append(PATHSEP);
++#else
++ path_std_str.append(pathlist_relocation(BINDIR, LIBDIR)).append(PATHSEP);
++#endif
++
+ if (HOME) {
+ const char * userooodir[] = USEROOODIR;
+ for(size_t i = 0; i < sizeof(userooodir)/sizeof(userooodir[0]); ++i) {
+@@ -2056,7 +2087,11 @@ int main(int argc, char** argv) {
+ #endif
+ path_std_str.append(userooodir[i]).append(PATHSEP);
+ }
++#ifndef __MINGW32__
+ path_std_str.append(OOODIR);
++#else
++ path_std_str.append(single_path_relocation(BINDIR, OOODIR)).append(PATHSEP);
++#endif
+ }
+ path = mystrdup(path_std_str.c_str());
+ }
+@@ -2152,6 +2187,7 @@ int main(int argc, char** argv) {
+ }
+
+ if (arg_files == -1) {
++ fflush(stderr);
+ pipe_interface(pMS, format, stdin, NULL);
+ } else if (filter_mode != NORMAL) {
+ for (int i = arg_files; i < argc; i++) {
+diff --git a/src/tools/pathtools.cxx b/src/tools/pathtools.cxx
+new file mode 100644
+index 0000000..d8ba8cf
+--- /dev/null
++++ b/src/tools/pathtools.cxx
+@@ -0,0 +1,538 @@
++/*
++ .Some useful path tools.
++ .ASCII only for now.
++ .Written by Ray Donnelly in 2014.
++ .Licensed under CC0 (and anything.
++ .else you need to license it under).
++ .No warranties whatsoever.
++ .email: <mingw.android@gmail.com>.
++ */
++
++#if defined(__APPLE__)
++#include <stdlib.h>
++#else
++#include <malloc.h>
++#endif
++#include <limits.h>
++#include <stdio.h>
++#include <string.h>
++#if defined(__linux__) || defined(__CYGWIN__) || defined(__MSYS__)
++#include <alloca.h>
++#endif
++#include <unistd.h>
++
++/* If you don't define this, then get_executable_path()
++ can only use argv[0] which will often not work well */
++#define IMPLEMENT_SYS_GET_EXECUTABLE_PATH
++
++#if defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH)
++#if defined(__linux__) || defined(__CYGWIN__) || defined(__MSYS__)
++/* Nothing needed, unistd.h is enough. */
++#elif defined(__APPLE__)
++#include <mach-o/dyld.h>
++#elif defined(_WIN32)
++#define WIN32_MEAN_AND_LEAN
++#include <windows.h>
++#include <psapi.h>
++#endif
++#endif /* defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH) */
++
++#include "pathtools.hxx"
++
++char *
++malloc_copy_string(char const * original)
++{
++ char * result = (char *) malloc (sizeof (char*) * strlen (original)+1);
++ if (result != NULL)
++ {
++ strcpy (result, original);
++ }
++ return result;
++}
++
++void
++sanitise_path(char * path)
++{
++ size_t path_size = strlen (path);
++
++ /* Replace any '\' with '/' */
++ char * path_p = path;
++ while ((path_p = strchr (path_p, '\\')) != NULL)
++ {
++ *path_p = '/';
++ }
++ /* Replace any '//' with '/' */
++ path_p = path;
++ while ((path_p = strstr (path_p, "//")) != NULL)
++ {
++ memmove (path_p, path_p + 1, path_size--);
++ }
++ return;
++}
++
++char *
++get_relative_path(char const * from_in, char const * to_in)
++{
++ size_t from_size = (from_in == NULL) ? 0 : strlen (from_in);
++ size_t to_size = (to_in == NULL) ? 0 : strlen (to_in);
++ size_t max_size = (from_size + to_size) * 2 + 4;
++ char * scratch_space = (char *) alloca (from_size + 1 + to_size + 1 + max_size + max_size);
++ char * from;
++ char * to;
++ char * common_part;
++ char * result;
++ size_t count;
++
++ /* No to, return "./" */
++ if (to_in == NULL)
++ {
++ return malloc_copy_string ("./");
++ }
++
++ /* If alloca failed or no from was given return a copy of to */
++ if ( from_in == NULL
++ || scratch_space == NULL )
++ {
++ return malloc_copy_string (to_in);
++ }
++
++ from = scratch_space;
++ strcpy (from, from_in);
++ to = from + from_size + 1;
++ strcpy (to, to_in);
++ common_part = to + to_size + 1;
++ result = common_part + max_size;
++ simplify_path (from);
++ simplify_path (to);
++
++ result[0] = '\0';
++
++ size_t match_size_dirsep = 0; /* The match size up to the last /. Always wind back to this - 1 */
++ size_t match_size = 0; /* The running (and final) match size. */
++ size_t largest_size = (from_size > to_size) ? from_size : to_size;
++ int to_final_is_slash = (to[to_size-1] == '/') ? 1 : 0;
++ char from_c;
++ char to_c;
++ for (match_size = 0; match_size < largest_size; ++match_size)
++ {
++ /* To simplify the logic, always pretend the strings end with '/' */
++ from_c = (match_size < from_size) ? from[match_size] : '/';
++ to_c = (match_size < to_size) ? to[match_size] : '/';
++
++ if (from_c != to_c)
++ {
++ if (from_c != '\0' || to_c != '\0')
++ {
++ match_size = match_size_dirsep;
++ }
++ break;
++ }
++ else if (from_c == '/')
++ {
++ match_size_dirsep = match_size;
++ }
++ }
++ strncpy (common_part, from, match_size);
++ common_part[match_size] = '\0';
++ from += match_size;
++ to += match_size;
++ size_t ndotdots = 0;
++ char const* from_last = from + strlen(from) - 1;
++ while ((from = strchr (from, '/')) && from != from_last)
++ {
++ ++ndotdots;
++ ++from;
++ }
++ for (count = 0; count < ndotdots; ++count)
++ {
++ strcat(result, "../");
++ }
++ if (strlen(to) > 0)
++ {
++ strcat(result, to+1);
++ }
++ /* Make sure that if to ends with '/' result does the same, and
++ vice-versa. */
++ size_t size_result = strlen(result);
++ if ((to_final_is_slash == 1)
++ && (!size_result || result[size_result-1] != '/'))
++ {
++ strcat (result, "/");
++ }
++ else if (!to_final_is_slash
++ && size_result && result[size_result-1] == '/')
++ {
++ result[size_result-1] = '\0';
++ }
++
++ return malloc_copy_string (result);
++}
++
++void
++simplify_path(char * path)
++{
++ ssize_t n_toks = 1; /* in-case we need an empty initial token. */
++ ssize_t i, j;
++ size_t tok_size;
++ size_t in_size = strlen (path);
++ int it_ended_with_a_slash = (path[in_size - 1] == '/') ? 1 : 0;
++ char * result = path;
++ sanitise_path(result);
++ char * result_p = result;
++
++ do
++ {
++ ++n_toks;
++ ++result_p;
++ } while ((result_p = strchr (result_p, '/')) != NULL);
++
++ result_p = result;
++ char const ** toks = (char const **) alloca (sizeof (char const*) * n_toks);
++ n_toks = 0;
++ do
++ {
++ if (result_p > result)
++ {
++ *result_p++ = '\0';
++ }
++ else if (*result_p == '/')
++ {
++ /* A leading / creates an empty initial token. */
++ toks[n_toks++] = result_p;
++ *result_p++ = '\0';
++ }
++ toks[n_toks++] = result_p;
++ } while ((result_p = strchr (result_p, '/')) != NULL);
++
++ /* Remove all non-leading '.' and any '..' we can match
++ with an earlier forward path (i.e. neither '.' nor '..') */
++ for (i = 1; i < n_toks; ++i)
++ {
++ int removals[2] = { -1, -1 };
++ if ( strcmp (toks[i], "." ) == 0)
++ {
++ removals[0] = i;
++ }
++ else if ( strcmp (toks[i], ".." ) == 0)
++ {
++ /* Search backwards for a forward path to collapse.
++ If none are found then the .. also stays. */
++ for (j = i - 1; j > -1; --j)
++ {
++ if ( strcmp (toks[j], "." )
++ && strcmp (toks[j], ".." ) )
++ {
++ removals[0] = j;
++ removals[1] = i;
++ break;
++ }
++ }
++ }
++ for (j = 0; j < 2; ++j)
++ {
++ if (removals[j] >= 0) /* Can become -2 */
++ {
++ --n_toks;
++ memmove (&toks[removals[j]], &toks[removals[j]+1], (n_toks - removals[j])*sizeof (char*));
++ --i;
++ if (!j)
++ {
++ --removals[1];
++ }
++ }
++ }
++ }
++ result_p = result;
++ for (i = 0; i < n_toks; ++i)
++ {
++ tok_size = strlen(toks[i]);
++ memcpy (result_p, toks[i], tok_size);
++ result_p += tok_size;
++ if ((!i || tok_size) && ((i < n_toks - 1) || it_ended_with_a_slash == 1))
++ {
++ *result_p = '/';
++ ++result_p;
++ }
++ }
++ *result_p = '\0';
++}
++
++/* Returns actual_to by calculating the relative path from -> to and
++ applying that to actual_from. An assumption that actual_from is a
++ dir is made, and it may or may not end with a '/' */
++char const *
++get_relocated_path (char const * from, char const * to, char const * actual_from)
++{
++ char const * relative_from_to = get_relative_path (from, to);
++ char * actual_to = (char *) malloc (strlen(actual_from) + 2 + strlen(relative_from_to));
++ return actual_to;
++}
++
++int
++get_executable_path(char const * argv0, char * result, ssize_t max_size)
++{
++ char * system_result = (char *) alloca (max_size);
++ ssize_t system_result_size = -1;
++ ssize_t result_size = -1;
++
++ if (system_result != NULL)
++ {
++#if defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH)
++#if defined(__linux__) || defined(__CYGWIN__) || defined(__MSYS__)
++ system_result_size = readlink("/proc/self/exe", system_result, max_size);
++#elif defined(__APPLE__)
++ uint32_t bufsize = (uint32_t)max_size;
++ if (_NSGetExecutablePath(system_result, &bufsize) == 0)
++ {
++ system_result_size = (ssize_t)bufsize;
++ }
++#elif defined(_WIN32)
++ unsigned long bufsize = (unsigned long)max_size;
++ system_result_size = GetModuleFileNameA(NULL, system_result, bufsize);
++ if (system_result_size == 0 || system_result_size == (ssize_t)bufsize)
++ {
++ /* Error, possibly not enough space. */
++ system_result_size = -1;
++ }
++ else
++ {
++ /* Early conversion to unix slashes instead of more changes
++ everywhere else .. */
++ char * winslash;
++ system_result[system_result_size] = '\0';
++ while ((winslash = strchr (system_result, '\\')) != NULL)
++ {
++ *winslash = '/';
++ }
++ }
++#else
++#warning "Don't know how to get executable path on this system"
++#endif
++#endif /* defined(IMPLEMENT_SYS_GET_EXECUTABLE_PATH) */
++ }
++ /* Use argv0 as a default in-case of failure */
++ if (system_result_size != -1)
++ {
++ strncpy (result, system_result, system_result_size);
++ result[system_result_size] = '\0';
++ }
++ else
++ {
++ if (argv0 != NULL)
++ {
++ strncpy (result, argv0, max_size);
++ result[max_size-1] = '\0';
++ }
++ else
++ {
++ result[0] = '\0';
++ }
++ }
++ result_size = strlen (result);
++ return result_size;
++}
++
++char const *
++strip_n_prefix_folders(char const * path, size_t n)
++{
++ if (path == NULL)
++ {
++ return NULL;
++ }
++
++ if (path[0] != '/')
++ {
++ return path;
++ }
++
++ char const * last = path;
++ while (n-- && path != NULL)
++ {
++ last = path;
++ path = strchr (path + 1, '/');
++ }
++ return (path == NULL) ? last : path;
++}
++
++void
++strip_n_suffix_folders(char * path, size_t n)
++{
++ if (path == NULL)
++ {
++ return;
++ }
++ while (n--)
++ {
++ if (strrchr (path + 1, '/'))
++ {
++ *strrchr (path + 1, '/') = '\0';
++ }
++ else
++ {
++ return;
++ }
++ }
++ return;
++}
++
++size_t
++split_path_list(char const * path_list, char split_char, char *** arr)
++{
++ size_t path_count;
++ size_t path_list_size;
++ char const * path_list_p;
++
++ path_list_p = path_list;
++ if (path_list == NULL || path_list[0] == '\0')
++ {
++ return 0;
++ }
++ path_list_size = strlen (path_list);
++
++ path_count = 0;
++ do
++ {
++ ++path_count;
++ ++path_list_p;
++ }
++ while ((path_list_p = strchr (path_list_p, split_char)) != NULL);
++
++ /* allocate everything in one go. */
++ char * all_memory = (char *) malloc (sizeof (char *) * path_count + strlen(path_list) + 1);
++ if (all_memory == NULL)
++ return 0;
++ *arr = (char **)all_memory;
++ all_memory += sizeof (char *) * path_count;
++
++ path_count = 0;
++ path_list_p = path_list;
++ char const * next_path_list_p = 0;
++ do
++ {
++ next_path_list_p = strchr (path_list_p, split_char);
++ if (next_path_list_p != NULL)
++ {
++ ++next_path_list_p;
++ }
++ size_t this_size = (next_path_list_p != NULL)
++ ? next_path_list_p - path_list_p - 1
++ : &path_list[path_list_size] - path_list_p;
++ memcpy (all_memory, path_list_p, this_size);
++ all_memory[this_size] = '\0';
++ (*arr)[path_count++] = all_memory;
++ all_memory += this_size + 1;
++ } while ((path_list_p = next_path_list_p) != NULL);
++
++ return path_count;
++}
++
++char *
++get_relocated_path_list(char const * from, char const * to_path_list)
++{
++ char exe_path[MAX_PATH];
++ char * temp;
++ get_executable_path (NULL, &exe_path[0], sizeof (exe_path) / sizeof (exe_path[0]));
++ if ((temp = strrchr (exe_path, '/')) != NULL)
++ {
++ temp[1] = '\0';
++ }
++
++ char **arr = NULL;
++ /* Ask Alexey why he added this. Are we not 100% sure
++ that we're dealing with unix paths here? */
++ char split_char = ':';
++ if (strchr (to_path_list, ';'))
++ {
++ split_char = ';';
++ }
++ size_t count = split_path_list (to_path_list, split_char, &arr);
++ int result_size = 1 + (count - 1); /* count - 1 is for ; delim. */
++ size_t exe_path_size = strlen (exe_path);
++ size_t i;
++ /* Space required is:
++ count * (exe_path_size + strlen (rel_to_datadir))
++ rel_to_datadir upper bound is:
++ (count * strlen (from)) + (3 * num_slashes (from))
++ + strlen(arr[i]) + 1.
++ .. pathalogically num_slashes (from) is strlen (from)
++ (from = ////////) */
++ size_t space_required = (count * (exe_path_size + 4 * strlen (from))) + count - 1;
++ for (i = 0; i < count; ++i)
++ {
++ space_required += strlen (arr[i]);
++ }
++ char * scratch = (char *) alloca (space_required);
++ if (scratch == NULL)
++ return NULL;
++ for (i = 0; i < count; ++i)
++ {
++ char * rel_to_datadir = get_relative_path (from, arr[i]);
++ scratch[0] = '\0';
++ arr[i] = scratch;
++ strcat (scratch, exe_path);
++ strcat (scratch, rel_to_datadir);
++ simplify_path (arr[i]);
++ size_t arr_i_size = strlen (arr[i]);
++ result_size += arr_i_size;
++ scratch = arr[i] + arr_i_size + 1;
++ }
++ char * result = (char *) malloc (result_size);
++ if (result == NULL)
++ {
++ return NULL;
++ }
++ result[0] = '\0';
++ for (i = 0; i < count; ++i)
++ {
++ strcat (result, arr[i]);
++ if (i != count-1)
++ {
++#if defined(_WIN32)
++ strcat (result, ";");
++#else
++ strcat (result, ":");
++#endif
++ }
++ }
++ free ((void*)arr);
++ return result;
++}
++
++char *
++single_path_relocation(const char *from, const char *to)
++{
++#if defined(__MINGW32__)
++ char exe_path[PATH_MAX];
++ get_executable_path (NULL, &exe_path[0], sizeof(exe_path)/sizeof(exe_path[0]));
++ if (strrchr (exe_path, '/') != NULL)
++ {
++ strrchr (exe_path, '/')[1] = '\0';
++ }
++ char * rel_to_datadir = get_relative_path (from, to);
++ strcat (exe_path, rel_to_datadir);
++ simplify_path (&exe_path[0]);
++ return malloc_copy_string(exe_path);
++#else
++ return malloc_copy_string(to);
++#endif
++}
++
++char *
++pathlist_relocation(const char *from_path, const char *to_path_list)
++{
++#if defined(__MINGW32__)
++ static char stored_path[PATH_MAX];
++ static int stored = 0;
++ if (stored == 0)
++ {
++ char const * relocated = get_relocated_path_list(from_path, to_path_list);
++ strncpy (stored_path, relocated, PATH_MAX);
++ stored_path[PATH_MAX-1] = '\0';
++ free ((void *)relocated);
++ stored = 1;
++ }
++ return stored_path;
++#else
++ return (to_path_list);
++#endif
++}
+diff --git a/src/tools/pathtools.hxx b/src/tools/pathtools.hxx
+new file mode 100644
+index 0000000..ab2402f
+--- /dev/null
++++ b/src/tools/pathtools.hxx
+@@ -0,0 +1,106 @@
++/*
++ .Some useful path tools.
++ .ASCII only for now.
++ .Written by Ray Donnelly in 2014.
++ .Licensed under CC0 (and anything.
++ .else you need to license it under).
++ .No warranties whatsoever.
++ .email: <mingw.android@gmail.com>.
++ */
++
++#ifndef PATHTOOLS_H
++#define PATHTOOLS_H
++
++#include <unistd.h>
++#if defined(__APPLE__)
++#include <stdlib.h>
++#else
++#include <malloc.h>
++#endif
++#include <stdio.h>
++
++char * malloc_copy_string(char const * original);
++
++/* In-place replaces any '\' with '/' and any '//' with '/' */
++void sanitise_path(char * path);
++
++/* Uses a host OS specific function to determine the path of the executable,
++ if IMPLEMENT_SYS_GET_EXECUTABLE_PATH is defined, otherwise uses argv0. */
++int get_executable_path(char const * argv0, char * result, ssize_t max_size);
++
++/* Where possible, in-place removes occourances of '.' and 'path/..' */
++void simplify_path(char * path);
++
++/* Allocates (via malloc) and returns the path to get from from to to. */
++char * get_relative_path(char const * from, char const * to);
++
++size_t split_path_list(char const * path_list, char split_char, char *** arr);
++
++/* Advances path along by the amount that removes n prefix folders. */
++char const *
++strip_n_prefix_folders(char const * path, size_t n);
++
++/* NULL terminates path to remove n suffix folders. */
++void
++strip_n_suffix_folders(char * path, size_t n);
++
++char const * get_relocated_path (char const * from, char const * to, char const * actual_from);
++char * get_relocated_path_list(char const * from, char const * to_path_list);
++
++char * single_path_relocation(const char *from, const char *to);
++char * pathlist_relocation(const char *from_path, const char *to_path_list);
++
++#endif /* PATHTOOLS_H */
++/*
++ .Some useful path tools.
++ .ASCII only for now.
++ .Written by Ray Donnelly in 2014.
++ .Licensed under CC0 (and anything.
++ .else you need to license it under).
++ .No warranties whatsoever.
++ .email: <mingw.android@gmail.com>.
++ */
++
++#ifndef PATHTOOLS_H
++#define PATHTOOLS_H
++
++#include <unistd.h>
++#if defined(__APPLE__)
++#include <stdlib.h>
++#else
++#include <malloc.h>
++#endif
++#include <stdio.h>
++
++char * malloc_copy_string(char const * original);
++
++/* In-place replaces any '\' with '/' and any '//' with '/' */
++void sanitise_path(char * path);
++
++/* Uses a host OS specific function to determine the path of the executable,
++ if IMPLEMENT_SYS_GET_EXECUTABLE_PATH is defined, otherwise uses argv0. */
++int get_executable_path(char const * argv0, char * result, ssize_t max_size);
++
++/* Where possible, in-place removes occourances of '.' and 'path/..' */
++void simplify_path(char * path);
++
++/* Allocates (via malloc) and returns the path to get from from to to. */
++char * get_relative_path(char const * from, char const * to);
++
++size_t split_path_list(char const * path_list, char split_char, char *** arr);
++
++/* Advances path along by the amount that removes n prefix folders. */
++char const *
++strip_n_prefix_folders(char const * path, size_t n);
++
++/* NULL terminates path to remove n suffix folders. */
++void
++strip_n_suffix_folders(char * path, size_t n);
++
++char const * get_relocated_path (char const * from, char const * to, char const * actual_from);
++char * get_relocated_path_list(char const * from, char const * to_path_list);
++
++char * single_path_relocation(const char *from, const char *to);
++char * pathlist_relocation(const char *from_path, const char *to_path_list);
++
++#endif /* PATHTOOLS_H */
diff --git a/PKGBUILD b/PKGBUILD
index ab3ed72ab0ed..b6b52e94a9a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-hunspell
-pkgver=1.5.4
+pkgver=1.6.1
pkgrel=1
pkgdesc="Spell checker and morphological analyzer library (mingw-w64)"
arch=(any)
@@ -10,15 +10,16 @@ depends=(mingw-w64-gettext)
optdepends=(mingw-w64-readline)
options=(!strip !buildflags staticlibs !debug !emptydirs)
source=("https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
-"0005-windows-sub-dicts-paths.patch")
-md5sums=('9849a2381bacbeb2714034ad825bede8'
- '8f3f269734623b2c57521202877c51bd')
+"01-relocate.patch")
+sha256sums=('30f593733c50b794016bb03d31fd2a2071e4610c6fa4708e33edad2335102c49'
+ '2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd hunspell-${pkgver}
- patch -Np1 -i "${srcdir}"/0005-windows-sub-dicts-paths.patch
+ rm -rf src/tools/pathtools.cxx src/tools/pathtools.hxx
+ patch -Np1 -i ${srcdir}/01-relocate.patch
autoreconf -fi
}
@@ -31,10 +32,6 @@ build() {
--enable-threads=win32 \
--with-ui \
--with-readline
- # temporarily copy hunvisapi.h to work around build process
- # where the file is not spotted.
- cp ${srcdir}/hunspell-${pkgver}/build-${_arch}/src/hunspell/hunvisapi.h \
- "${srcdir}/hunspell-${pkgver}/src/hunspell"
make
popd
done