summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-06-23 18:48:23 -0400
committerAndrew Sun2018-06-23 18:48:23 -0400
commit3395437391775ef65fd15cba4d5d00b355f4baf8 (patch)
tree3b3666195231a6a448360f30cb1230a611e87971
parent07b10014e5bdecd5a68929e825108e8767a2ed21 (diff)
downloadaur-3395437391775ef65fd15cba4d5d00b355f4baf8.tar.gz
mingw-w64-hunspell: update to 1.6.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b99c3ab9d2b..b49bc096e7b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
-# Generated by mksrcinfo v8
-# Mon Jul 31 00:51:35 UTC 2017
pkgbase = mingw-w64-hunspell
- pkgdesc = Spell checker and morphological analyzer library (mingw-w64)
- pkgver = 1.6.1
+ pkgdesc = Spell checker and morphological analyzer library and program (mingw-w64)
+ pkgver = 1.6.2
pkgrel = 1
- url = http://hunspell.github.io/
+ url = https://hunspell.github.io/
arch = any
license = GPL
license = LGPL
license = MPL
makedepends = mingw-w64-configure
makedepends = mingw-w64-readline
+ makedepends = mingw-w64-wine
depends = mingw-w64-gettext
- optdepends = mingw-w64-readline
+ depends = mingw-w64-ncurses
+ depends = mingw-w64-readline
options = !strip
options = !buildflags
options = staticlibs
options = !debug
options = !emptydirs
- source = https://github.com/hunspell/hunspell/archive/v1.6.1.tar.gz
+ source = hunspell-1.6.2.tar.gz::https://github.com/hunspell/hunspell/archive/v1.6.2.tar.gz
source = 01-relocate.patch
- sha256sums = 30f593733c50b794016bb03d31fd2a2071e4610c6fa4708e33edad2335102c49
+ sha256sums = 3cd9ceb062fe5814f668e4f22b2fa6e3ba0b339b921739541ce180cac4d6f4c4
sha256sums = 2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806
pkgname = mingw-w64-hunspell
diff --git a/PKGBUILD b/PKGBUILD
index b6b52e94a9a3..0bfafc1c0c37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
pkgname=mingw-w64-hunspell
-pkgver=1.6.1
+pkgver=1.6.2
pkgrel=1
-pkgdesc="Spell checker and morphological analyzer library (mingw-w64)"
+pkgdesc="Spell checker and morphological analyzer library and program (mingw-w64)"
arch=(any)
-url="http://hunspell.github.io/"
+url="https://hunspell.github.io/"
license=("GPL" "LGPL" "MPL")
-makedepends=(mingw-w64-configure mingw-w64-readline)
-depends=(mingw-w64-gettext)
-optdepends=(mingw-w64-readline)
+makedepends=('mingw-w64-configure' 'mingw-w64-readline' 'mingw-w64-wine')
+depends=('mingw-w64-gettext' 'mingw-w64-ncurses' 'mingw-w64-readline')
options=(!strip !buildflags staticlibs !debug !emptydirs)
-source=("https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
-"01-relocate.patch")
-sha256sums=('30f593733c50b794016bb03d31fd2a2071e4610c6fa4708e33edad2335102c49'
+source=("hunspell-${pkgver}.tar.gz"::"https://github.com/hunspell/hunspell/archive/v${pkgver}.tar.gz"
+ "01-relocate.patch")
+sha256sums=('3cd9ceb062fe5814f668e4f22b2fa6e3ba0b339b921739541ce180cac4d6f4c4'
'2730c6cbca341db54f5d4a53a81c89f8e91ac6e3060af9740f5bb15185067806')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd hunspell-${pkgver}
+ cd "${srcdir}/hunspell-${pkgver}"
+
+ # Remove files created by patch
rm -rf src/tools/pathtools.cxx src/tools/pathtools.hxx
patch -Np1 -i ${srcdir}/01-relocate.patch
autoreconf -fi