summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2015-06-08 23:39:54 -0700
committerSchala2015-06-08 23:39:54 -0700
commitc9909de660f9871678b5973d2bc5a2689fbeffd9 (patch)
tree8b9bd96f5144496bfbbd98f5e22d8c072b914d12
downloadaur-c9909de660f9871678b5973d2bc5a2689fbeffd9.tar.gz
update to 55.1
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore4
-rw-r--r--0004-move-to-bin.mingw.patch20
-rw-r--r--0007-actually-move-to-bin.mingw.patch184
-rw-r--r--0008-data-install-dir.mingw.patch11
-rw-r--r--0009-fix-bindir-in-config.mingw.patch11
-rw-r--r--0010-msys-rules-for-makefiles.mingw.patch36
-rw-r--r--0011-sbin-dir.mingw.patch28
-rw-r--r--0012-libprefix.mingw.patch92
-rw-r--r--0014-mingwize-pkgdata.mingw.patch41
-rw-r--r--0015-debug.mingw.patch33
-rw-r--r--0016-icu-pkgconfig.patch29
-rw-r--r--PKGBUILD87
13 files changed, 614 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf034f9a3e9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = mingw-w64-icu
+ pkgdesc = International Components for Unicode library (mingw-w64)
+ pkgver = 55.1
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = any
+ license = custom:icu
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ options = !emptydirs
+ source = http://download.icu-project.org/files/icu4c/55.1/icu4c-55_1-src.tgz
+ source = 0004-move-to-bin.mingw.patch
+ source = 0007-actually-move-to-bin.mingw.patch
+ source = 0008-data-install-dir.mingw.patch
+ source = 0009-fix-bindir-in-config.mingw.patch
+ source = 0010-msys-rules-for-makefiles.mingw.patch
+ source = 0011-sbin-dir.mingw.patch
+ source = 0012-libprefix.mingw.patch
+ source = 0014-mingwize-pkgdata.mingw.patch
+ source = 0015-debug.mingw.patch
+ source = 0016-icu-pkgconfig.patch
+ md5sums = e2d523df79d6cb7855c2fbe284f4db29
+ md5sums = 4c8143786ed499184e64fc5a1a1d0fdf
+ md5sums = eb56b72df2ca0dc77261c4f2adc5c8ad
+ md5sums = 9c63125f7bdd88871c89e13ee62ac02b
+ md5sums = 93830d77021eab270e537d466653557e
+ md5sums = cce2427d95bcb4a364df5ab605c3e9a3
+ md5sums = ee93f131a132f7e65d11d15a467b7abc
+ md5sums = f43d08a14a3e723977178fed136e58b1
+ md5sums = 74415f3f3876b5f2f7cea0c5d367c5c6
+ md5sums = d1accfbefbcd399a4a28a4a4e0737915
+ md5sums = 3f13cf5733c4a9363c5823a24d3fba85
+
+pkgname = mingw-w64-icu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..200217578e54
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tgz
+*.xz
diff --git a/0004-move-to-bin.mingw.patch b/0004-move-to-bin.mingw.patch
new file mode 100644
index 000000000000..70fdb420adb0
--- /dev/null
+++ b/0004-move-to-bin.mingw.patch
@@ -0,0 +1,20 @@
+--- icu/source/tools/genren/Makefile.orig 2013-10-04 20:49:44.000000000 +0000
++++ icu/source/tools/genren/Makefile 2014-02-01 11:39:37.631753000 +0000
+@@ -30,12 +30,12 @@
+ include $(BUILDDIR)/icudefs.mk
+ endif
+
+-COM=$(ICUDIR)/lib/libicuuc.$(SO)
+-I18=$(ICUDIR)/lib/libicui18n.$(SO)
+-LAY=$(ICUDIR)/lib/libicule.$(SO)
+-LEX=$(ICUDIR)/lib/libiculx.$(SO)
++COM=$(ICUDIR)/bin/libicuuc.$(SO)
++I18=$(ICUDIR)/bin/libicui18n.$(SO)
++LAY=$(ICUDIR)/bin/libicule.$(SO)
++LEX=$(ICUDIR)/bin/libiculx.$(SO)
+ DAT=$(ICUDIR)/stubdata/libicudata.$(SO)
+-UIO=$(ICUDIR)/lib/libicuio.$(SO)
++UIO=$(ICUDIR)/bin/libicuio.$(SO)
+
+ LIBS=$(COM) $(I18) $(LAY) $(LEX) $(UIO)
+
diff --git a/0007-actually-move-to-bin.mingw.patch b/0007-actually-move-to-bin.mingw.patch
new file mode 100644
index 000000000000..77c8e80232c9
--- /dev/null
+++ b/0007-actually-move-to-bin.mingw.patch
@@ -0,0 +1,184 @@
+--- icu/source/common/Makefile.in.orig 2013-10-04 20:49:26.000000000 +0000
++++ icu/source/common/Makefile.in 2014-02-01 13:20:07.278920900 +0000
+@@ -141,16 +141,16 @@
+ install-local: install-headers install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
+--- icu/source/i18n/Makefile.in.orig 2013-10-04 20:48:52.000000000 +0000
++++ icu/source/i18n/Makefile.in 2014-02-01 13:22:41.831046600 +0000
+@@ -121,16 +121,16 @@
+ install-local: install-headers install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
+--- icu/source/io/Makefile.in.orig 2013-10-04 20:50:00.000000000 +0000
++++ icu/source/io/Makefile.in 2014-02-01 13:23:27.458340500 +0000
+@@ -94,16 +94,16 @@
+ install-local: install-headers install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
+--- icu/source/layout/Makefile.in.orig 2013-10-04 20:54:54.000000000 +0000
++++ icu/source/layout/Makefile.in 2014-02-01 13:24:13.288160100 +0000
+@@ -178,16 +178,16 @@
+ install-local: install-headers install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
+--- icu/source/layoutex/Makefile.in.orig 2013-10-04 20:54:46.000000000 +0000
++++ icu/source/layoutex/Makefile.in 2014-02-01 13:25:00.140109600 +0000
+@@ -95,16 +95,16 @@
+ install-local: install-headers install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
+--- icu/source/stubdata/Makefile.in.orig 2013-10-04 20:50:02.000000000 +0000
++++ icu/source/stubdata/Makefile.in 2014-02-01 13:25:36.860772500 +0000
+@@ -80,16 +80,16 @@
+ install-local: install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
+--- icu/source/tools/ctestfw/Makefile.in.orig 2013-10-04 20:49:32.000000000 +0000
++++ icu/source/tools/ctestfw/Makefile.in 2014-02-01 13:58:35.642045800 +0000
+@@ -76,16 +76,16 @@
+ install-local: install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
+--- icu/source/tools/toolutil/Makefile.in.orig 2013-10-04 20:49:40.000000000 +0000
++++ icu/source/tools/toolutil/Makefile.in 2014-02-01 13:59:28.907309700 +0000
+@@ -87,16 +87,16 @@
+ install-local: install-library
+
+ install-library: all-local
+- $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+ ifneq ($(ENABLE_STATIC),)
+ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
+ endif
+ ifneq ($(ENABLE_SHARED),)
+- $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(bindir)
+ ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
+ ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
+- cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(bindir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
+ endif
+ endif
+ ifneq ($(IMPORT_LIB_EXT),)
diff --git a/0008-data-install-dir.mingw.patch b/0008-data-install-dir.mingw.patch
new file mode 100644
index 000000000000..ecba9a53c5fe
--- /dev/null
+++ b/0008-data-install-dir.mingw.patch
@@ -0,0 +1,11 @@
+--- icu/source/data/Makefile.in.orig 2013-10-04 20:54:44.000000000 +0000
++++ icu/source/data/Makefile.in 2014-02-01 13:37:24.732160800 +0000
+@@ -203,7 +203,7 @@
+ endif
+ ifneq ($(ENABLE_STATIC),)
+ ifeq ($(PKGDATA_MODE),dll)
+- $(PKGDATA_INVOKE) $(PKGDATA) -m static -e $(ICUDATA_ENTRY_POINT) -T $(OUTTMPDIR) -s $(BUILDDIR) -p $(ICUDATA_NAME) $(PKGDATA_LIBSTATICNAME) $(PKGDATA_LIST) -I $(ICUPKGDATA_INSTALL_LIBDIR)
++ $(PKGDATA_INVOKE) $(PKGDATA) -m static -e $(ICUDATA_ENTRY_POINT) -T $(OUTTMPDIR) -s $(BUILDDIR) -p $(ICUDATA_NAME) $(PKGDATA_LIBSTATICNAME) $(PKGDATA_LIST) -I $(DESTDIR)$(bindir)
+ endif
+ endif
+ ifneq ($(ICUDATA_SOURCE_IS_NATIVE_TARGET),YES)
diff --git a/0009-fix-bindir-in-config.mingw.patch b/0009-fix-bindir-in-config.mingw.patch
new file mode 100644
index 000000000000..2f6420b169fd
--- /dev/null
+++ b/0009-fix-bindir-in-config.mingw.patch
@@ -0,0 +1,11 @@
+--- icu/source/config/icu-config-bottom.orig 2013-10-04 20:50:00.000000000 +0000
++++ icu/source/config/icu-config-bottom 2014-02-01 15:33:11.255757200 +0000
+@@ -3,7 +3,7 @@
+ ## Copyright (c) 2002-2013, International Business Machines Corporation and
+ ## others. All Rights Reserved.
+
+-ICUUC_FILE="${libdir}/${ICULIBS_COMMON_LIB_NAME}"
++ICUUC_FILE="${bindir}/${ICULIBS_COMMON_LIB_NAME}"
+ ICUUC_FILE_A="${libdir}/${ICULIBS_COMMON_LIB_NAME_A}"
+
+ # echo ENABLE RPATH $ENABLE_RPATH and RPATHLDFLAGS=${RPATH_LDFLAGS}
diff --git a/0010-msys-rules-for-makefiles.mingw.patch b/0010-msys-rules-for-makefiles.mingw.patch
new file mode 100644
index 000000000000..31afd3943495
--- /dev/null
+++ b/0010-msys-rules-for-makefiles.mingw.patch
@@ -0,0 +1,36 @@
+--- icu/source/config/mh-mingw.orig 2013-10-04 20:50:00.000000000 +0000
++++ icu/source/config/mh-mingw 2014-02-06 17:53:24.827138600 +0000
+@@ -82,11 +82,11 @@
+
+ # The #M# is used to delete lines for icu-config
+ # Current full path directory.
+-#CURR_FULL_DIR=$(shell pwd -W)#M# for MSYS
+-CURR_FULL_DIR?=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
++CURR_FULL_DIR=$(shell $(SHELL) -c "pwd -W")#M# for MSYS
++#CURR_FULL_DIR?=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
+ # Current full path directory for use in source code in a -D compiler option.
+-#CURR_SRCCODE_FULL_DIR=$(subst /,\\\\,$(shell pwd -W))#M# for MSYS
+-CURR_SRCCODE_FULL_DIR=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
++CURR_SRCCODE_FULL_DIR=$(subst /,\\\\,$(shell $(SHELL) -c "pwd -W"))#M# for MSYS
++#CURR_SRCCODE_FULL_DIR=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
+
+ ## Compilation rules
+ %.$(STATIC_O): $(srcdir)/%.c
+--- icu/source/config/mh-mingw64.orig 2013-10-04 20:50:00.000000000 +0000
++++ icu/source/config/mh-mingw64 2014-02-06 17:53:10.783855300 +0000
+@@ -82,11 +82,11 @@
+
+ # The #M# is used to delete lines for icu-config
+ # Current full path directory.
+-#CURR_FULL_DIR=$(shell pwd -W)#M# for MSYS
+-CURR_FULL_DIR?=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
++CURR_FULL_DIR=$(shell $(SHELL) -c "pwd -W")#M# for MSYS
++#CURR_FULL_DIR?=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
+ # Current full path directory for use in source code in a -D compiler option.
+-#CURR_SRCCODE_FULL_DIR=$(subst /,\\\\,$(shell pwd -W))#M# for MSYS
+-CURR_SRCCODE_FULL_DIR=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
++CURR_SRCCODE_FULL_DIR=$(subst /,\\\\,$(shell $(SHELL) -c "pwd -W"))#M# for MSYS
++#CURR_SRCCODE_FULL_DIR=$(subst \,/,$(shell cmd /c cd))#M# for Cygwin shell
+
+ ## Compilation rules
+ %.$(STATIC_O): $(srcdir)/%.c
diff --git a/0011-sbin-dir.mingw.patch b/0011-sbin-dir.mingw.patch
new file mode 100644
index 000000000000..7cba9de2593e
--- /dev/null
+++ b/0011-sbin-dir.mingw.patch
@@ -0,0 +1,28 @@
+--- icu/source/config/mh-mingw.orig 2014-02-06 18:07:17.886923700 +0000
++++ icu/source/config/mh-mingw 2014-02-06 18:11:32.766789400 +0000
+@@ -8,11 +8,6 @@
+ # This file is similar to mh-mingw64
+ # Any changes made here may also need to be made in mh-mingw64
+
+-# We install sbin tools into the same bin directory because
+-# pkgdata needs some of the tools in sbin, and we can't always depend on
+-# icu-config working on Windows.
+-sbindir=$(bindir)
+-
+ ## Commands to generate dependency files
+ GEN_DEPS.c= $(CC) -E -MM $(DEFS) $(CPPFLAGS)
+ GEN_DEPS.cc= $(CXX) -E -MM $(DEFS) $(CPPFLAGS)
+--- icu/source/config/mh-mingw64.orig 2014-02-06 18:07:17.888423900 +0000
++++ icu/source/config/mh-mingw64 2014-02-06 18:11:37.160847300 +0000
+@@ -8,11 +8,6 @@
+ # This file is similar to mh-mingw
+ # Any changes made here may also need to be made in mh-mingw
+
+-# We install sbin tools into the same bin directory because
+-# pkgdata needs some of the tools in sbin, and we can't always depend on
+-# icu-config working on Windows.
+-sbindir=$(bindir)
+-
+ ## Commands to generate dependency files
+ GEN_DEPS.c= $(CC) -E -MM $(DEFS) $(CPPFLAGS)
+ GEN_DEPS.cc= $(CXX) -E -MM $(DEFS) $(CPPFLAGS)
diff --git a/0012-libprefix.mingw.patch b/0012-libprefix.mingw.patch
new file mode 100644
index 000000000000..7f01e93d4129
--- /dev/null
+++ b/0012-libprefix.mingw.patch
@@ -0,0 +1,92 @@
+diff -urN icu.orig/source/config/mh-mingw icu/source/config/mh-mingw
+--- icu.orig/source/config/mh-mingw 2014-04-17 22:21:37.195201800 +0100
++++ icu/source/config/mh-mingw 2014-04-17 22:09:02.956061800 +0100
+@@ -39,8 +39,8 @@
+ LD_SOOPTIONS= -Wl,-Bsymbolic
+
+ ## Commands to make a shared library
+-SHLIB.c= $(CC) $(CFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)lib$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
+-SHLIB.cc= $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)lib$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
++SHLIB.c= $(CC) $(CFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
++SHLIB.cc= $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
+
+ ## Compiler switch to embed a runtime search path
+ LD_RPATH=
+@@ -61,19 +61,19 @@
+ endif
+
+ # Static library prefix and file extension
+-LIBSICU = lib$(LIBPREFIX)$(STATIC_PREFIX)$(ICUPREFIX)
++LIBSICU = $(LIBPREFIX)$(STATIC_PREFIX)$(ICUPREFIX)
+ A = a
+
+ ## An import library is needed for z/OS and MSVC
+ IMPORT_LIB_EXT = .dll.a
+
+-LIBPREFIX=
++LIBPREFIX=lib
+
+ # Change the stubnames so that poorly working FAT disks and installation programs can work.
+ # This is also for backwards compatibility.
+ DATA_STUBNAME = dt
+ I18N_STUBNAME = in
+-LIBICU = $(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)
++LIBICU = $(LIBPREFIX)$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)
+
+ # The #M# is used to delete lines for icu-config
+ # Current full path directory.
+@@ -125,7 +125,7 @@
+ FINAL_SO_TARGET=$(basename $(SO_TARGET))$(SO_TARGET_VERSION_MAJOR).$(SO)
+ MIDDLE_SO_TARGET=$(FINAL_SO_TARGET)
+
+-FINAL_IMPORT_LIB = $(dir $(SO_TARGET))lib$(notdir $(basename $(SO_TARGET)))$(IMPORT_LIB_EXT)#M#
++FINAL_IMPORT_LIB = $(dir $(SO_TARGET))$(notdir $(basename $(SO_TARGET)))$(IMPORT_LIB_EXT)#M#
+ IMPORT_LIB = $(FINAL_IMPORT_LIB)#M#
+ MIDDLE_IMPORT_LIB = $(FINAL_IMPORT_LIB)#M#
+
+diff -urN icu.orig/source/config/mh-mingw64 icu/source/config/mh-mingw64
+--- icu.orig/source/config/mh-mingw64 2014-04-17 22:21:37.195201800 +0100
++++ icu/source/config/mh-mingw64 2014-04-17 22:08:50.428345300 +0100
+@@ -39,8 +39,8 @@
+ LD_SOOPTIONS= -Wl,-Bsymbolic
+
+ ## Commands to make a shared library
+-SHLIB.c= $(CC) $(CFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)lib$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
+-SHLIB.cc= $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)lib$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
++SHLIB.c= $(CC) $(CFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
++SHLIB.cc= $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(LD_SOOPTIONS) -Wl,--enable-auto-import -Wl,--out-implib=$(dir $@)$(notdir $(@:$(SO_TARGET_VERSION_MAJOR).$(SO)=))$(IMPORT_LIB_EXT)#M#
+
+ ## Compiler switch to embed a runtime search path
+ LD_RPATH=
+@@ -61,19 +61,19 @@
+ endif
+
+ # Static library prefix and file extension
+-LIBSICU = lib$(LIBPREFIX)$(STATIC_PREFIX)$(ICUPREFIX)
++LIBSICU = $(LIBPREFIX)$(STATIC_PREFIX)$(ICUPREFIX)
+ A = a
+
+ ## An import library is needed for z/OS and MSVC
+ IMPORT_LIB_EXT = .dll.a
+
+-LIBPREFIX=
++LIBPREFIX=lib
+
+ # Change the stubnames so that poorly working FAT disks and installation programs can work.
+ # This is also for backwards compatibility.
+ DATA_STUBNAME = dt
+ I18N_STUBNAME = in
+-LIBICU = $(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)
++LIBICU = $(LIBPREFIX)$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)
+
+ # The #M# is used to delete lines for icu-config
+ # Current full path directory.
+@@ -125,7 +125,7 @@
+ FINAL_SO_TARGET=$(basename $(SO_TARGET))$(SO_TARGET_VERSION_MAJOR).$(SO)
+ MIDDLE_SO_TARGET=$(FINAL_SO_TARGET)
+
+-FINAL_IMPORT_LIB = $(dir $(SO_TARGET))lib$(notdir $(basename $(SO_TARGET)))$(IMPORT_LIB_EXT)#M#
++FINAL_IMPORT_LIB = $(dir $(SO_TARGET))$(notdir $(basename $(SO_TARGET)))$(IMPORT_LIB_EXT)#M#
+ IMPORT_LIB = $(FINAL_IMPORT_LIB)#M#
+ MIDDLE_IMPORT_LIB = $(FINAL_IMPORT_LIB)#M#
+
diff --git a/0014-mingwize-pkgdata.mingw.patch b/0014-mingwize-pkgdata.mingw.patch
new file mode 100644
index 000000000000..051673c62f69
--- /dev/null
+++ b/0014-mingwize-pkgdata.mingw.patch
@@ -0,0 +1,41 @@
+--- icu/source/tools/pkgdata/pkgdata.cpp.orig 2013-10-04 20:49:38.000000000 +0000
++++ icu/source/tools/pkgdata/pkgdata.cpp 2014-02-06 19:09:43.258525500 +0000
+@@ -868,21 +868,10 @@
+ const char* FILE_EXTENSION_SEP = uprv_strlen(pkgDataFlags[SO_EXT]) == 0 ? "" : ".";
+ const char* FILE_SUFFIX = pkgDataFlags[LIB_EXT_ORDER][0] == '.' ? "." : "";
+
+-#if U_PLATFORM == U_PF_MINGW
+- /* MinGW does not need the library prefix when building in dll mode. */
+- if (IN_DLL_MODE(mode)) {
+- sprintf(libFileNames[LIB_FILE], "%s", libName);
+- } else {
+- sprintf(libFileNames[LIB_FILE], "%s%s",
+- pkgDataFlags[LIBPREFIX],
+- libName);
+- }
+-#else
+ sprintf(libFileNames[LIB_FILE], "%s%s",
+ pkgDataFlags[LIBPREFIX],
+ libName);
+-#endif
+
+ if(o->verbose) {
+ fprintf(stdout, "# libFileName[LIB_FILE] = %s\n", libFileNames[LIB_FILE]);
+ }
+--- icu/source/tools/pkgdata/pkgtypes.h.orig 2013-10-04 20:49:38.000000000 +0000
++++ icu/source/tools/pkgdata/pkgtypes.h 2014-02-06 19:10:24.970822300 +0000
+@@ -138,10 +138,10 @@
+ # ifndef UDATA_SO_SUFFIX
+ # define UDATA_SO_SUFFIX ".dll"
+ # endif
+-# define LIB_PREFIX ""
+-# define LIB_STATIC_PREFIX ""
+-# define OBJ_SUFFIX ".obj"
+-# define UDATA_LIB_SUFFIX ".lib"
++# define LIB_PREFIX "lib"
++# define LIB_STATIC_PREFIX "lib"
++# define OBJ_SUFFIX ".o"
++# define UDATA_LIB_SUFFIX ".a"
+
+ #elif U_PLATFORM == U_PF_CYGWIN
+ # define LIB_PREFIX "cyg"
diff --git a/0015-debug.mingw.patch b/0015-debug.mingw.patch
new file mode 100644
index 000000000000..21578a6fce48
--- /dev/null
+++ b/0015-debug.mingw.patch
@@ -0,0 +1,33 @@
+--- icu/source/tools/pkgdata/pkgdata.cpp.orig 2014-02-07 08:37:03.380639800 +0000
++++ icu/source/tools/pkgdata/pkgdata.cpp 2014-02-07 08:43:36.684083000 +0000
+@@ -1276,6 +1276,18 @@
+ freeCmd = TRUE;
+ }
+ #if U_PLATFORM == U_PF_MINGW
++ fprintf(stderr, "genlib=%s targetdir=%s libfilenames=%s -o pkgdataflags=%s targetdir=%s libfilenames=%s objectfileandeverythingelse=%s %s%s %s %s",
++ pkgDataFlags[GENLIB],
++ targetDir,
++ libFileNames[LIB_FILE_MINGW],
++ pkgDataFlags[LDICUDTFLAGS],
++ targetDir,
++ libFileNames[LIB_FILE_VERSION_TMP],
++ objectFile,
++ pkgDataFlags[LD_SONAME],
++ pkgDataFlags[LD_SONAME][0] == 0 ? "" : libFileNames[LIB_FILE_VERSION_MAJOR],
++ pkgDataFlags[RPATH_FLAGS],
++ pkgDataFlags[BIR_FLAGS]);
+ sprintf(cmd, "%s%s%s %s -o %s%s %s %s%s %s %s",
+ pkgDataFlags[GENLIB],
+ targetDir,
+diff -urN icu/source/configure.ac.orig icu/source/configure.ac
+--- icu/source/configure.ac.orig 2014-04-20 16:00:12.325064200 +0100
++++ icu/source/configure.ac 2014-04-20 16:05:49.914432600 +0100
+@@ -1173,7 +1173,7 @@
+ if test "$ICULIBSUFFIX" != ""
+ then
+ U_HAVE_LIB_SUFFIX=1
+- ICULIBSUFFIXCNAME=`echo _$ICULIBSUFFIX | sed 's/[^A-Za-z0-9_]/_/g'`
++ ICULIBSUFFIXCNAME=`echo $ICULIBSUFFIX | sed 's/[^A-Za-z0-9_]/_/g'`
+ UCONFIG_CPPFLAGS="${UCONFIG_CPPFLAGS} -DU_HAVE_LIB_SUFFIX=1 -DU_LIB_SUFFIX_C_NAME=${ICULIBSUFFIXCNAME} "
+ else
+ U_HAVE_LIB_SUFFIX=0
diff --git a/0016-icu-pkgconfig.patch b/0016-icu-pkgconfig.patch
new file mode 100644
index 000000000000..49d25024aa8f
--- /dev/null
+++ b/0016-icu-pkgconfig.patch
@@ -0,0 +1,29 @@
+--- icu-54_1/source/icudefs.mk.in.orig 2012-11-05 20:18:14 +0300
++++ icu-54_1/source/icudefs.mk.in 2012-12-17 10:29:24 +0300
+@@ -262,18 +262,18 @@
+ USING_ICULEHB=no
+ ICULEHB_TRUE=#
+ ICULEHB_FALSE=
+-ICULIBS_LE = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(LAYOUT_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
++ICULIBS_LE = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(LAYOUT_STUBNAME)$(ICULIBSUFFIX)
+ ICULE_CFLAGS=-I$(top_srcdir)
+ endif
+
+ # Just the libs.
+-ICULIBS_DT = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(DATA_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
+-ICULIBS_UC = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(COMMON_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
+-ICULIBS_I18N = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(I18N_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
+-ICULIBS_LX = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(LAYOUTEX_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
+-ICULIBS_IO = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(IO_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
+-ICULIBS_CTESTFW = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(CTESTFW_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
+-ICULIBS_TOOLUTIL = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(TOOLUTIL_STUBNAME)$(ICULIBSUFFIX)$(SO_TARGET_VERSION_SUFFIX)
++ICULIBS_DT = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(DATA_STUBNAME)$(ICULIBSUFFIX)
++ICULIBS_UC = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(COMMON_STUBNAME)$(ICULIBSUFFIX)
++ICULIBS_I18N = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(I18N_STUBNAME)$(ICULIBSUFFIX)
++ICULIBS_LX = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(LAYOUTEX_STUBNAME)$(ICULIBSUFFIX)
++ICULIBS_IO = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(IO_STUBNAME)$(ICULIBSUFFIX)
++ICULIBS_CTESTFW = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(CTESTFW_STUBNAME)$(ICULIBSUFFIX)
++ICULIBS_TOOLUTIL = -l$(STATIC_PREFIX_WHEN_USED)$(ICUPREFIX)$(TOOLUTIL_STUBNAME)$(ICULIBSUFFIX)
+ # Link commands to link to ICU libs
+ LLIBDIR = -L$(LIBDIR)
+ LSTUBDIR = -L$(top_builddir)/stubdata
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26c62577047d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,87 @@
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Alexey Pavlov <Alexpux@gmail.com>
+# Contributor: Ray Donnelly <mingw.android@gmail.com>
+_realname=icu
+pkgname=mingw-w64-${_realname}
+pkgver=55.1
+pkgrel=1
+arch=(any)
+pkgdesc="International Components for Unicode library (mingw-w64)"
+url="http://www.icu-project.org/"
+license=("custom:icu")
+depends=(mingw-w64-crt)
+makedepends=(mingw-w64-configure)
+options=(!buildflags staticlibs !strip !emptydirs)
+source=("http://download.icu-project.org/files/icu4c/${pkgver}/icu4c-${pkgver//./_}-src.tgz"
+"0004-move-to-bin.mingw.patch"
+"0007-actually-move-to-bin.mingw.patch"
+"0008-data-install-dir.mingw.patch"
+"0009-fix-bindir-in-config.mingw.patch"
+"0010-msys-rules-for-makefiles.mingw.patch"
+"0011-sbin-dir.mingw.patch"
+"0012-libprefix.mingw.patch"
+"0014-mingwize-pkgdata.mingw.patch"
+"0015-debug.mingw.patch"
+"0016-icu-pkgconfig.patch")
+md5sums=('e2d523df79d6cb7855c2fbe284f4db29'
+ '4c8143786ed499184e64fc5a1a1d0fdf'
+ 'eb56b72df2ca0dc77261c4f2adc5c8ad'
+ '9c63125f7bdd88871c89e13ee62ac02b'
+ '93830d77021eab270e537d466653557e'
+ 'cce2427d95bcb4a364df5ab605c3e9a3'
+ 'ee93f131a132f7e65d11d15a467b7abc'
+ 'f43d08a14a3e723977178fed136e58b1'
+ '74415f3f3876b5f2f7cea0c5d367c5c6'
+ 'd1accfbefbcd399a4a28a4a4e0737915'
+ '3f13cf5733c4a9363c5823a24d3fba85')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd icu
+ patch -p1 -i ../0004-move-to-bin.mingw.patch
+ patch -p1 -i ../0007-actually-move-to-bin.mingw.patch
+ patch -p1 -i ../0008-data-install-dir.mingw.patch
+ patch -p1 -i ../0009-fix-bindir-in-config.mingw.patch
+ patch -p1 -i ../0010-msys-rules-for-makefiles.mingw.patch
+ patch -p1 -i ../0011-sbin-dir.mingw.patch
+ patch -p1 -i ../0012-libprefix.mingw.patch
+ patch -p1 -i ../0014-mingwize-pkgdata.mingw.patch
+ patch -p1 -i ../0015-debug.mingw.patch
+ patch -p1 -i ../0016-icu-pkgconfig.patch
+
+ cd source
+ autoreconf -vfi
+}
+
+build() {
+ cd icu/source
+ mkdir -p nativebuild && pushd nativebuild
+ CFLAGS=-fno-stack-protector
+ ../configure --enable-static --disable-shared
+ make
+ popd
+ for _arch in ${_architectures}; do
+ mkdir build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --with-cross-build=$PWD/../nativebuild \
+ --with-data-packaging=library \
+ --disable-rpath \
+ --enable-release
+ make -j1
+ popd
+ done
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ for _arch in ${_architectures}; do
+ cd "$srcdir/icu/source/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -r "$pkgdir/usr/${_arch}/share"
+ ln -s "/usr/${_arch}/bin/icu-config" "$pkgdir/usr/bin/${_arch}-icu-config"
+ done
+}