summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-12-27 12:06:58 +0100
committerNicola Murino2020-12-27 12:06:58 +0100
commitde990f8bacfdc5b7a929f9292488d2dbedabe84b (patch)
tree31dd7af0f7d54c52da24a29f37a315f3fdd844e4
parent126d3ae18309723842d66d6900fabdca2942da1f (diff)
downloadaur-de990f8bacfdc5b7a929f9292488d2dbedabe84b.tar.gz
update to 2.0.23
-rw-r--r--.SRCINFO12
-rw-r--r--002-add-more-exports.patch132
-rw-r--r--004-jasper-exports.patch27
-rw-r--r--PKGBUILD15
4 files changed, 42 insertions, 144 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64e9e89138db..300e3abdff22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mingw-w64-jasper
pkgdesc = A software-based implementation of the codec specified in the emerging JPEG-2000 Part-1 standard (mingw-w64)
- pkgver = 2.0.16
+ pkgver = 2.0.23
pkgrel = 1
- url = http://www.ece.uvic.ca/~mdadams/jasper
+ url = https://www.ece.uvic.ca/~mdadams/jasper/
arch = any
license = custom:JasPer2.0
makedepends = mingw-w64-cmake
@@ -10,15 +10,15 @@ pkgbase = mingw-w64-jasper
options = staticlibs
options = !strip
options = !buildflags
- source = https://github.com/mdadams/jasper/archive/version-2.0.16.tar.gz
+ source = https://github.com/mdadams/jasper/archive/version-2.0.23.tar.gz
source = jasper-1.900.1-fix-filename-buffer-overflow.patch
source = 001-mingw-cmake.patch
- source = 002-add-more-exports.patch
+ source = 004-jasper-exports.patch
source = jasper-static-fix.patch
- sha256sums = f1d8b90f231184d99968f361884e2054a1714fdbbd9944ba1ae4ebdcc9bbfdb1
+ sha256sums = 20facc904bd9d38c20e0c090b1be3ae02ae5b2703b803013be2ecad586a18927
sha256sums = f51377e9b3e4faaa6b17b2d5fcf6f6d94fe2916a65dc9c78b5a99b891f5726dc
sha256sums = 2b261c9b40b973d0d11f7b2b6842b36aee45657cbd5e0780fa73cb184f570b65
- sha256sums = 48c60686d7e3c737f282513d78f8e6263e5f555d71de625002e3fba1c38c8850
+ sha256sums = aef39fbaf65c0453a785eb563253f2bb66806ddbebcd836b8bd8dce67c7059eb
sha256sums = 3102b4175d714df84a63b8ebf3c0f346fc09a0a784a560917994f6074d6b1697
pkgname = mingw-w64-jasper
diff --git a/002-add-more-exports.patch b/002-add-more-exports.patch
deleted file mode 100644
index e38eb23627eb..000000000000
--- a/002-add-more-exports.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-diff -Naur jasper-version-2.0.13-orig/src/libjasper/include/jasper/jas_image.h jasper-version-2.0.13/src/libjasper/include/jasper/jas_image.h
---- jasper-version-2.0.13-orig/src/libjasper/include/jasper/jas_image.h 2017-05-19 03:21:50.000000000 +0300
-+++ jasper-version-2.0.13/src/libjasper/include/jasper/jas_image.h 2017-09-11 08:56:10.654417700 +0300
-@@ -492,14 +492,14 @@
-
-
- #define jas_image_cmprof(image) ((image)->cmprof_)
--int jas_image_ishomosamp(jas_image_t *image);
--int jas_image_sampcmpt(jas_image_t *image, int cmptno, int newcmptno,
-+JAS_DLLEXPORT int jas_image_ishomosamp(jas_image_t *image);
-+JAS_DLLEXPORT int jas_image_sampcmpt(jas_image_t *image, int cmptno, int newcmptno,
- jas_image_coord_t ho, jas_image_coord_t vo, jas_image_coord_t hs,
- jas_image_coord_t vs, int sgnd, int prec);
--int jas_image_writecmpt2(jas_image_t *image, int cmptno, jas_image_coord_t x,
-+JAS_DLLEXPORT int jas_image_writecmpt2(jas_image_t *image, int cmptno, jas_image_coord_t x,
- jas_image_coord_t y, jas_image_coord_t width, jas_image_coord_t height,
- long *buf);
--int jas_image_readcmpt2(jas_image_t *image, int cmptno, jas_image_coord_t x,
-+JAS_DLLEXPORT int jas_image_readcmpt2(jas_image_t *image, int cmptno, jas_image_coord_t x,
- jas_image_coord_t y, jas_image_coord_t width, jas_image_coord_t height,
- long *buf);
-
-@@ -514,58 +514,58 @@
-
- #if !defined(EXCLUDE_JPG_SUPPORT)
- /* Format-dependent operations for JPG support. */
--jas_image_t *jpg_decode(jas_stream_t *in, const char *optstr);
--int jpg_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int jpg_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *jpg_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int jpg_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int jpg_validate(jas_stream_t *in);
- #endif
-
- #if !defined(EXCLUDE_MIF_SUPPORT)
- /* Format-dependent operations for MIF support. */
--jas_image_t *mif_decode(jas_stream_t *in, const char *optstr);
--int mif_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int mif_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *mif_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int mif_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int mif_validate(jas_stream_t *in);
- #endif
-
- #if !defined(EXCLUDE_PNM_SUPPORT)
- /* Format-dependent operations for PNM support. */
--jas_image_t *pnm_decode(jas_stream_t *in, const char *optstr);
--int pnm_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int pnm_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *pnm_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int pnm_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int pnm_validate(jas_stream_t *in);
- #endif
-
- #if !defined(EXCLUDE_RAS_SUPPORT)
- /* Format-dependent operations for Sun Rasterfile support. */
--jas_image_t *ras_decode(jas_stream_t *in, const char *optstr);
--int ras_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int ras_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *ras_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int ras_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int ras_validate(jas_stream_t *in);
- #endif
-
- #if !defined(EXCLUDE_BMP_SUPPORT)
- /* Format-dependent operations for BMP support. */
--jas_image_t *bmp_decode(jas_stream_t *in, const char *optstr);
--int bmp_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int bmp_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *bmp_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int bmp_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int bmp_validate(jas_stream_t *in);
- #endif
-
- #if !defined(EXCLUDE_JP2_SUPPORT)
- /* Format-dependent operations for JP2 support. */
--jas_image_t *jp2_decode(jas_stream_t *in, const char *optstr);
--int jp2_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int jp2_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *jp2_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int jp2_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int jp2_validate(jas_stream_t *in);
- #endif
-
- #if !defined(EXCLUDE_JPC_SUPPORT)
- /* Format-dependent operations for JPEG-2000 code stream support. */
--jas_image_t *jpc_decode(jas_stream_t *in, const char *optstr);
--int jpc_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int jpc_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *jpc_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int jpc_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int jpc_validate(jas_stream_t *in);
- #endif
-
- #if !defined(EXCLUDE_PGX_SUPPORT)
- /* Format-dependent operations for PGX support. */
--jas_image_t *pgx_decode(jas_stream_t *in, const char *optstr);
--int pgx_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
--int pgx_validate(jas_stream_t *in);
-+JAS_DLLEXPORT jas_image_t *pgx_decode(jas_stream_t *in, const char *optstr);
-+JAS_DLLEXPORT int pgx_encode(jas_image_t *image, jas_stream_t *out, const char *optstr);
-+JAS_DLLEXPORT int pgx_validate(jas_stream_t *in);
- #endif
-
- #ifdef __cplusplus
-diff -Naur jasper-version-2.0.13-orig/src/libjasper/jp2/jp2_cod.h jasper-version-2.0.13/src/libjasper/jp2/jp2_cod.h
---- jasper-version-2.0.13-orig/src/libjasper/jp2/jp2_cod.h 2017-09-11 09:36:23.281414800 +0300
-+++ jasper-version-2.0.13/src/libjasper/jp2/jp2_cod.h 2017-09-11 13:16:28.075347800 +0300
-@@ -296,10 +296,10 @@
- * Box class.
- \******************************************************************************/
-
--jp2_box_t *jp2_box_create(int type);
--void jp2_box_destroy(jp2_box_t *box);
--jp2_box_t *jp2_box_get(jas_stream_t *in);
--int jp2_box_put(jp2_box_t *box, jas_stream_t *out);
-+JAS_DLLEXPORT jp2_box_t *jp2_box_create(int type);
-+JAS_DLLEXPORT void jp2_box_destroy(jp2_box_t *box);
-+JAS_DLLEXPORT jp2_box_t *jp2_box_get(jas_stream_t *in);
-+JAS_DLLEXPORT int jp2_box_put(jp2_box_t *box, jas_stream_t *out);
-
- #define JP2_DTYPETOBPC(dtype) \
- ((JAS_IMAGE_CDT_GETSGND(dtype) << 7) | (JAS_IMAGE_CDT_GETPREC(dtype) - 1))
-@@ -310,7 +310,7 @@
- #define ICC_CS_YCBCR 0x59436272
- #define ICC_CS_GRAY 0x47524159
-
--jp2_cdefchan_t *jp2_cdef_lookup(jp2_cdef_t *cdef, int channo);
-+JAS_DLLEXPORT jp2_cdefchan_t *jp2_cdef_lookup(jp2_cdef_t *cdef, int channo);
-
-
- #endif
diff --git a/004-jasper-exports.patch b/004-jasper-exports.patch
new file mode 100644
index 000000000000..2f12ae315708
--- /dev/null
+++ b/004-jasper-exports.patch
@@ -0,0 +1,27 @@
+diff -Naur jasper-version-2.0.22-orig/src/libjasper/jp2/jp2_cod.h jasper-version-2.0.22/src/libjasper/jp2/jp2_cod.h
+--- jasper-version-2.0.22-orig/src/libjasper/jp2/jp2_cod.h 2017-09-11 09:36:23.281414800 +0300
++++ jasper-version-2.0.22/src/libjasper/jp2/jp2_cod.h 2017-09-11 13:16:28.075347800 +0300
+@@ -288,10 +288,10 @@
+ * Box class.
+ \******************************************************************************/
+
+-jp2_box_t *jp2_box_create(int type);
+-void jp2_box_destroy(jp2_box_t *box);
+-jp2_box_t *jp2_box_get(jas_stream_t *in);
+-int jp2_box_put(jp2_box_t *box, jas_stream_t *out);
++JAS_DLLEXPORT jp2_box_t *jp2_box_create(int type);
++JAS_DLLEXPORT void jp2_box_destroy(jp2_box_t *box);
++JAS_DLLEXPORT jp2_box_t *jp2_box_get(jas_stream_t *in);
++JAS_DLLEXPORT int jp2_box_put(jp2_box_t *box, jas_stream_t *out);
+
+ JAS_ATTRIBUTE_CONST
+ static inline uint_least8_t JP2_DTYPETOBPC(uint_least8_t dtype)
+@@ -309,7 +309,7 @@
+ #define ICC_CS_YCBCR 0x59436272
+ #define ICC_CS_GRAY 0x47524159
+
+-const jp2_cdefchan_t *jp2_cdef_lookup(jp2_cdef_t *cdef, int channo);
++JAS_DLLEXPORT const jp2_cdefchan_t *jp2_cdef_lookup(jp2_cdef_t *cdef, int channo);
+
+
+ #endif
diff --git a/PKGBUILD b/PKGBUILD
index f7e8f00c2d6e..18c09aa3f764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-jasper
-pkgver=2.0.16
+pkgver=2.0.23
pkgrel=1
pkgdesc="A software-based implementation of the codec specified in the emerging JPEG-2000 Part-1 standard (mingw-w64)"
arch=(any)
-url="http://www.ece.uvic.ca/~mdadams/jasper"
+url='https://www.ece.uvic.ca/~mdadams/jasper/'
license=("custom:JasPer2.0")
makedepends=('mingw-w64-cmake')
depends=('mingw-w64-libjpeg-turbo')
@@ -12,13 +12,13 @@ options=(staticlibs !strip !buildflags)
source=("https://github.com/mdadams/jasper/archive/version-${pkgver}.tar.gz"
"jasper-1.900.1-fix-filename-buffer-overflow.patch"
"001-mingw-cmake.patch"
- "002-add-more-exports.patch"
+ "004-jasper-exports.patch"
"jasper-static-fix.patch")
-sha256sums=('f1d8b90f231184d99968f361884e2054a1714fdbbd9944ba1ae4ebdcc9bbfdb1'
+sha256sums=('20facc904bd9d38c20e0c090b1be3ae02ae5b2703b803013be2ecad586a18927'
'f51377e9b3e4faaa6b17b2d5fcf6f6d94fe2916a65dc9c78b5a99b891f5726dc'
'2b261c9b40b973d0d11f7b2b6842b36aee45657cbd5e0780fa73cb184f570b65'
- '48c60686d7e3c737f282513d78f8e6263e5f555d71de625002e3fba1c38c8850'
+ 'aef39fbaf65c0453a785eb563253f2bb66806ddbebcd836b8bd8dce67c7059eb'
'3102b4175d714df84a63b8ebf3c0f346fc09a0a784a560917994f6074d6b1697')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -27,7 +27,7 @@ prepare() {
cd "$srcdir/jasper-version-$pkgver"
patch -p1 -i "${srcdir}"/jasper-1.900.1-fix-filename-buffer-overflow.patch
patch -p1 -i "${srcdir}"/001-mingw-cmake.patch
- patch -p1 -i "${srcdir}"/002-add-more-exports.patch
+ patch -p1 -i "${srcdir}"/004-jasper-exports.patch
patch -p1 -i "${srcdir}"/jasper-static-fix.patch
}
@@ -63,6 +63,9 @@ package() {
rm -r "$pkgdir/usr/${_arch}/share"
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ if [[ $NO_EXECUTABLES ]]; then
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete
+ fi
done
}