summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-03-13 10:51:09 +0100
committerMichel Zou2016-03-13 10:51:09 +0100
commit6bef062cba9a185f9fe43e1b4fe00084404ccf08 (patch)
treec8dc5f52ae4edf00bd57c1f0355af42447631e46
downloadaur-6bef062cba9a185f9fe43e1b4fe00084404ccf08.tar.gz
inital import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dd95e6fe678
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 09:51:08 UTC 2016
+pkgbase = mingw-w64-jsoncpp
+ pkgdesc = A C++ library for interacting with JSON (mingw-w64)
+ pkgver = 1.6.5
+ pkgrel = 1
+ url = https://github.com/open-source-parsers/jsoncpp
+ arch = any
+ license = MIT
+ license = custom:Public_Domain
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = jsoncpp-1.6.5.tar.gz::https://github.com/open-source-parsers/jsoncpp/archive/1.6.5.tar.gz
+ md5sums = 2bb16bb8d2b867acbdd71d1855062a89
+
+pkgname = mingw-w64-jsoncpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56c34ccafe96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=mingw-w64-jsoncpp
+pkgver=1.6.5
+pkgrel=1
+pkgdesc='A C++ library for interacting with JSON (mingw-w64)'
+url='https://github.com/open-source-parsers/jsoncpp'
+license=('MIT' 'custom:Public_Domain')
+arch=('any')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-cmake')
+options=('!strip' '!buildflags' 'staticlibs')
+source=(jsoncpp-${pkgver}.tar.gz::"https://github.com/open-source-parsers/jsoncpp/archive/${pkgver}.tar.gz")
+md5sums=('2bb16bb8d2b867acbdd71d1855062a89')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd jsoncpp-${pkgver}
+ for _arch in $_architectures; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DJSONCPP_WITH_TESTS=OFF \
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in $_architectures; do
+ cd "$srcdir/jsoncpp-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
+