summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2015-06-15 17:26:57 -0700
committerSchala2015-06-15 17:26:57 -0700
commit761b5214e5b2f41d5268ae7887ae15f7142bc746 (patch)
tree691c4cfef805a5a441a1ee54a595df630241ecad
downloadaur-761b5214e5b2f41d5268ae7887ae15f7142bc746.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD39
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66f8e0008a28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-kcodecs
+ pkgdesc = Provide a collection of methods to manipulate strings using various encodings (mingw-w64)
+ pkgver = 5.11.0
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/kcodecs
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-extra-cmake-modules
+ depends = mingw-w64-qt5-base
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://download.kde.org/stable/frameworks/5.11/kcodecs-5.11.0.tar.xz
+ md5sums = 5cfbb6836dbbdeddef9d889cf824f1bd
+
+pkgname = mingw-w64-kcodecs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f46de972b6fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..018ddbb494c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=mingw-w64-kcodecs
+pkgver=5.11.0
+pkgrel=1
+arch=(any)
+pkgdesc="Provide a collection of methods to manipulate strings using various encodings (mingw-w64)"
+license=("LGPL")
+depends=(mingw-w64-qt5-base)
+makedepends=(mingw-w64-cmake mingw-w64-extra-cmake-modules)
+options=(staticlibs !strip !buildflags)
+url="https://projects.kde.org/projects/frameworks/kcodecs"
+source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-${pkgver}.tar.xz")
+md5sums=('5cfbb6836dbbdeddef9d889cf824f1bd')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd kcodecs-$pkgver
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir "build-${_arch}" && pushd "build-${_arch}"
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -rf "$pkgdir/usr/${_arch}/share"
+ done
+}