summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-12-30 16:02:41 -0800
committerSchala2016-12-30 16:02:41 -0800
commita174724d79602b0f287bd5e876e4b0887c9af65e (patch)
tree9aa159476d8af350e631c5fae87fd69e25278031
parentdb9983778fb03fc71b3e458b71226684cab7b34c (diff)
downloadaur-a174724d79602b0f287bd5e876e4b0887c9af65e.tar.gz
5.29
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54727292a463..7db8453d4d1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Apr 19 14:05:21 UTC 2016
+# Sat Dec 31 00:02:29 UTC 2016
pkgbase = mingw-w64-kcoreaddons
pkgdesc = Addons to QtCore (mingw-w64)
- pkgver = 5.21.0
- pkgrel = 2
+ pkgver = 5.29.0
+ pkgrel = 1
url = https://projects.kde.org/projects/frameworks/kcoreaddons
arch = any
groups = mingw-w64-kf5
license = LGPL
- makedepends = mingw-w64-extra-cmake-modules=5.21.0
+ makedepends = mingw-w64-extra-cmake-modules=5.29.0
makedepends = mingw-w64-qt5-tools
depends = mingw-w64-qt5-base
depends = shared-mime-info
@@ -16,8 +16,8 @@ pkgbase = mingw-w64-kcoreaddons
options = staticlibs
options = !strip
options = !buildflags
- source = http://download.kde.org/stable/frameworks/5.21/kcoreaddons-5.21.0.tar.xz
- md5sums = f3823cbe368197f64ec692e3e6688865
+ source = http://download.kde.org/stable/frameworks/5.29/kcoreaddons-5.29.0.tar.xz
+ md5sums = f0a3330cd34e3269cd65b65bb465b02c
pkgname = mingw-w64-kcoreaddons
diff --git a/.gitignore b/.gitignore
index f46de972b6fc..1a0ccd4e2816 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg/
src/
+*.log
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index a49dc2fc15b8..1ed8348179c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-kcoreaddons
-pkgver=5.21.0
-pkgrel=2
+pkgver=5.29.0
+pkgrel=1
arch=(any)
pkgdesc="Addons to QtCore (mingw-w64)"
license=("LGPL")
@@ -11,7 +11,7 @@ options=(staticlibs !strip !buildflags)
optdepends=("kcoreaddons: needed for desktopjson.exe workaround symlink")
url="https://projects.kde.org/projects/frameworks/kcoreaddons"
source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/kcoreaddons-${pkgver}.tar.xz")
-md5sums=('f3823cbe368197f64ec692e3e6688865')
+md5sums=('f0a3330cd34e3269cd65b65bb465b02c')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -41,10 +41,10 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ rm "$pkgdir/usr/${_arch}/bin/desktoptojson.exe"
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
ln -s "/usr/bin/desktoptojson" "$pkgdir/usr/${_arch}/bin/desktoptojson.exe"
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- rm -rf "$pkgdir/usr/${_arch}/share"
done
}