summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2015-06-15 17:42:52 -0700
committerSchala2015-06-15 17:42:52 -0700
commitdb37fd935a97c1e8e7c5f70849379a96bc2bf8d6 (patch)
tree7010d7e7dcbf25888dad8aa336b8c69b5da55e85
downloadaur-db37fd935a97c1e8e7c5f70849379a96bc2bf8d6.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD47
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a0dd761cb76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-kcoreaddons
+ pkgdesc = Addons to QtCore (mingw-w64)
+ pkgver = 5.11.0
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/kcoreaddons
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-extra-cmake-modules
+ depends = mingw-w64-qt5-base
+ depends = shared-mime-info
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://download.kde.org/stable/frameworks/5.11/kcoreaddons-5.11.0.tar.xz
+ md5sums = 1d17806d243683ac89c95352f82b0da3
+
+pkgname = mingw-w64-kcoreaddons
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f46de972b6fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ad27ca5b79f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=mingw-w64-kcoreaddons
+pkgver=5.11.0
+pkgrel=1
+arch=(any)
+pkgdesc="Addons to QtCore (mingw-w64)"
+license=("LGPL")
+depends=(mingw-w64-qt5-base shared-mime-info)
+makedepends=(mingw-w64-cmake mingw-w64-extra-cmake-modules)
+options=(staticlibs !strip !buildflags)
+url="https://projects.kde.org/projects/frameworks/kcoreaddons"
+source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/kcoreaddons-${pkgver}.tar.xz")
+md5sums=('1d17806d243683ac89c95352f82b0da3')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd kcoreaddons-$pkgver
+ find . -type f -exec sed -i "s,LM.h,lm.h,g" {} \;
+ find . -type f -exec sed -i "s,Userenv.h,userenv.h,g" {} \;
+ find . -type f -exec sed -i "s,Shlobj.h,shlobj.h,g" {} \;
+}
+
+build() {
+ cd kcoreaddons-$pkgver
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir "build-${_arch}" && pushd "build-${_arch}"
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -rf "$pkgdir/usr/${_arch}/share"
+ done
+}