summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-04-19 17:03:28 -0700
committerBuildTools2016-04-19 17:03:28 -0700
commitac342ea079dffc1c0d44100e5218fabb24211081 (patch)
tree1acf0d91b8c8a43895a8897258926ee318cec04b
downloadaur-ac342ea079dffc1c0d44100e5218fabb24211081.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD41
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f807a0a7a778
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Apr 20 00:02:47 UTC 2016
+pkgbase = mingw-w64-kdbusaddons
+ pkgdesc = Addons to QtDBus (mingw-w64)
+ pkgver = 5.21.0
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/kdbusaddons
+ arch = any
+ groups = mingw-w64-kf5
+ license = LGPL
+ makedepends = mingw-w64-extra-cmake-modules
+ makedepends = mingw-w64-qt5-tools
+ depends = mingw-w64-qt5-winextras
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://download.kde.org/stable/frameworks/5.21/kdbusaddons-5.21.0.tar.xz
+ md5sums = 9f7719be3da4cf774783cc62ee45ea7b
+
+pkgname = mingw-w64-kdbusaddons
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f46de972b6fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48c7655c492b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=mingw-w64-kdbusaddons
+pkgver=5.21.0
+pkgrel=1
+arch=(any)
+pkgdesc="Addons to QtDBus (mingw-w64)"
+license=("LGPL")
+depends=(mingw-w64-qt5-winextras)
+groups=(mingw-w64-kf5)
+makedepends=(mingw-w64-extra-cmake-modules mingw-w64-qt5-tools)
+options=(staticlibs !strip !buildflags)
+url="https://projects.kde.org/projects/frameworks/kdbusaddons"
+source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-${pkgver}.tar.xz")
+md5sums=('9f7719be3da4cf774783cc62ee45ea7b')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd kdbusaddons-$pkgver
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir "build-${_arch}" && pushd "build-${_arch}"
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -rf "$pkgdir/usr/${_arch}/share"
+ done
+}