summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-02-23 12:09:53 +0100
committerNicola Murino2020-02-23 12:09:53 +0100
commit228a24ca54a510e73c0e3a80483ebee9edc8d871 (patch)
treea24943c09777d41fdba5a06ede4dcc706ced7a69
parenta9fd21c2e3641d3a4c163a19760026053902dd7b (diff)
downloadaur-228a24ca54a510e73c0e3a80483ebee9edc8d871.tar.gz
Update to 1.9.0-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2458b695d8cf..7ef4e833d6b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-kdsoap
pkgdesc = Qt-based client-side and server-side SOAP component (mingw-w64)
- pkgver = 1.8.0
+ pkgver = 1.9.0
pkgrel = 1
url = https://github.com/KDAB/KDSoap
arch = any
@@ -8,14 +8,15 @@ pkgbase = mingw-w64-kdsoap
license = LGPL
license = custom
makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-wine
depends = mingw-w64-qt5-base
options = !buildflags
options = staticlibs
options = !strip
- source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.8.0/kdsoap-1.8.0.tar.gz
- source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.8.0/kdsoap-1.8.0.tar.gz.asc
+ source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.9.0/kdsoap-1.9.0.tar.gz
+ source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.9.0/kdsoap-1.9.0.tar.gz.asc
validpgpkeys = E86C000370B1B9E2A9191AD53DBFB6882C9358FB
- sha256sums = e73fbaf57f01a6d45f8f0530861a8f528bf0216633c2c70617cec4434237e742
+ sha256sums = e3b9626d5cb08f41a709fa35031ce17bfdd075b7387baf14ecf8a9ca10994828
sha256sums = SKIP
pkgname = mingw-w64-kdsoap
diff --git a/PKGBUILD b/PKGBUILD
index ebef501a1a5b..ce404285b66a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname="mingw-w64-kdsoap"
-pkgver=1.8.0
+pkgver=1.9.0
pkgrel=1
pkgdesc="Qt-based client-side and server-side SOAP component (mingw-w64)"
arch=('any')
@@ -10,23 +10,17 @@ license=('GPL3' 'LGPL' 'custom')
url='https://github.com/KDAB/KDSoap'
options=('!buildflags' 'staticlibs' '!strip')
depends=('mingw-w64-qt5-base')
-makedepends=('mingw-w64-cmake')
+makedepends=('mingw-w64-cmake' 'mingw-w64-wine')
source=("https://github.com/KDAB/KDSoap/releases/download/kdsoap-${pkgver}/kdsoap-${pkgver}.tar.gz"{,.asc})
-sha256sums=('e73fbaf57f01a6d45f8f0530861a8f528bf0216633c2c70617cec4434237e742'
+sha256sums=('e3b9626d5cb08f41a709fa35031ce17bfdd075b7387baf14ecf8a9ca10994828'
'SKIP')
validpgpkeys=(E86C000370B1B9E2A9191AD53DBFB6882C9358FB) # KDAB Products (user for KDAB products) <info@kdab.com>
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "${srcdir}/kdsoap-${pkgver}"
- sed -i 's/add_subdirectory(examples)//g' CMakeLists.txt
-}
-
build() {
- unset LDFLAGS
cd "$srcdir/kdsoap-$pkgver/"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}