summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-12-27 11:36:56 +0100
committerNicola Murino2020-12-27 11:36:56 +0100
commit2a41567cd541f5071e0880e4d0ae125fb29e2d80 (patch)
tree7fd066d9e5cbc8a24ec3cae26e2f2b1f6534224d
parent228a24ca54a510e73c0e3a80483ebee9edc8d871 (diff)
downloadaur-2a41567cd541f5071e0880e4d0ae125fb29e2d80.tar.gz
Update to 1.10.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ef4e833d6b5..9979a8804069 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-kdsoap
pkgdesc = Qt-based client-side and server-side SOAP component (mingw-w64)
- pkgver = 1.9.0
+ pkgver = 1.10.0
pkgrel = 1
url = https://github.com/KDAB/KDSoap
arch = any
@@ -13,10 +13,10 @@ pkgbase = mingw-w64-kdsoap
options = !buildflags
options = staticlibs
options = !strip
- source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.9.0/kdsoap-1.9.0.tar.gz
- source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.9.0/kdsoap-1.9.0.tar.gz.asc
+ source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.10.0/kdsoap-1.10.0.tar.gz
+ source = https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.10.0/kdsoap-1.10.0.tar.gz.asc
validpgpkeys = E86C000370B1B9E2A9191AD53DBFB6882C9358FB
- sha256sums = e3b9626d5cb08f41a709fa35031ce17bfdd075b7387baf14ecf8a9ca10994828
+ sha256sums = 0c606ecc434466dbadb2829820ca163af60cc7ca226f553b5d4032196737338f
sha256sums = SKIP
pkgname = mingw-w64-kdsoap
diff --git a/PKGBUILD b/PKGBUILD
index ce404285b66a..0713e36b56cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname="mingw-w64-kdsoap"
-pkgver=1.9.0
+pkgver=1.10.0
pkgrel=1
pkgdesc="Qt-based client-side and server-side SOAP component (mingw-w64)"
arch=('any')
@@ -13,7 +13,7 @@ depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-cmake' 'mingw-w64-wine')
source=("https://github.com/KDAB/KDSoap/releases/download/kdsoap-${pkgver}/kdsoap-${pkgver}.tar.gz"{,.asc})
-sha256sums=('e3b9626d5cb08f41a709fa35031ce17bfdd075b7387baf14ecf8a9ca10994828'
+sha256sums=('0c606ecc434466dbadb2829820ca163af60cc7ca226f553b5d4032196737338f'
'SKIP')
validpgpkeys=(E86C000370B1B9E2A9191AD53DBFB6882C9358FB) # KDAB Products (user for KDAB products) <info@kdab.com>
@@ -37,6 +37,9 @@ package() {
find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ if [[ $NO_EXECUTABLES ]]; then
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete
+ fi
done
}