summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-09-11 23:40:58 -0700
committerBuildTools2015-09-11 23:40:58 -0700
commit5019047ea52f24bf30dc83bf6e8d4fbd6712dd8f (patch)
treefcbfffaa31f484edfa3555c65c44f72e2afa75f3
downloadaur-5019047ea52f24bf30dc83bf6e8d4fbd6712dd8f.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5e22d2e01d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-kunitconversion
+ pkgdesc = Support for unit conversion (mingw-w64)
+ pkgver = 5.13.0
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/kunitconversion
+ arch = any
+ groups = mingw-w64-kf5
+ license = LGPL
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-extra-cmake-modules
+ makedepends = python
+ depends = mingw-w64-ki18n
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://download.kde.org/stable/frameworks/5.13/kunitconversion-5.13.0.tar.xz
+ md5sums = 8505e76f2e45febe316ab83ee31ece3f
+
+pkgname = mingw-w64-kunitconversion
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f46de972b6fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3c8f7e1aa755
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=mingw-w64-kunitconversion
+pkgver=5.13.0
+pkgrel=1
+arch=(any)
+pkgdesc="Support for unit conversion (mingw-w64)"
+license=("LGPL")
+depends=(mingw-w64-ki18n)
+groups=(mingw-w64-kf5)
+makedepends=(mingw-w64-cmake mingw-w64-extra-cmake-modules python)
+options=(staticlibs !strip !buildflags)
+url="https://projects.kde.org/projects/frameworks/kunitconversion"
+source=("http://download.kde.org/stable/frameworks/${pkgver%.*}/kunitconversion-${pkgver}.tar.xz")
+md5sums=('8505e76f2e45febe316ab83ee31ece3f')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd kunitconversion-$pkgver
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir "build-${_arch}" && pushd "build-${_arch}"
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname#mingw-w64-}-$pkgver/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -rf "$pkgdir/usr/${_arch}/share"
+ done
+}