summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2020-04-12 09:32:06 +0200
committerkfg2020-04-12 09:32:06 +0200
commit97e5ae09e1ab3a9828d5eab1c8e70375d91619bc (patch)
tree8beceb984fd4fb56258935257aa248e0ea288524
parent62b949e25f99237bbf564996a589176863bd0f72 (diff)
downloadaur-97e5ae09e1ab3a9828d5eab1c8e70375d91619bc.tar.gz
source correct cflags and ldflags from mingw-env
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f721f29e6d49..090620dd0280 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Tue Feb 13 10:26:26 UTC 2018
pkgbase = mingw-w64-l-smash
pkgdesc = MP4 muxer and other tools
pkgver = 2.14.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/l-smash/l-smash
arch = any
license = custom
makedepends = mingw-w64-gcc
makedepends = fakeroot
+ makedepends = mingw-w64-environment
depends = mingw-w64-crt
options = !strip
options = !buildflags
diff --git a/PKGBUILD b/PKGBUILD
index c919f59bd6f2..17a8c57821a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgname=mingw-w64-l-smash
pkgver=2.14.5
-pkgrel=1
+pkgrel=2
pkgdesc='MP4 muxer and other tools'
arch=('any')
url='https://github.com/l-smash/l-smash'
license=('custom')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-gcc' 'fakeroot')
+makedepends=('mingw-w64-gcc' 'fakeroot' "mingw-w64-environment")
options=(!strip !buildflags staticlibs)
source=("l-smash-${pkgver}.tar.gz::https://github.com/l-smash/l-smash/archive/v${pkgver}.tar.gz")
sha256sums=('e6f7c31de684f4b89ee27e5cd6262bf96f2a5b117ba938d2d606cf6220f05935')
@@ -21,10 +21,7 @@ build() {
for _arch in ${_architectures}; do
mkdir -p ${srcdir}/l-smash-${pkgver}/build-${_arch} && cd ${srcdir}/l-smash-${pkgver}/build-${_arch}
- mingw_c_flags="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
- LDFLAGS=""
- export CFLAGS="$mingw_c_flags $CFLAGS"
- export CXXFLAGS="$mingw_c_flags $CXXFLAGS"
+ source mingw-env ${_arch}
${srcdir}/l-smash-${pkgver}/configure \
--prefix=/usr/${_arch} \
@@ -41,6 +38,8 @@ package() {
for _arch in ${_architectures}; do
cd ${srcdir}/l-smash-${pkgver}/build-${_arch}
+ source mingw-env ${_arch}
+
make DESTDIR="${pkgdir}" install
#install -dm 755 "${pkgdir}"/usr/share/licenses/l-smash