summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2016-03-06 19:42:19 +0100
committerkfg2016-03-06 19:42:19 +0100
commitf589c75b076932923fa3ed93938f9a8a172139c5 (patch)
treeb98c3275eac8e92549e4a93e9d86cb7205b82f92
downloadaur-f589c75b076932923fa3ed93938f9a8a172139c5.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61e58638c554
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Mar 6 18:41:50 UTC 2016
+pkgbase = mingw-w64-l-smash
+ pkgdesc = MP4 muxer and other tools
+ pkgver = 2.9.1
+ pkgrel = 1
+ url = https://github.com/l-smash/l-smash
+ arch = any
+ license = custom
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = l-smash-2.9.1.tar.gz::https://github.com/l-smash/l-smash/archive/v2.9.1.tar.gz
+ sha256sums = 17f24fc8bffba753f8c628f1732fc3581b80362341274747ef6fb96af1cac45c
+
+pkgname = mingw-w64-l-smash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..378f239bf67b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id: PKGBUILD 244452 2015-08-20 20:37:01Z alucryd $
+# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=mingw-w64-l-smash
+pkgver=2.9.1
+pkgrel=1
+pkgdesc='MP4 muxer and other tools'
+arch=('any')
+url='https://github.com/l-smash/l-smash'
+license=('custom')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-gcc')
+options=(!strip !buildflags staticlibs)
+source=("l-smash-${pkgver}.tar.gz::https://github.com/l-smash/l-smash/archive/v${pkgver}.tar.gz")
+sha256sums=('17f24fc8bffba753f8c628f1732fc3581b80362341274747ef6fb96af1cac45c')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p ${srcdir}/build-${_arch} && cd ${srcdir}/build-${_arch}
+
+ ${srcdir}/l-smash-${pkgver}/configure \
+ --prefix=/usr/${_arch} \
+ --cross-prefix=${_arch}- \
+ --enable-shared
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd ${srcdir}/build-${_arch}
+
+ make DESTDIR="${pkgdir}" install
+
+ #install -dm 755 "${pkgdir}"/usr/share/licenses/l-smash
+ #install -m 644 LICENSE "${pkgdir}"/usr/share/licenses/l-smash/
+ ${_arch}-strip --strip-unneeded ${pkgdir}/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
+ rm ${pkgdir}/usr/${_arch}/bin/*.exe
+ done
+}
+
+# vim: ts=2 sw=2 et: