summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2019-04-24 13:20:00 +0100
committerAlexandros Theodotou2019-04-24 13:20:50 +0100
commit841ebb1781058b747d531298811b54c854655633 (patch)
tree4b1d599a40ed22ea7550808e3af9c8715fe9afc9
downloadaur-841ebb1781058b747d531298811b54c854655633.tar.gz
initial push
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD56
-rw-r--r--fix-memleak-in-plugin-scanning.patch11
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..424caaca96e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mingw-w64-ladspa
+ pkgdesc = Linux Audio Developer's Simple Plugin API (LADSPA)
+ pkgver = 1.15
+ pkgrel = 1
+ url = https://www.ladspa.org/
+ arch = x86_64
+ license = LGPL
+ depends = gcc-libs
+ source = https://ladspa.org/download/ladspa_sdk_1.15.tgz
+ source = fix-memleak-in-plugin-scanning.patch
+ sha512sums = a521622e23d988284244003e4ccfc3b42f6ddc7944cb00e7949b87e09d7f39a0cbb64b6d8b5a5af0a5ccf7179f88815416a88f02d3912957167e54b74accfc65
+ sha512sums = e80a575e6afe42f9d0ac1234a7832a29fb9362c7ab7b2d6b14cc3e6da6a9ba67af886cf09f1c0b78c161205084f705049fb4dc22fe2795efaeb7d94da90dc93e
+
+pkgname = mingw-w64-ladspa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b72dfe4ca86a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Alexandros Theodotou <alex@zrythm.org>
+# `ladspa` Maintainer: damir <damir@archlinux.org>
+# Contributor: David Runge <dave@sleepmap.de>
+
+_pkgbase=ladspa
+pkgname=mingw-w64-ladspa
+pkgver=1.15
+pkgrel=1
+pkgdesc="Linux Audio Developer's Simple Plugin API (LADSPA)"
+arch=('x86_64')
+license=('LGPL')
+url="https://www.ladspa.org/"
+depends=('gcc-libs')
+source=("https://ladspa.org/download/ladspa_sdk_${pkgver}.tgz"
+ 'fix-memleak-in-plugin-scanning.patch')
+sha512sums=('a521622e23d988284244003e4ccfc3b42f6ddc7944cb00e7949b87e09d7f39a0cbb64b6d8b5a5af0a5ccf7179f88815416a88f02d3912957167e54b74accfc65'
+ 'e80a575e6afe42f9d0ac1234a7832a29fb9362c7ab7b2d6b14cc3e6da6a9ba67af886cf09f1c0b78c161205084f705049fb4dc22fe2795efaeb7d94da90dc93e')
+
+prepare() {
+ mv -v ${pkgname}_sdk_${pkgver} ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
+ patch -Np0 -i "../fix-memleak-in-plugin-scanning.patch"
+ # add LDFLAGS for full RELRO
+ sed -e "s#-O2#${CFLAGS} ${LDFLAGS}#" -i src/Makefile
+}
+
+build() {
+ cd "${srcdir}"
+
+ for _arch in "${_architectures[@]}"; do
+ rm -rf build-${_arch}
+ cp -r "${_pkgbase}-${pkgver}" build-${_arch}
+ pushd build-${_arch}/src
+
+ make targets
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}"
+
+ for _arch in "${_architectures[@]}"; do
+ pushd "build-${_arch}/src"
+
+ make INSTALL_PLUGINS_DIR="${pkgdir}/usr/$_arch/lib/ladspa/" \
+ INSTALL_INCLUDE_DIR="${pkgdir}/usr/$_arch/include/" \
+ INSTALL_BINARY_DIR="${pkgdir}/usr/$_arch/bin/" install
+ install -vDm 644 ../doc/*.{html,txt} -t "${pkgdir}/usr/$_arch/share/doc/${_pkgbase}"
+
+ popd
+ done
+}
+
+
diff --git a/fix-memleak-in-plugin-scanning.patch b/fix-memleak-in-plugin-scanning.patch
new file mode 100644
index 000000000000..76cb2e864015
--- /dev/null
+++ b/fix-memleak-in-plugin-scanning.patch
@@ -0,0 +1,11 @@
+--- src/search.c.orig 2008-11-07 00:38:18.000000000 +0100
++++ src/search.c 2008-11-07 00:50:51.000000000 +0100
+@@ -83,6 +83,8 @@
+ dlclose(pcFilename);
+ free(pcFilename);
+ }
++ } else {
++ free(pcFilename);
+ }
+ }
+ }