summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqwertzdenek2015-06-14 13:23:18 +0200
committerqwertzdenek2015-06-14 13:23:18 +0200
commit3aef61c705c97ad0e300b31e8037f036d4a886de (patch)
treef6971a6cd7fa8bf989b39b0fd724a58e0fb6f588
downloadaur-mingw-w64-lapackpp.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD55
-rw-r--r--package.patch29
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f6fdc0ee21a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mingw-w64-lapackpp
+ pkgdesc = C++ library for high performance linear algebra computations. (mingw-w64)
+ pkgver = 2.5.4
+ pkgrel = 0
+ url = http://lapackpp.sourceforge.net/
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = automake-1.11
+ depends = mingw-w64-lapack
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://sourceforge.net/projects/lapackpp/files/lapackpp-2.5.4.tar.gz
+ source = package.patch
+ sha256sums = 776c4b2b09412479e1559bcec08a71cfbb162dfbe3f6fbd4da52cef3039cddbc
+ sha256sums = 5196f3de40ed7a5a06d043b1987b89a208141d7a2c7571f930c3e9041d5e15de
+
+pkgname = mingw-w64-lapackpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3b0d5234d39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+pkgname=mingw-w64-lapackpp
+pkgver=2.5.4
+pkgrel=0
+pkgdesc="C++ library for high performance linear algebra computations. (mingw-w64)"
+arch=('any')
+url="http://lapackpp.sourceforge.net/"
+license=('LGPL')
+depends=('mingw-w64-lapack')
+makedepends=('mingw-w64-gcc' 'automake-1.11')
+options=('!strip' '!buildflags' 'staticlibs')
+source=(http://sourceforge.net/projects/lapackpp/files/lapackpp-$pkgver.tar.gz package.patch)
+sha256sums=('776c4b2b09412479e1559bcec08a71cfbb162dfbe3f6fbd4da52cef3039cddbc'
+ '5196f3de40ed7a5a06d043b1987b89a208141d7a2c7571f930c3e9041d5e15de')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+
+build() {
+ cd "$srcdir/lapackpp-$pkgver"
+
+ # clean MSVC includes
+ patch -p1 -i $srcdir/package.patch
+
+ aclocal-1.11
+ unset CFLAGS
+ unset LDFLAGS
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch}
+ cd build-${_arch}
+ export PKG_CONFIG_PATH="/usr/${_arch}/lib/pkgconfig"
+
+ ../configure \
+ --prefix="/usr/${_arch}" \
+ --target="${_arch}" \
+ --host="${_arch}"
+
+ # replace dnl macro
+ sed -i 's/dnl/#/g' ../configure.ac
+
+ make
+
+ cd ..
+ done
+}
+
+package() {
+ cd lapackpp-$pkgver
+
+ for _arch in ${_architectures}; do
+ cd build-${_arch}
+ make DESTDIR="$pkgdir" install
+ cd ..
+ done
+}
+
diff --git a/package.patch b/package.patch
new file mode 100644
index 000000000000..d417ed86ec02
--- /dev/null
+++ b/package.patch
@@ -0,0 +1,29 @@
+diff -aur package.pristine/src/Makefile.am package.new/src/Makefile.am
+--- package.pristine/src/Makefile.am 2014-05-23 18:15:48.536268233 +0200
++++ package.new/src/Makefile.am 2014-05-23 18:17:59.556444065 +0200
+@@ -21,14 +21,6 @@
+ $(top_builddir)/matrix/src/liblamatrixpp.la \
+ $(top_builddir)/blaspp/src/libblaspp.la
+
+-# if IS_WINDOWS
+-if IS_WINDOWS
+-# Dependencies for Windows
+-liblapackpp_la_DEPENDENCIES += ressource.o
+-ressource_ldflags = -Wl,ressource.o -Wl,-export-all-symbols
+-endif
+-# IS_WINDOWS
+-
+ # Linker flags
+ liblapackpp_la_LDFLAGS = -no-undefined \
+ -version-info \
+@@ -40,9 +32,3 @@
+ $(top_builddir)/blaspp/src/libblaspp.la \
+ $(LAPACK_LIBS) $(BLAS_LIBS) $(FLIBS)
+
+-# ressource must be packages here because MSVC won't run configure
+-EXTRA_DIST = ressource.rc
+-
+-ressource.o: ressource.rc
+- $(RC) -i $< -o $@
+-
+