summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2019-05-21 14:27:10 +0800
committerpingplug2019-05-21 14:27:10 +0800
commitc3b506cea496807bf970eda908282295461289bc (patch)
tree71662a35761c3e1a2b161aaa333988931feb5aff
parent61e30edcfc283ec2424b1fdc30bda27048b31bf2 (diff)
downloadaur-c3b506cea496807bf970eda908282295461289bc.tar.gz
update email
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD36
3 files changed, 29 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f85bfc58d4d..bf94e31f75f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,8 @@ pkgbase = mingw-w64-lcms2
makedepends = mingw-w64-configure
depends = mingw-w64-crt
depends = mingw-w64-libtiff
- options = staticlibs
options = !strip
+ options = staticlibs
options = !buildflags
source = https://downloads.sourceforge.net/sourceforge/lcms/lcms2-2.9.tar.gz
source = 0002-need-jconfig-before-jmoreconfig.mingw.patch
diff --git a/.gitignore b/.gitignore
index 49c4674d6625..97589fb4de69 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
-pkg/
-src/
-*.gz
-*.log
-*.tar
-*.xz
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.install
+!*.patch
+!*.diff
diff --git a/PKGBUILD b/PKGBUILD
index 165fa5efe6e0..c5191eb027c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
+# Maintainer: pingplug < aur at pingplug dot me >
+# Contributor: Schala Zeal < schalaalexiazeal at gmail dot com >
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
pkgname=mingw-w64-lcms2
pkgver=2.9
pkgrel=1
pkgdesc="Small-footprint color management engine, version 2 (mingw-w64)"
-arch=(any)
+arch=('any')
url="http://www.littlecms.com"
-license=("MIT")
-makedepends=(mingw-w64-configure)
-depends=(mingw-w64-crt mingw-w64-libtiff)
-options=(staticlibs !strip !buildflags)
+license=('MIT')
+depends=('mingw-w64-crt'
+ 'mingw-w64-libtiff')
+makedepends=('mingw-w64-configure')
+options=('!strip' 'staticlibs' '!buildflags')
source=("https://downloads.sourceforge.net/sourceforge/lcms/lcms2-${pkgver}.tar.gz"
-"0002-need-jconfig-before-jmoreconfig.mingw.patch")
+ "0002-need-jconfig-before-jmoreconfig.mingw.patch")
sha256sums=('48c6fdf98396fa245ed86e622028caf49b96fa22f3e5734f853f806fbc8e7d20'
'3e85375a6b38de36e19fa7b4415b8c86aff492c0ef625932bec073d45e944339')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-
prepare() {
- cd lcms2-$pkgver
- patch -p1 -i ${srcdir}/0002-need-jconfig-before-jmoreconfig.mingw.patch
- autoreconf -fi
+ cd lcms2-${pkgver}
+ patch -p1 -i ${srcdir}/0002-need-jconfig-before-jmoreconfig.mingw.patch
+ autoreconf -fi
}
build() {
@@ -34,9 +38,11 @@ build() {
package() {
for _arch in ${_architectures}; do
cd "${srcdir}/${pkgname#mingw-w64-}-${pkgver}/build-${_arch}"
- make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}
+
+# vim:set ts=2 sw=2 et: