summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-12-11 18:51:34 +0100
committerMichel Zou2019-12-11 18:51:34 +0100
commit6c2334bba27920c49f40afeb96cd5274738bdf4c (patch)
treed9b7f5667a8e7dc2ea4917e8376fc571d46135f4
parent7d4bc6e433b96774cbf8c736474c2922a6f266d0 (diff)
downloadaur-6c2334bba27920c49f40afeb96cd5274738bdf4c.tar.gz
LIBBATCH_PYTHON_WRAPPING=OFF
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28207145594a..1db9fd4ec25e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = mingw-w64-libbatch
arch = any
license = LGPL
makedepends = mingw-w64-cmake
- depends = mingw-w64-python
+ depends = mingw-w64-crt
options = !buildflags
options = !strip
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index df992c59b18e..51a4b4b2b664 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgver=2.4.2
pkgrel=1
pkgdesc="Generic platform for Pre and Post-Processing for numerical simulation - KERNEL Module"
url="http://www.salome-platform.org"
-depends=('mingw-w64-python')
+depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
arch=('any')
@@ -22,7 +22,7 @@ build() {
cd "$srcdir/libbatch-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake-py38 \
+ ${_arch}-cmake -DLIBBATCH_PYTHON_WRAPPING=OFF \
-DPTHREAD_LIBRARY=/usr/${_arch}/lib/libwinpthread.dll.a \
..
make