summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-12-07 19:48:43 +0100
committerMichel Zou2016-12-07 19:48:43 +0100
commit8face12379c5f31167246c6bdf1c3918f1b32a09 (patch)
tree20f4c7a4c4e7e748c1847b15bdfe377fcd4faadd
downloadaur-8face12379c5f31167246c6bdf1c3918f1b32a09.tar.gz
0.9.5
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73add9dcb9b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Dec 7 18:48:43 UTC 2016
+pkgbase = mingw-w64-libcmaes
+ pkgdesc = High performance blackbox stochastic optimization using the CMA-ES algorithm
+ pkgver = 0.9.5
+ pkgrel = 1
+ url = https://github.com/beniz/libcmaes
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-eigen
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/beniz/libcmaes/archive/0.9.5.tar.gz
+ sha256sums = SKIP
+
+pkgname = mingw-w64-libcmaes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..899be99c1d7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgname=mingw-w64-libcmaes
+pkgver=0.9.5
+pkgrel=1
+pkgdesc="High performance blackbox stochastic optimization using the CMA-ES algorithm"
+license=('LGPL')
+arch=('any')
+url="https://github.com/beniz/libcmaes"
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-eigen' 'mingw-w64-configure')
+options=(!strip !buildflags staticlibs)
+source=("https://github.com/beniz/libcmaes/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "$srcdir/libcmaes-$pkgver"
+
+ # AC_CHECK_FILE does not work when cross-compiling
+ sed -i "32,33d" configure.ac
+
+ ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/libcmaes-$pkgver"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ # exports no symbol, so disable shared
+ ${_arch}-configure --with-eigen3-include=/usr/${_arch}/include \
+ --enable-onlylib --disable-shared ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}"/libcmaes-${pkgver}/build-${_arch}
+ make DESTDIR="$pkgdir" install
+# ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}