summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-04-29 22:24:01 -0700
committerSchala2017-04-29 22:24:01 -0700
commit6834e04af141660856f76ba507a83906f0ad7960 (patch)
tree379a5b93aa5828d0e2ca27054fcb8c6d9d2380c9
parentcb3957f4c0689734e083ec6b995d5d5e4716d29c (diff)
downloadaur-6834e04af141660856f76ba507a83906f0ad7960.tar.gz
0.6.12
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2beacb11b32..56567f9b525c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
# Generated by mksrcinfo v8
-# Fri Nov 11 02:43:11 UTC 2016
+# Sun Apr 30 05:23:04 UTC 2017
pkgbase = mingw-w64-libcroco
pkgdesc = GNOME CSS2 parsing and manipulation toolkit (mingw-w64)
- pkgver = 0.6.11
- pkgrel = 2
- url = http://www.gnome.org
+ pkgver = 0.6.12+4+g9ad7287
+ pkgrel = 1
+ url = http://www.gnome.org/browse/libcroco
arch = any
license = LGPL
makedepends = mingw-w64-configure
makedepends = intltool
+ makedepends = git
depends = mingw-w64-glib2
depends = mingw-w64-libxml2
options = staticlibs
options = !strip
options = !buildflags
- source = http://ftp.gnome.org/pub/gnome/sources/libcroco/0.6/libcroco-0.6.11.tar.xz
- sha256sums = 132b528a948586b0dfa05d7e9e059901bca5a3be675b6071a90a90b81ae5a056
+ source = git+https://git.gnome.org/browse/libcroco#commit=9ad72875e9f08e4c519ef63d44cdbd94aa9504f7
+ sha256sums = SKIP
pkgname = mingw-w64-libcroco
diff --git a/.gitignore b/.gitignore
index 436a59477780..fdcb46c3d6db 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
+libcroco/
pkg/
src/
+*.log
*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 860bc9a71e2f..ae620338e777 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,31 @@
pkgname=mingw-w64-libcroco
-pkgver=0.6.11
-pkgrel=2
+pkgver=0.6.12+4+g9ad7287
+pkgrel=1
pkgdesc="GNOME CSS2 parsing and manipulation toolkit (mingw-w64)"
arch=(any)
-url="http://www.gnome.org"
+url="http://www.gnome.org/browse/libcroco"
license=("LGPL")
-makedepends=(mingw-w64-configure intltool)
+makedepends=(mingw-w64-configure intltool git)
depends=(mingw-w64-glib2 mingw-w64-libxml2)
options=(staticlibs !strip !buildflags)
-source=("http://ftp.gnome.org/pub/gnome/sources/libcroco/${pkgver%.*}/libcroco-$pkgver.tar.xz")
-sha256sums=('132b528a948586b0dfa05d7e9e059901bca5a3be675b6071a90a90b81ae5a056')
+_commit=9ad72875e9f08e4c519ef63d44cdbd94aa9504f7 # master
+source=("git+https://git.gnome.org/browse/libcroco#commit=$_commit")
+sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd libcroco
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd libcroco
+ NOCONFIGURE=1 ./autogen.sh
+}
+
build() {
- cd libcroco-$pkgver
+ cd libcroco
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure
@@ -26,7 +37,7 @@ build() {
package() {
mkdir -p "$pkgdir/usr/bin"
for _arch in ${_architectures}; do
- cd "${srcdir}/libcroco-${pkgver}/build-${_arch}"
+ cd "${srcdir}/libcroco/build-${_arch}"
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;